copyright | disclaimer | privacy | contact  
Australia's Leading Computer Emergency Response Team
 
Search this site

 
On this site

 > HOME
 > About AusCERT
 > Membership
 > Contact Us
 > PKI Services
 > Publications
 > Sec. Bulletins
 > Conferences
 > News & Media
 > Services
 > Web Log
 > Site Map
 > Site Help
 > Member login





 

ESB-2014.1568 - [Juniper] Juniper Networks SSL VPN/UAC products: Multiple vulnerabilities

Date: 11 September 2014

Click here for printable version
Click here for PGP verifiable version
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2014.1568
     Multiple vulnerabilities in Juniper Networks SSL VPN/UAC products
                             11 September 2014

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           SA700
                   SA2500
                   SA4000
                   FIPS SA6000
                   MAG2600
                   MAG4610
                   MAG6610
                   MAG6611
                   IC4000
                   IC4500
                   IC6000
                   IC6500
                   FIPS IC6500
Publisher:         Juniper Networks
Operating System:  Juniper
Impact/Access:     Administrator Compromise       -- Existing Account            
                   Cross-site Scripting           -- Remote with User Interaction
                   Provide Misleading Information -- Remote with User Interaction
Resolution:        Patch/Upgrade
CVE Names:         CVE-2014-3824 CVE-2014-3823 CVE-2014-3820
                   CVE-2014-3811  

Original Bulletin: 
   http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10644
   http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10645
   http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10646
   http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10647

Comment: This bulletin contains four (4) Juniper Networks security 
         advisories.

- --------------------------BEGIN INCLUDED TEXT--------------------

2014-09 Security Bulletin: Junos Pulse Secure Access Service (SSL VPN) and 
Junos Pulse Client: User privilege escalation issue in Windows Juniper 
Installer Service (JIS) (CVE-2014-3811)

[JSA10644] Show KB Properties

PRODUCT AFFECTED:

This issue can affect all: SA700, SA2000, SA2500, SA4000, FIPS SA4000, SA4500,
FIPS SA4500, SA6000, FIPS SA6000, SA6500, FIPS SA6500, MAG2600, MAG4610, 
MAG6610, and MAG6611. The affected software releases includes IVE OS 7.1, 7.4
and Windows Junos Pulse 4.0.

PROBLEM:

A privilege escalation issue has been found and corrected in the Juniper 
Installer Service client (Windows platform only) software. This issue could 
allow a non-administrator user to escalate their access to administrator 
privileges on an end-user client system that has the Juniper Installer Service
installed.

Note: This issue only affects the client side. The SSL VPN (server side) is 
not affected.

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

No other Juniper Networks products or platforms are affected by this issue.

This issue has been assigned CVE-2014-3811.

SOLUTION:

Software updates for JIS and Junos Pulse have been released to resolve this 
issue. Fixes for this issue can be found in the following software:

Software updates for JIS Client and Junos Pulse client have been released to 
resolve this issue.

JIS Client version 7.4R6 and higher: For all 7.X JIS client customers we 
recommend upgrading to a 7.4 JIS client that has the fix. 7.4R6 and subsequent
7.4 releases has the fix for this issue. Note that JIS client starting from 
8.0R1 and higher is not impacted by this issue so an upgrade is not required.
You will need to download the JIS client from the system from Maintenance -->
System --> Installers page.

Junos Pulse Client 4.0R6 and higher.

More information about the upgrade process for JIS Client and Pulse can be 
found in the following KB article: http://kb.juniper.net/KB29453

WORKAROUND:

There is no workaround for this issue. An upgrade to a fixed version of 
software is required.

IMPLEMENTATION:

 How to obtain fixed software:

Software release fixes:

1. Junos Pulse are available at: 
http://www.juniper.net/support/downloads/?p=pulse#sw

2. MAG-Series: http://www.juniper.net/support/downloads/mag.html

3. Secure Access: http://www.juniper.net/support/downloads/group/?f=sa

RELATED LINKS:

KB16613: Overview of the Juniper Networks SIRT Monthly Security Bulletin 
Publication Process

KB16765: In which releases are vulnerabilities fixed?

KB16446: Common Vulnerability Scoring System (CVSS) and Juniper's Security 
Advisories

Report a Vulnerability - How to Contact the Juniper Networks Security Incident
Response Team

CVE-2014-3811: User privilege escalation issue in Juniper Installer Service

CVSS SCORE:

7.2 (AV:L/AC:L/Au:N/C:C/I:C/A:C)

RISK LEVEL:

High

RISK ASSESSMENT:

Information for how Juniper Networks uses CVSS can be found at KB 16446 
"Common Vulnerability Scoring System (CVSS) and Juniper's Security 
Advisories."

ACKNOWLEDGEMENTS:

- -------------------------------------------------------------------------------

2014-09 Security Bulletin: Junos Pulse Secure Access Service (SSL VPN) and 
Junos Pulse Access Control Service (UAC): Cross site scripting issue 
(CVE-2014-3820)

[JSA10645] Show KB Properties

PRODUCT AFFECTED:

SA700, SA2500, FIPS SA4000, SA4500, FIPS SA4500, FIPS SA6000, SA6500, FIPS 
SA6500, MAG2600, MAG4610, MAG6610, MAG6611, IC4000, IC4500, IC6000, IC6500, 
and FIPS IC6500. The affected software releases includes IVE OS: 8.0, 7.4, 
7.1, and UAC 5.0, 4.4, and 4.1.

PROBLEM:

A cross site scripting issue has been found in the Juniper Networks SSL 
VPN/UAC products. The problem is a result of incorrect user input validation 
on the SSL VPN/UAC web server. The issue exists within a web page that is only
accessible by an authenticated administrator session.

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

No other Juniper Networks products or platforms are affected by this issue.

This issue has been assigned CVE-2014-3820.

SOLUTION:

The issue is fixed in SA/MAG (IVE OS) releases: 8.0r1, 7.4r8, 7.3r10, and 
7.1r18, and all subsequent releases. UAC OS: 5.0r1, 4.4r8, and 4.1r8, and all
subsequent releases.

KB16765 - "In which releases are vulnerabilities fixed?" describes which 
release vulnerabilities are fixed as per our End of Engineering and End of 
Life support policies.

WORKAROUND:

There is no workaround for this issue. An upgrade to a fixed version of 
software is required.

IMPLEMENTATION:

 How to obtain fixed software:

Software release Service Packages are available at http://support.juniper.net
from the "Download Software" links. Select "Secure Access (SA) / SSL VPN" or 
"MAG Series" and choose the version applicable to your environment and 
installation.

RELATED LINKS:

KB16613: Overview of the Juniper Networks SIRT Monthly Security Bulletin 
Publication Process

KB16765: In which releases are vulnerabilities fixed?

KB16446: Common Vulnerability Scoring System (CVSS) and Juniper's Security 
Advisories

Report a Vulnerability - How to Contact the Juniper Networks Security Incident
Response Team

CVE-2014-3820: Cross site scripting issue

CVSS SCORE:

9.3 (AV:N/AC:M/Au:N/C:C/I:C/A:C)

RISK LEVEL:

Critical

RISK ASSESSMENT:

Successful exploit of this vulnerability could allow an attacker to 
dynamically create arbitrary active content which could be rendered in the 
user's browser, leading to possible session theft, service disruption, or 
other information disclosure. Information for how Juniper Networks uses CVSS 
can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and 
Juniper's Security Advisories."

ACKNOWLEDGEMENTS:

- ----------------------------------------------------------------------------

2014-09 Security Bulletin: Junos Pulse Secure Access Service (SSL VPN): Cross
site scripting issue (CVE-2014-3824)

[JSA10646] Show KB Properties

PRODUCT AFFECTED:

SA700, SA2500, FIPS SA4000, SA4500, FIPS SA4500, FIPS SA6000, SA6500, FIPS 
SA6500, MAG2600, MAG4610, MAG6610, and MAG6611. The affected software releases
includes IVE OS: 8.0, 7.4, and 7.1.

PROBLEM:

A cross site scripting issue has been found in the Juniper Networks SSL VPN 
product. The problem is a result of incorrect user input validation on the SSL
VPN web server. The issue exists within a web page that is only accessible by
an authenticated user session.

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

No other Juniper Networks products or platforms are affected by this issue.

This issue has been assigned CVE-2014-3824.

SOLUTION:

The issue is fixed in SA/MAG (IVE OS) releases: 8.0r6, 7.4r13, and 7.1r20, and
all subsequent releases.

KB16765 - "In which releases are vulnerabilities fixed?" describes which 
release vulnerabilities are fixed as per our End of Engineering and End of 
Life support policies.

WORKAROUND:

There is no workaround for this issue. An upgrade to a fixed version of 
software is required.

IMPLEMENTATION:

 How to obtain fixed software:

Software release Service Packages are available at http://support.juniper.net
from the "Download Software" links. Select "Secure Access (SA) / SSL VPN" or 
"MAG Series" and choose the version applicable to your environment and 
installation.

RELATED LINKS:

KB16613: Overview of the Juniper Networks SIRT Monthly Security Bulletin 
Publication Process

KB16765: In which releases are vulnerabilities fixed?

KB16446: Common Vulnerability Scoring System (CVSS) and Juniper's Security 
Advisories

Report a Vulnerability - How to Contact the Juniper Networks Security Incident
Response Team

CVE-2014-3824: Cross site scripting issue

CVSS SCORE:

6.4 (AV:N/AC:L/Au:N/C:P/I:P/A:N)

RISK LEVEL:

High

RISK ASSESSMENT:

Successful exploit of this vulnerability could allow an attacker to 
dynamically create arbitrary active content which could be rendered in the 
user's browser, leading to possible session theft, service disruption, or 
other information disclosure. Information for how Juniper Networks uses CVSS 
can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and 
Juniper's Security Advisories."

ACKNOWLEDGEMENTS:

Juniper Networks SIRT would like to thank an anonymous contributor from 
VeriSign iDefense Labs for bringing this issue to our attention.

- -----------------------------------------------------------------------------

2014-09 Security Bulletin: Junos Pulse Secure Access Service (SSL VPN): 
Clickjacking issue (CVE-2014-3823)

[JSA10647] Show KB Properties

PRODUCT AFFECTED:

This issue can affect all: SA700, SA2000, SA2500, SA4000, FIPS SA4000, SA4500,
FIPS SA4500, SA6000, FIPS SA6000, SA6500, FIPS SA6500, MAG2600, MAG4610, 
MAG6610, and MAG6611.

PROBLEM:

A clickjacking issue has been found in the Juniper Networks SSL VPN product. 
'X-Frame-Options' has been added to defend against this type of attack. The 
attack could take place against authenticated or unauthenticated pages on the
SSL VPN.

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

No other Juniper Networks products or platforms are affected by this issue.

This issue has been assigned CVE-2014-3823.

SOLUTION:

The issue is fixed in SSL VPN (IVE OS) releases: 8.0r1, 7.4r5, and 7.1r18, and
all subsequent releases.

KB16765 - "In which releases are vulnerabilities fixed?" describes which 
release vulnerabilities are fixed as per our End of Engineering and End of 
Life support policies.

WORKAROUND:

There is no workaround for this issue. An upgrade to a fixed version of 
software is required.

IMPLEMENTATION:

 How to obtain fixed software:

Software release Service Packages are available at http://support.juniper.net
from the "Download Software" links. Select "Secure Access (SA) / SSL VPN" or 
"MAG Series" and choose the version applicable to your environment and 
installation.

RELATED LINKS:

KB16613: Overview of the Juniper Networks SIRT Monthly Security Bulletin 
Publication Process

KB16765: In which releases are vulnerabilities fixed?

KB16446: Common Vulnerability Scoring System (CVSS) and Juniper's Security 
Advisories

Report a Vulnerability - How to Contact the Juniper Networks Security Incident
Response Team

CVE-2014-3823: Click jacking issue

CVSS SCORE:

4.3 (AV:N/AC:M/Au:N/C:P/I:N/A:N)

RISK LEVEL:

Medium

RISK ASSESSMENT:

Information for how Juniper Networks uses CVSS can be found at KB 16446 
"Common Vulnerability Scoring System (CVSS) and Juniper's Security 
Advisories."

ACKNOWLEDGEMENTS:

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        http://www.auscert.org.au/render.html?cid=1980

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBVBE65xLndAQH1ShLAQLY7Q/+IVf2DRxSJiPOU5GiUlFp0AeJvKAvjto5
HpGv7fBNixljBHoeGnGdmoeaKfCAMtICOTyEtDGjjXurgXMMurIzL5awRUc70GKo
QIpNTL2eQNL/1ffG8DH7wUeulY3xapfp+ID1ZvH+2/aZ/S5lvQ8WJC5vRM3YWCr1
alV8dK+AY42bjZpXYqH14t591CWsm8jYIsBiOT3ppZtd7RGATh2aKcktVDn9FiRU
SQRfXPZE1G2hZOkOoD1FfWnTW36EiSCKCuThb1IOenrLkPFimZbBrNQMj2tPxd6D
yGMtzgIXq9zyRZcfanCZPn5dGlTCZAGxCbNqDBSxrOtz+Wc7/hm40nyHyVS5c3C9
ngnLidPRIW+0Inpcl9ZR3jzmUUe9MdtiaO7pN4IbPOhnGqSSYnN+t6iZW2sdYmsT
LxLgMzbqDK2TrszM0XZxmbOcZh5i7vDWD/BHoyV4CP61HesI4BrK2rfUInCOgp8X
5MBCDvjK9mC2UqhIjcNvAz5wEXgZ5c2Ezt8HbqqowKIpiixqQtAaVyoPowtxugV/
IpJqOg3alIzdI8qgxRekOx0kfmopsvfHUWlAIR9wjKZbIXO+n4//bymAwKaWa123
qjEvkwrvLlNEc8CIdfeOVF/ZkeJYZLtIQvbY+ubGo7ETqxcj62QNLyFAaUueHchm
Uq9+709hdac=
=GiaX
-----END PGP SIGNATURE-----