copyright | disclaimer | privacy | contact  
Australia's Leading Computer Emergency Response Team
 
Search this site

 
On this site

 > HOME
 > About AusCERT
 > Membership
 > Contact Us
 > PKI Services
 > Publications
 > Sec. Bulletins
 > Conferences
 > News & Media
 > Services
 > Web Log
 > Site Map
 > Site Help
 > Member login





 

ESB-2009.1432 - [Win][UNIX/Linux] Drupal Third Party Modules: Execute arbitrary code/commands - Remote/unauthenticated

Date: 22 October 2009

Click here for printable version
Click here for PGP verifiable version
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2009.1432
         Mutliple flaws in multiple third party modules for Drupal
                              22 October 2009

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           Flag Content (third-party module)
                   Organic Groups Vocabulary (third-party module)
                   Moodle Course List module (third-party module)
                   vCard module (third-party module)
                   Simplenews Statistics (third-party module)
                   Abuse (third-party module)
Operating System:  UNIX variants (UNIX, Linux, OSX)
                   Windows
Impact/Access:     Execute Arbitrary Code/Commands -- Remote/Unauthenticated
                   Cross-site Scripting            -- Remote/Unauthenticated
                   Cross-site Request Forgery      -- Remote/Unauthenticated
                   Provide Misleading Information  -- Remote/Unauthenticated
                   Read-only Data Access           -- Existing Account      
Resolution:        Patch/Upgrade

Original Bulletin: 
   http://drupal.org/node/610868
   http://drupal.org/node/610818
   http://drupal.org/node/610948
   http://drupal.org/node/610986
   http://drupal.org/node/610996
   http://drupal.org/node/611002
   http://drupal.org/node/611078

Comment: This contains advisories for seven (7) third party modules for Drupal

- --------------------------BEGIN INCLUDED TEXT--------------------

  * Advisory ID: DRUPAL-SA-CONTRIB-2009-076
  * Project: Flag Content (third-party module)
  * Version: 5.x
  * Date: 2009-October-21
  * Security risk: Moderately Critical
  * Exploitable from: Remote
  * Vulnerability: Cross Site Scripting

- -------- DESCRIPTION  
- ---------------------------------------------------------

The Flag Content module enables users to flag nodes and users for the
attention of a site maintainer (e.g. for abuse, spam, trolling, ...etc.). In
some specific cases, the module does not sanitize before outputting the
Reason field, resulting in a cross-site scripting (XSS [1]) vulnerability.
Such an attack may lead to a malicious user gaining full administrative
access.
- -------- VERSIONS AFFECTED  
- ---------------------------------------------------

  * Flag Content 5.x-2.x prior to 5.x-2.10

Drupal core is not affected. If you do not use the contributed Flag Content
module, there is nothing you need to do.
- -------- SOLUTION  
- ------------------------------------------------------------

Install the latest version:
  * If you use Flag Content module for Drupal 5.x upgrade to Flag Content
    5.x-2.10 [2]

- -------- REPORTED BY  
- ---------------------------------------------------------

patPrzybilla [3].
- -------- FIXED BY  
- ------------------------------------------------------------

kbahey [4], the module maintainer.
- -------- CONTACT  
- -------------------------------------------------------------

The security team for Drupal can be reached at security at drupal.org or via
the form at http://drupal.org/contact.

[1] http://en.wikipedia.org/wiki/Cross-site_scripting
[2] http://drupal.org/node/610870
[3] http://drupal.org/user/151965
[4] http://drupal.org/user/4063

_______________________________________________

  * Advisory ID: DRUPAL-SA-CONTRIB-2009-077
  * Project: Userpoints (third party module)
  * Version: 6.x
  * Date: 2009-October-21
  * Security risk: Less critical
  * Exploitable from: Remote
  * Vulnerability: Information disclosure

- -------- DESCRIPTION  
- ---------------------------------------------------------

The Userpoints module enables the users of a site to gain or lose points
based on their activity. There is a vulnerability in the module which allows
any user with the "View own userpoints" permission to view the userpoints
data of any user, not just their own.
- -------- VERSIONS AFFECTED  
- ---------------------------------------------------

  * Userponts module versions 6.x prior to 6.x-1.1

Drupal core is not affected. If you do not use the contributed Userpoints
module, there is nothing you need to do.
- -------- SOLUTION  
- ------------------------------------------------------------

Install the latest version.
  * If you use the Userpoints module for Drupal 6.x upgrade to Userpoints
    module 6.x-1.1 [1]

See also the Userpoints module project page [2].
- -------- REPORTED BY  
- ---------------------------------------------------------

mr.baileys [3].
- -------- FIXED BY  
- ------------------------------------------------------------

kbahey [4] the module maintainer.
- -------- CONTACT  
- -------------------------------------------------------------

The security team for Drupal can be reached at security at drupal.org or via
the form at http://drupal.org/contact.

[1] http://drupal.org/node/610828
[2] http://drupal.org/project/userpoints
[3] http://drupal.org/user/383424
[4] http://drupal.org/user/4063

_______________________________________________

  * Advisory ID: DRUPAL-SA-CONTRIB-2009-075
  * Project: Organic Groups Vocabulary (third-party module)
  * Version: 5.x
  * Date: 2009-October-21
  * Security risk: Critical
  * Exploitable from: Remote
  * Vulnerability: Cross Site Scripting

- -------- DESCRIPTION  
- ---------------------------------------------------------

The Organic Groups Vocabulary module enables an organic group to have a group
specific vocabulary. In some specific cases, the module does not sanitize
before outputting the group title, resulting in a cross-site scripting (XSS
[1]) vulnerability. Such an attack may lead to a malicious user gaining full
administrative access.
- -------- VERSIONS AFFECTED  
- ---------------------------------------------------

  * Organic Groups Vocabulary versions for Drupal 5.x before Organic Groups
    Vocabulary 5.x-1.1 [2]

Drupal core is not affected. If you do not use the contributed Organic Groups
Vocabulary module, there is nothing you need to do.
- -------- SOLUTION  
- ------------------------------------------------------------

Upgrade to the latest version:
  * If you use Organic Groups Vocabulary for Drupal 5.x upgrade to version
    5.x-1.1 [3]

See also the Organic Groups Vocabulary module project page [4].
- -------- REPORTED BY  
- ---------------------------------------------------------

Stéphane Corlosquet [5] of the Drupal Security Team.
- -------- FIXED BY  
- ------------------------------------------------------------

Amitaibu [6], the module maintainer.
- -------- CONTACT  
- -------------------------------------------------------------

The security contact for Drupal can be reached at security at drupal.org or
via the form at http://drupal.org/contact.

[1] http://en.wikipedia.org/wiki/Cross-site_scripting
[2] http://drupal.org/node/605094
[3] http://drupal.org/node/605094
[4] http://drupal.org/project/og_vocab
[5] http://drupal.org/user/52142
[6] http://drupal.org/user/57511

_______________________________________________

  * Advisory ID: DRUPAL-SA-CONTRIB-2009-078
  * Project: Moodle Course List module (third-party module)
  * Version: 6.x
  * Date: 2009-October-21
  * Security risk: Critical
  * Exploitable from: Remote
  * Vulnerability: SQL Injection

- -------- DESCRIPTION  
- ---------------------------------------------------------

The Moodle Course List module provides a block which displays links to a
user's Moodle courses. In some cases the module does not properly sanitize
user input, leading to a SQL Injection (SQL Injection [1]) vulnerability.
Such an attack may lead to a malicious user gaining full administrative
access.
- -------- VERSIONS AFFECTED  
- ---------------------------------------------------

  * Moodle Course List module versions 6.x prior to 6.x-1.2

Drupal core is not affected. If you do not use the contributed Moodle Course
List module, there is nothing you need to do.
- -------- SOLUTION  
- ------------------------------------------------------------

Install the latest version:
  * If you use the Moodle Course List module for Drupal 6.x upgrade to Moodle
    Course List module 6.x-1.2 [2]

See also the Moodle Course List module project page [3].
- -------- REPORTED BY  
- ---------------------------------------------------------

Charlie Gordon [4]
- -------- FIXED BY  
- ------------------------------------------------------------

Adam Gerson [5], the module maintainer.
- -------- CONTACT  
- -------------------------------------------------------------

The security team for Drupal can be reached at security at drupal.org or via
the form at http://drupal.org/contact.

[1] http://en.wikipedia.org/wiki/SQL_Injection
[2] http://drupal.org/node/569734
[3] http://drupal.org/project/moodle_courselist
[4] http://drupal.org/user/157412
[5] http://drupal.org/user/293615

_______________________________________________

  * Advisory ID: DRUPAL-SA-CONTRIB-2009-079
  * Project: vCard module (third-party module)
  * Version: 6.x, 5.x
  * Date: 2009-October-21
  * Security risk: Less critical
  * Exploitable from: Remote
  * Vulnerability: Cross Site Scripting

- -------- DESCRIPTION  
- ---------------------------------------------------------

The vCard module adds a vCard download link to every user's profile. This
link makes it easy to add users from a Drupal site to a local address book.
When the theme_vcard() function is added to a theme and default content from
the vCard module is output, the site will be vulnerable to Cross Site
Scripting attack (XSS [1]) vulnerability. Such an attack may lead to a
malicious user gaining full administrative access.
- -------- VERSIONS AFFECTED  
- ---------------------------------------------------

  * vCard module versions 6.x prior to 6.x-1.3
  * vCard module versions 5.x prior to 5.x-1.4

Drupal core is not affected. If you do not use the contributed vCard module,
there is nothing you need to do.
- -------- SOLUTION  
- ------------------------------------------------------------

Install the latest version:
  * If you use the vCard module for Drupal 6.x upgrade to vCard module 6.x-1.3
    [2]
  * If you use the vCard module for Drupal 5.x upgrade to vCard module 5.x-1.4
    [3]

See also the vCard module project page [4].
- -------- REPORTED BY  
- ---------------------------------------------------------

John Morahan [5]
- -------- FIXED BY  
- ------------------------------------------------------------

sanduhrs [6], the module maintainer.
- -------- CONTACT  
- -------------------------------------------------------------

The security team for Drupal can be reached at security at drupal.org or via
the form at http://drupal.org/contact.

[1] http://en.wikipedia.org/wiki/Cross_Site_Scripting
[2] http://drupal.org/node/610420
[3] http://drupal.org/node/610416
[4] http://drupal.org/project/vCard
[5] http://drupal.org/user/58170
[6] http://drupal.org/user/28074

_______________________________________________

  * Advisory ID: DRUPAL-SA-CONTRIB-2009-080
  * Project: Simplenews Statistics (third-party module)
  * Version: 6.x
  * Date: 2009 October 21
  * Security risk: Critical
  * Exploitable from: Remote
  * Vulnerability: Multiple vulnerabilities (XSS, CSRF, Open Redirect)

- -------- DESCRIPTION  
- ---------------------------------------------------------

The Simplenews Statistics module provides newsletter statistics such as the
open rate and CTR (click-through rate). The module suffers multiple
vulnerabilities, including Cross Site Request Forgeries (CSRF [1]), Cross
Site Scripting problem (Cross Site Scripting [2]) and Open Redirect. This
problem allows an attacker to hijack the account of a logged in user by
tricking them into visiting a seemingly innocent page.
- -------- VERSIONS AFFECTED  
- ---------------------------------------------------

  * Simplenews Statistics 6.x prior to 6.x-2.0

Drupal core is not affected. If you do not use the contributed Simplenews
Statistics module, there is nothing you need to do.
- -------- SOLUTION  
- ------------------------------------------------------------

Upgrade to the latest version:
  * If you use Simplenews Statistics for Drupal 6.x upgrade to version 6.x-2.0
    [3]

- -------- REPORTED BY  
- ---------------------------------------------------------

  * Open redirect vulnerability reported by John Pettitt
  * XSS and CSRF vulnerability reported by Dylan Wilder-Tack [4]

- -------- FIXED BY  
- ------------------------------------------------------------

  * Fixed by Sjoerd Arendsen [5].

- -------- CONTACT  
- -------------------------------------------------------------

The security contact for Drupal can be reached at security at drupal.org or
via the form at http://drupal.org/contact.

[1] http://en.wikipedia.org/wiki/Csrf
[2] http://en.wikipedia.org/wiki/XSS
[3] http://drupal.org/node/590098
[4] http://drupal.org/user/96647
[5] http://drupal.org/user/310132

_______________________________________________

  * Advisory ID: DRUPAL-SA-CONTRIB-2009-081
  * Project: Abuse (third-party module)
  * Version: 5.x, 6.x
  * Date: 2009 October 21
  * Security risk: Critical
  * Exploitable from: Remote
  * Vulnerability: Cross Site Scripting

- -------- DESCRIPTION  
- ---------------------------------------------------------

The Abuse module enables users to flag nodes and comments as offensive,
bringing them to the attention of the site maintainer for review. The module
suffers from a Cross Site Scripting (Cross Site Scripting [1]) vulnerability.
Such an attack may lead to a malicious user gaining full administrative
access.
- -------- VERSIONS AFFECTED  
- ---------------------------------------------------

  * Abuse 6.x prior to 6.x-1.1-alpha1
  * Abuse 5.x prior to 5.x-2.1

Drupal core is not affected. If you do not use the contributed Abuse module,
there is nothing you need to do.
- -------- SOLUTION  
- ------------------------------------------------------------

Upgrade to the latest version:
  * If you use Abuse for Drupal 6.x upgrade to version 6.x-1.1-alpha1 [2]
  * If you use Abuse for Drupal 5.x upgrade to version 5.x-2.1 [3]

- -------- REPORTED BY  
- ---------------------------------------------------------

  * Reported by Mustafa ULU [4].

- -------- FIXED BY  
- ------------------------------------------------------------

  * Fixed by Ashok Modi [5].

- -------- CONTACT  
- -------------------------------------------------------------

The security contact for Drupal can be reached at security at drupal.org or
via the form at http://drupal.org/contact.

[1] http://en.wikipedia.org/wiki/XSS
[2] http://drupal.org/node/610900
[3] http://drupal.org/node/610784
[4] http://drupal.org/user/207559
[5] http://drupal.org/user/60422

_______________________________________________

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        http://www.auscert.org.au/render.html?cid=1980

If you believe that your computer system has been compromised or attacked in 
any way, we encourage you to let us know by completing the secure National IT 
Incident Reporting Form at:

        http://www.auscert.org.au/render.html?it=3192

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iD8DBQFK37IWNVH5XJJInbgRAll1AJ40YF2TQKPGjM9yP/PraGGxOj7ZpwCfW0zy
e1nd8A+52CZajtZubS6W0vM=
=wq6/
-----END PGP SIGNATURE-----