-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2021.3924
                        Security update for tomcat
                             17 November 2021

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           tomcat
Publisher:         SUSE
Operating System:  SUSE
Impact/Access:     Denial of Service              -- Remote/Unauthenticated      
                   Provide Misleading Information -- Remote with User Interaction
                   Reduced Security               -- Remote/Unauthenticated      
Resolution:        Patch/Upgrade
CVE Names:         CVE-2021-41079 CVE-2021-33037 CVE-2021-30640

Reference:         ASB-2021.0220
                   ESB-2021.3688
                   ESB-2021.3531
                   ESB-2021.3414
                   ESB-2021.3327

Original Bulletin: 
   https://www.suse.com/support/update/announcement/2021/suse-su-20213670-1
   https://www.suse.com/support/update/announcement/2021/suse-su-20213672-1
   https://www.suse.com/support/update/announcement/2021/suse-su-20213669-1

Comment: This bulletin contains three (3) SUSE security advisories.

- --------------------------BEGIN INCLUDED TEXT--------------------

SUSE Security Update: Security update for tomcat

______________________________________________________________________________

Announcement ID:   SUSE-SU-2021:3670-1
Rating:            important
References:        #1188278 #1188279 #1190558
Cross-References:  CVE-2021-30640 CVE-2021-33037 CVE-2021-41079
Affected Products:
                   SUSE Linux Enterprise Server for SAP 15
                   SUSE Linux Enterprise Server 15-LTSS
                   SUSE Linux Enterprise High Performance Computing 15-LTSS
                   SUSE Linux Enterprise High Performance Computing 15-ESPOS
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for tomcat fixes the following issues:

  o CVE-2021-30640: Escape parameters in JNDI Realm queries (bsc#1188279).
  o CVE-2021-33037: Process T-E header from both HTTP 1.0 and HTTP 1.1. clients
    (bsc#1188278).
  o CVE-2021-41079: Fixed a denial of service caused by an unexpected TLS
    packet (bsc#1190558).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  o SUSE Linux Enterprise Server for SAP 15:
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2021-3670=1
  o SUSE Linux Enterprise Server 15-LTSS:
    zypper in -t patch SUSE-SLE-Product-SLES-15-2021-3670=1
  o SUSE Linux Enterprise High Performance Computing 15-LTSS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-2021-3670=1
  o SUSE Linux Enterprise High Performance Computing 15-ESPOS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-2021-3670=1

Package List:

  o SUSE Linux Enterprise Server for SAP 15 (noarch):
       tomcat-9.0.36-3.84.1
       tomcat-admin-webapps-9.0.36-3.84.1
       tomcat-el-3_0-api-9.0.36-3.84.1
       tomcat-jsp-2_3-api-9.0.36-3.84.1
       tomcat-lib-9.0.36-3.84.1
       tomcat-servlet-4_0-api-9.0.36-3.84.1
       tomcat-webapps-9.0.36-3.84.1
  o SUSE Linux Enterprise Server 15-LTSS (noarch):
       tomcat-9.0.36-3.84.1
       tomcat-admin-webapps-9.0.36-3.84.1
       tomcat-el-3_0-api-9.0.36-3.84.1
       tomcat-jsp-2_3-api-9.0.36-3.84.1
       tomcat-lib-9.0.36-3.84.1
       tomcat-servlet-4_0-api-9.0.36-3.84.1
       tomcat-webapps-9.0.36-3.84.1
  o SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):
       tomcat-9.0.36-3.84.1
       tomcat-admin-webapps-9.0.36-3.84.1
       tomcat-el-3_0-api-9.0.36-3.84.1
       tomcat-jsp-2_3-api-9.0.36-3.84.1
       tomcat-lib-9.0.36-3.84.1
       tomcat-servlet-4_0-api-9.0.36-3.84.1
       tomcat-webapps-9.0.36-3.84.1
  o SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):
       tomcat-9.0.36-3.84.1
       tomcat-admin-webapps-9.0.36-3.84.1
       tomcat-el-3_0-api-9.0.36-3.84.1
       tomcat-jsp-2_3-api-9.0.36-3.84.1
       tomcat-lib-9.0.36-3.84.1
       tomcat-servlet-4_0-api-9.0.36-3.84.1
       tomcat-webapps-9.0.36-3.84.1


References:

  o https://www.suse.com/security/cve/CVE-2021-30640.html
  o https://www.suse.com/security/cve/CVE-2021-33037.html
  o https://www.suse.com/security/cve/CVE-2021-41079.html
  o https://bugzilla.suse.com/1188278
  o https://bugzilla.suse.com/1188279
  o https://bugzilla.suse.com/1190558

- -----------------------------------------------------------------------------------------------------

SUSE Security Update: Security update for tomcat

______________________________________________________________________________

Announcement ID:   SUSE-SU-2021:3672-1
Rating:            moderate
References:        #1188278 #1188279 #1190558
Cross-References:  CVE-2021-30640 CVE-2021-33037 CVE-2021-41079
Affected Products:
                   SUSE Linux Enterprise Module for Web Scripting 15-SP3
                   SUSE Linux Enterprise Module for Web Scripting 15-SP2
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for tomcat fixes the following issues:

  o CVE-2021-30640: Escape parameters in JNDI Realm queries (bsc#1188279).
  o CVE-2021-33037: Process T-E header from both HTTP 1.0 and HTTP 1.1. clients
    (bsc#1188278).
  o CVE-2021-41079: Fixed a denial of service caused by an unexpected TLS
    packet (bsc#1190558).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  o SUSE Linux Enterprise Module for Web Scripting 15-SP3:
    zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP3-2021-3672=1
  o SUSE Linux Enterprise Module for Web Scripting 15-SP2:
    zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP2-2021-3672=1

Package List:

  o SUSE Linux Enterprise Module for Web Scripting 15-SP3 (noarch):
       tomcat-9.0.36-13.1
       tomcat-admin-webapps-9.0.36-13.1
       tomcat-el-3_0-api-9.0.36-13.1
       tomcat-jsp-2_3-api-9.0.36-13.1
       tomcat-lib-9.0.36-13.1
       tomcat-servlet-4_0-api-9.0.36-13.1
       tomcat-webapps-9.0.36-13.1
  o SUSE Linux Enterprise Module for Web Scripting 15-SP2 (noarch):
       tomcat-9.0.36-13.1
       tomcat-admin-webapps-9.0.36-13.1
       tomcat-el-3_0-api-9.0.36-13.1
       tomcat-jsp-2_3-api-9.0.36-13.1
       tomcat-lib-9.0.36-13.1
       tomcat-servlet-4_0-api-9.0.36-13.1
       tomcat-webapps-9.0.36-13.1


References:

  o https://www.suse.com/security/cve/CVE-2021-30640.html
  o https://www.suse.com/security/cve/CVE-2021-33037.html
  o https://www.suse.com/security/cve/CVE-2021-41079.html
  o https://bugzilla.suse.com/1188278
  o https://bugzilla.suse.com/1188279
  o https://bugzilla.suse.com/1190558

- -----------------------------------------------------------------------------------------------------

SUSE Security Update: Security update for tomcat

______________________________________________________________________________

Announcement ID:   SUSE-SU-2021:3669-1
Rating:            important
References:        #1188278 #1188279 #1190558
Cross-References:  CVE-2021-30640 CVE-2021-33037 CVE-2021-41079
Affected Products:
                   SUSE Linux Enterprise Server for SAP 15-SP1
                   SUSE Linux Enterprise Server 15-SP1-LTSS
                   SUSE Linux Enterprise Server 15-SP1-BCL
                   SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS
                   SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
                   SUSE Enterprise Storage 6
                   SUSE CaaS Platform 4.0
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for tomcat fixes the following issues:

  o CVE-2021-30640: Escape parameters in JNDI Realm queries (bsc#1188279).
  o CVE-2021-33037: Process T-E header from both HTTP 1.0 and HTTP 1.1. clients
    (bsc#1188278).
  o CVE-2021-41079: Fixed a denial of service caused by an unexpected TLS
    packet (bsc#1190558).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  o SUSE Linux Enterprise Server for SAP 15-SP1:
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2021-3669=1
  o SUSE Linux Enterprise Server 15-SP1-LTSS:
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-3669=1
  o SUSE Linux Enterprise Server 15-SP1-BCL:
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2021-3669=1
  o SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-3669=1
  o SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-3669=1
  o SUSE Enterprise Storage 6:
    zypper in -t patch SUSE-Storage-6-2021-3669=1
  o SUSE CaaS Platform 4.0:
    To install this update, use the SUSE CaaS Platform 'skuba' tool. I will
    inform you if it detects new updates and let you then trigger updating of
    the complete cluster in a controlled way.

Package List:

  o SUSE Linux Enterprise Server for SAP 15-SP1 (noarch):
       tomcat-9.0.36-4.63.1
       tomcat-admin-webapps-9.0.36-4.63.1
       tomcat-el-3_0-api-9.0.36-4.63.1
       tomcat-jsp-2_3-api-9.0.36-4.63.1
       tomcat-lib-9.0.36-4.63.1
       tomcat-servlet-4_0-api-9.0.36-4.63.1
       tomcat-webapps-9.0.36-4.63.1
  o SUSE Linux Enterprise Server 15-SP1-LTSS (noarch):
       tomcat-9.0.36-4.63.1
       tomcat-admin-webapps-9.0.36-4.63.1
       tomcat-el-3_0-api-9.0.36-4.63.1
       tomcat-jsp-2_3-api-9.0.36-4.63.1
       tomcat-lib-9.0.36-4.63.1
       tomcat-servlet-4_0-api-9.0.36-4.63.1
       tomcat-webapps-9.0.36-4.63.1
  o SUSE Linux Enterprise Server 15-SP1-BCL (noarch):
       tomcat-9.0.36-4.63.1
       tomcat-admin-webapps-9.0.36-4.63.1
       tomcat-el-3_0-api-9.0.36-4.63.1
       tomcat-jsp-2_3-api-9.0.36-4.63.1
       tomcat-lib-9.0.36-4.63.1
       tomcat-servlet-4_0-api-9.0.36-4.63.1
       tomcat-webapps-9.0.36-4.63.1
  o SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (noarch):
       tomcat-9.0.36-4.63.1
       tomcat-admin-webapps-9.0.36-4.63.1
       tomcat-el-3_0-api-9.0.36-4.63.1
       tomcat-jsp-2_3-api-9.0.36-4.63.1
       tomcat-lib-9.0.36-4.63.1
       tomcat-servlet-4_0-api-9.0.36-4.63.1
       tomcat-webapps-9.0.36-4.63.1
  o SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (noarch):
       tomcat-9.0.36-4.63.1
       tomcat-admin-webapps-9.0.36-4.63.1
       tomcat-el-3_0-api-9.0.36-4.63.1
       tomcat-jsp-2_3-api-9.0.36-4.63.1
       tomcat-lib-9.0.36-4.63.1
       tomcat-servlet-4_0-api-9.0.36-4.63.1
       tomcat-webapps-9.0.36-4.63.1
  o SUSE Enterprise Storage 6 (noarch):
       tomcat-9.0.36-4.63.1
       tomcat-admin-webapps-9.0.36-4.63.1
       tomcat-el-3_0-api-9.0.36-4.63.1
       tomcat-jsp-2_3-api-9.0.36-4.63.1
       tomcat-lib-9.0.36-4.63.1
       tomcat-servlet-4_0-api-9.0.36-4.63.1
       tomcat-webapps-9.0.36-4.63.1
  o SUSE CaaS Platform 4.0 (noarch):
       tomcat-9.0.36-4.63.1
       tomcat-admin-webapps-9.0.36-4.63.1
       tomcat-el-3_0-api-9.0.36-4.63.1
       tomcat-jsp-2_3-api-9.0.36-4.63.1
       tomcat-lib-9.0.36-4.63.1
       tomcat-servlet-4_0-api-9.0.36-4.63.1
       tomcat-webapps-9.0.36-4.63.1


References:

  o https://www.suse.com/security/cve/CVE-2021-30640.html
  o https://www.suse.com/security/cve/CVE-2021-33037.html
  o https://www.suse.com/security/cve/CVE-2021-41079.html
  o https://bugzilla.suse.com/1188278
  o https://bugzilla.suse.com/1188279
  o https://bugzilla.suse.com/1190558

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBYZRS4uNLKJtyKPYoAQibDhAAm60GWCSLlm4hjRRPhUYAW/yVkn50QdO7
Rp9Aw5w402idbE7ToebXA5XL4w+Gu+OaNH4WNH3irhx2bK+rbL9AzEhXmZWOHsEv
kG4qtFHAFpdexSHr393eZ4Ar53rgfW7M1sTHqV1MXdT5GsFaItgc8MmkY0y0Y46X
UmrDULTxwrjgPp4/87dWR86Gxi4EeXjc0jt3DiOQ9Mk9jOHQsUWBmoxOEJGSeqF+
k66uPLEazqGcRnOsV1WWSdDjvrJDUcqCFRPnLfNZptDOQ6zdts0KESCg3m3G8L3G
mhEPH6dl2tXknt+PFqXC4PZIBifRD/oE03POFB3jnBYnGf615swOH/zS5h986KsH
lHcl054cAgVrE3d4cY0WcsOIoF03PhzyJC9IwBhIc76+aTFXMYFI+LAEWD7yPJ+T
Ovn9INNkrEvbK88rYpQMA1duJrgS9o0gvvRiHjSldmVzti4guIM97NbwJM1cs2R3
7VINsrUTLOxj/Uh2ZlfHy59jTiy7rypwjBrm63/4d9ZiUJaVvqhaX1MwmAtWk3hh
Zy8AdYWLhE3Yg+H/lePzrtD6wNEP8OhHnbMzvbdSHGTbXxICVrQA5AGePbDLEKNY
KbcG+JWoES+v3VkpBLLoZ/eKfAgVBPXPbVwW5+f8N0KTs3rwhFOTGpjTNJSvcYRc
/Oe7sT1f4y0=
=7lOo
-----END PGP SIGNATURE-----