Operating System:

[Cisco]

Published:

21 January 2021

Protect yourself against future threats.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2021.0240
          Cisco Smart Software Manager Satellite vulnerabilities
                              21 January 2021

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           Cisco Smart Software Manager Satellite
Publisher:         Cisco Systems
Operating System:  Cisco
Impact/Access:     Root Compromise                 -- Remote/Unauthenticated      
                   Execute Arbitrary Code/Commands -- Remote/Unauthenticated      
                   Provide Misleading Information  -- Remote with User Interaction
                   Access Confidential Data        -- Existing Account            
Resolution:        Patch/Upgrade
CVE Names:         CVE-2021-1222 CVE-2021-1219 CVE-2021-1218
                   CVE-2021-1142 CVE-2021-1141 CVE-2021-1140
                   CVE-2021-1139 CVE-2021-1138 

Original Bulletin: 
   https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssmor-MDCWkT2x
   https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssm-sqi-h5fDvZWp
   https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssm-sc-Jd42D4Tq
   https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssm-multici-pgG5WM5A

Comment: This bulletin contains four (4) Cisco Systems security advisories.

- --------------------------BEGIN INCLUDED TEXT--------------------

Cisco Smart Software Manager Satellite Open Redirect Vulnerability

Priority:        Medium
Advisory ID:     cisco-sa-cssmor-MDCWkT2x
First Published: 2021 January 20 16:00 GMT
Version 1.0:     Final
Workarounds:     No workarounds available
Cisco Bug IDs:   CSCvm45224
CVE Names:       CVE-2021-1218
CWEs:            CWE-601

CVSS Score:
4.6  AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N/E:X/RL:X/RC:X

Summary

  o A vulnerability in the web management interface of Cisco Smart Software
    Manager satellite could allow an authenticated, remote attacker to redirect
    a user to an undesired web page.

    The vulnerability is due to improper input validation of the URL parameters
    in an HTTP request that is sent to an affected device. An attacker could
    exploit this vulnerability by sending a crafted HTTP request that could
    cause the web application to redirect the request to a specified malicious
    URL. A successful exploit could allow the attacker to redirect a user to a
    malicious website.

    Cisco has released software updates that address this vulnerability. There
    are no workarounds that address this vulnerability.

    This advisory is available at the following link:
    https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssmor-MDCWkT2x

Affected Products

  o Vulnerable Products

    At the time of publication, this vulnerability affected Cisco Smart
    Software Manager satellite releases 5.0 and earlier.

    See the Details section in the bug ID(s) at the top of this advisory for
    the most complete and current information.

    Products Confirmed Not Vulnerable

    Only products listed in the Vulnerable Products section of this advisory
    are known to be affected by this vulnerability.

Workarounds

  o There are no workarounds that address this vulnerability.

Fixed Software

  o When considering software upgrades , customers are advised to regularly
    consult the advisories for Cisco products, which are available from the
    Cisco Security Advisories page , to determine exposure and a complete
    upgrade solution.

    In all cases, customers should ensure that the devices to be upgraded
    contain sufficient memory and confirm that current hardware and software
    configurations will continue to be supported properly by the new release.
    If the information is not clear, customers are advised to contact the Cisco
    Technical Assistance Center (TAC) or their contracted maintenance
    providers.

    Fixed Releases

    At the time of publication, Cisco Smart Software Manager On-Prem releases
    5.1.0 and later contained the fix for this vulnerability.

    See the Details section in the bug ID(s) at the top of this advisory for
    the most complete and current information.

Exploitation and Public Announcements

  o The Cisco Product Security Incident Response Team (PSIRT) is not aware of
    any public announcements or malicious use of the vulnerability that is
    described in this advisory.

Source

  o This vulnerability was found by Cisco during internal security testing.

Cisco Security Vulnerability Policy

  o To learn about Cisco security vulnerability disclosure policies and
    publications, see the Security Vulnerability Policy . This document also
    contains instructions for obtaining fixed software and receiving security
    vulnerability information from Cisco.

URL

  o https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssmor-MDCWkT2x

Revision History

  o +----------+---------------------------+----------+--------+--------------+
    | Version  |        Description        | Section  | Status |     Date     |
    +----------+---------------------------+----------+--------+--------------+
    | 1.0      | Initial public release.   | -        | Final  | 2021-JAN-20  |
    +----------+---------------------------+----------+--------+--------------+

- --------------------------------------------------------------------------------

Cisco Smart Software Manager Satellite SQL Injection Vulnerability

Priority:        Medium
Advisory ID:     cisco-sa-cssm-sqi-h5fDvZWp
First Published: 2021 January 20 16:00 GMT
Version 1.0:     Final
Workarounds:     No workarounds available
Cisco Bug IDs:   CSCvm42654
CVE Names:       CVE-2021-1222
CWEs:            CWE-89

CVSS Score:
6.8  AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N/E:X/RL:X/RC:X

Summary

  o A vulnerability in the web-based management interface of Cisco Smart
    Software Manager Satellite could allow an authenticated, remote attacker to
    conduct SQL injection attacks on an affected system.

    The vulnerability exists because the web-based management interface
    improperly validates values within SQL queries. An attacker could exploit
    this vulnerability by authenticating to the application and sending
    malicious SQL queries to an affected system. A successful exploit could
    allow the attacker to modify values on or return values from the underlying
    database or the operating system.

    Cisco has released software updates that address this vulnerability. There
    are no workarounds that address this vulnerability.

    This advisory is available at the following link:
    https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssm-sqi-h5fDvZWp

Affected Products

  o Vulnerable Products

    At the time of publication, this vulnerability affected Cisco Smart
    Software Manager Satellite releases 5.1.0 and earlier.

    See the Details section in the bug ID(s) at the top of this advisory for
    the most complete and current information.

    Products Confirmed Not Vulnerable

    Only products listed in the Vulnerable Products section of this advisory
    are known to be affected by this vulnerability.

Workarounds

  o There are no workarounds that address this vulnerability.

Fixed Software

  o When considering software upgrades , customers are advised to regularly
    consult the advisories for Cisco products, which are available from the
    Cisco Security Advisories page , to determine exposure and a complete
    upgrade solution.

    In all cases, customers should ensure that the devices to be upgraded
    contain sufficient memory and confirm that current hardware and software
    configurations will continue to be supported properly by the new release.
    If the information is not clear, customers are advised to contact the Cisco
    Technical Assistance Center (TAC) or their contracted maintenance
    providers.

    Fixed Releases

    At the time of publication, Cisco Smart Software Manager On-Prem releases
    6.3.0 and later contained the fix for this vulnerability.

    Note: With Release 6.3.0, Cisco Smart Software Manager Satellite was
    renamed to Cisco Smart Software Manager On-Prem.

    See the Details section in the bug ID(s) at the top of this advisory for
    the most complete and current information.

Exploitation and Public Announcements

  o The Cisco Product Security Incident Response Team (PSIRT) is not aware of
    any public announcements or malicious use of the vulnerability that is
    described in this advisory.

Source

  o This vulnerability was found during internal security testing.

Cisco Security Vulnerability Policy

  o To learn about Cisco security vulnerability disclosure policies and
    publications, see the Security Vulnerability Policy . This document also
    contains instructions for obtaining fixed software and receiving security
    vulnerability information from Cisco.

URL

  o https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssm-sqi-h5fDvZWp

Revision History

  o +----------+---------------------------+----------+--------+--------------+
    | Version  |        Description        | Section  | Status |     Date     |
    +----------+---------------------------+----------+--------+--------------+
    | 1.0      | Initial public release.   | -        | Final  | 2021-JAN-20  |
    +----------+---------------------------+----------+--------+--------------+

- --------------------------------------------------------------------------------

Cisco Smart Software Manager Satellite Static Credential Vulnerability

Priority:        High
Advisory ID:     cisco-sa-cssm-sc-Jd42D4Tq
First Published: 2021 January 20 16:00 GMT
Version 1.0:     Final
Workarounds:     No workarounds available
Cisco Bug IDs:   CSCvm42283
CVE Names:       CVE-2021-1219
CWEs:            CWE-798

CVSS Score:
7.8  AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:X/RL:X/RC:X

Summary

  o A vulnerability in Cisco Smart Software Manager Satellite could allow an
    authenticated, local attacker to access sensitive information on an
    affected system.

    The vulnerability is due to insufficient protection of static credentials
    in the affected software. An attacker could exploit this vulnerability by
    gaining access to the static credential that is stored on the local device.
    A successful exploit could allow the attacker to view static credentials,
    which the attacker could use to carry out further attacks.

    Cisco has released software updates that address this vulnerability. There
    are no workarounds that address this vulnerability.

    This advisory is available at the following link:
    https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssm-sc-Jd42D4Tq

Affected Products

  o Vulnerable Products

    This vulnerability affects Cisco Smart Software Manager Satellite releases
    5.1.0 and earlier.

    Products Confirmed Not Vulnerable

    Only products listed in the Vulnerable Products section of this advisory
    are known to be affected by this vulnerability.

Workarounds

  o There are no workarounds that address this vulnerability.

Fixed Software

  o Cisco has released free software updates that address the vulnerability
    described in this advisory. Customers may only install and expect support
    for software versions and feature sets for which they have purchased a
    license. By installing, downloading, accessing, or otherwise using such
    software upgrades, customers agree to follow the terms of the Cisco
    software license:
    https://www.cisco.com/c/en/us/products/end-user-license-agreement.html

    Additionally, customers may only download software for which they have a
    valid license, procured from Cisco directly, or through a Cisco authorized
    reseller or partner. In most cases this will be a maintenance upgrade to
    software that was previously purchased. Free security software updates do
    not entitle customers to a new software license, additional software
    feature sets, or major revision upgrades.

    When considering software upgrades , customers are advised to regularly
    consult the advisories for Cisco products, which are available from the
    Cisco Security Advisories page , to determine exposure and a complete
    upgrade solution.

    In all cases, customers should ensure that the devices to be upgraded
    contain sufficient memory and confirm that current hardware and software
    configurations will continue to be supported properly by the new release.
    If the information is not clear, customers are advised to contact the Cisco
    Technical Assistance Center (TAC) or their contracted maintenance
    providers.

    Customers Without Service Contracts

    Customers who purchase directly from Cisco but do not hold a Cisco service
    contract and customers who make purchases through third-party vendors but
    are unsuccessful in obtaining fixed software through their point of sale
    should obtain upgrades by contacting the Cisco TAC: https://www.cisco.com/c
    /en/us/support/web/tsd-cisco-worldwide-contacts.html

    Customers should have the product serial number available and be prepared
    to provide the URL of this advisory as evidence of entitlement to a free
    upgrade.

    Fixed Releases

    Cisco fixed this vulnerability in Cisco Smart Software Manager On-Prem 
    releases 6.3.0 and later.

    Note: With Release 6.3.0, Cisco Smart Software Manager Satellite was
    renamed to Cisco Smart Software Manager On-Prem.

Exploitation and Public Announcements

  o The Cisco Product Security Incident Response Team (PSIRT) is not aware of
    any public announcements or malicious use of the vulnerability that is
    described in this advisory.

Source

  o This vulnerability was found during internal security testing.

Cisco Security Vulnerability Policy

  o To learn about Cisco security vulnerability disclosure policies and
    publications, see the Security Vulnerability Policy . This document also
    contains instructions for obtaining fixed software and receiving security
    vulnerability information from Cisco.

URL

  o https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssm-sc-Jd42D4Tq

Revision History

  o +----------+---------------------------+----------+--------+--------------+
    | Version  |        Description        | Section  | Status |     Date     |
    +----------+---------------------------+----------+--------+--------------+
    | 1.0      | Initial public release.   | -        | Final  | 2021-JAN-20  |
    +----------+---------------------------+----------+--------+--------------+



- --------------------------------------------------------------------------------

Cisco Smart Software Manager Satellite Web UI Command Injection Vulnerabilities

Priority:        Critical
Advisory ID:     cisco-sa-cssm-multici-pgG5WM5A
First Published: 2021 January 20 16:00 GMT
Version 1.0:     Final
Workarounds:     No workarounds available
Cisco Bug IDs:   CSCvm42428 CSCvm42436 CSCvm42548 CSCvm42748 CSCvm45213
CVE Names:       CVE-2021-1138 CVE-2021-1139 CVE-2021-1140 CVE-2021-1141
                 CVE-2021-1142
CWEs:            CWE-20

Summary

  o Multiple vulnerabilities in the web UI of Cisco Smart Software Manager 
    Satellite could allow an unauthenticated, remote attacker to execute
    arbitrary commands on the underlying operating system.

    For more information about these vulnerabilities, see the Details section
    of this advisory.

    Cisco has released software updates that address these vulnerabilities.
    There are no workarounds that address these vulnerabilities.

    This advisory is available at the following link:
    https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssm-multici-pgG5WM5A

Affected Products

  o Vulnerable Products

    These vulnerabilities affect Cisco Smart Software Manager Satellite
    releases 5.1.0 and earlier.

    Products Confirmed Not Vulnerable

    Only products listed in the Vulnerable Products section of this advisory
    are known to be affected by these vulnerabilities.

Details

  o The vulnerabilities are not dependent on one another. Exploitation of one
    of the vulnerabilities is not required to exploit another vulnerability. In
    addition, a software release that is affected by one of the vulnerabilities
    may not be affected by the other vulnerabilities.

    Details about the vulnerabilities are as follows:

    CVE-2021-1138, CVE-2021-1140, CVE-2021-1142: Cisco Smart Software Manager
    Satellite Web U I Command Injection Vulnerabilities

    Vulnerabilities in the web UI of Cisco Smart Software Manager Satellite
    could allow an unauthenticated, remote attacker to execute arbitrary
    commands as a high-privileged user on an affected device.

    These vulnerabilities are due to insufficient input validation. An attacker
    could exploit these vulnerabilities by sending malicious HTTP requests to
    an affected device. A successful exploit could allow the attacker to run
    arbitrary commands on the underlying operating system.

    Cisco has released software updates that address these vulnerabilities.
    There are no workarounds that address these vulnerabilities.

    CVE-ID: CVE-2021-1138, CVE-2021-1140, CVE-2021-1142
    Bug ID(s): CSCvm45213 , CSCvm42428 , CSCvm42748
    Security Impact Rating (SIR): Critical
    CVSS Base Score: 9.8
    CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

    CVE-2021-1139, CVE-2021-1141: Cisco Smart Software Manager Satellite Web UI
    Command Injection Vulnerabilities

    Vulnerabilities in the web UI of Cisco Smart Software Manager Satellite
    could allow an authenticated, remote attacker to execute arbitrary commands
    as the root user on an affected device.

    These vulnerabilities are due to insufficient input validation. An attacker
    could exploit these vulnerabilities by sending malicious HTTP requests to
    an affected device. A successful exploit could allow the attacker to run
    arbitrary commands as the root user on the underlying operating system.

    Cisco has released software updates that address these vulnerabilities.
    There are no workarounds that address these vulnerabilities.

    CVE-ID: CVE-2021-1139, CVE-2021-1141
    Bug ID(s): CSCvm42548 , CSCvm42436
    Security Impact Rating (SIR): High
    CVSS Base Score: 8.8
    CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Workarounds

  o There are no workarounds that address these vulnerabilities.

Fixed Software

  o Cisco has released free software updates that address the vulnerabilities
    described in this advisory. Customers may only install and expect support
    for software versions and feature sets for which they have purchased a
    license. By installing, downloading, accessing, or otherwise using such
    software upgrades, customers agree to follow the terms of the Cisco
    software license:
    https://www.cisco.com/c/en/us/products/end-user-license-agreement.html

    Additionally, customers may only download software for which they have a
    valid license, procured from Cisco directly, or through a Cisco authorized
    reseller or partner. In most cases this will be a maintenance upgrade to
    software that was previously purchased. Free security software updates do
    not entitle customers to a new software license, additional software
    feature sets, or major revision upgrades.

    When considering software upgrades , customers are advised to regularly
    consult the advisories for Cisco products, which are available from the
    Cisco Security Advisories page , to determine exposure and a complete
    upgrade solution.

    In all cases, customers should ensure that the devices to be upgraded
    contain sufficient memory and confirm that current hardware and software
    configurations will continue to be supported properly by the new release.
    If the information is not clear, customers are advised to contact the Cisco
    Technical Assistance Center (TAC) or their contracted maintenance
    providers.

    Customers Without Service Contracts

    Customers who purchase directly from Cisco but do not hold a Cisco service
    contract and customers who make purchases through third-party vendors but
    are unsuccessful in obtaining fixed software through their point of sale
    should obtain upgrades by contacting the Cisco TAC: https://www.cisco.com/c
    /en/us/support/web/tsd-cisco-worldwide-contacts.html

    Customers should have the product serial number available and be prepared
    to provide the URL of this advisory as evidence of entitlement to a free
    upgrade.

    Fixed Releases

    Cisco fixed these vulnerabilities in Cisco Smart Software Manager On-Prem
    releases 6.3.0 and later.

    Note: With Release 6.3.0, Cisco Smart Software Manager Satellite was
    renamed to Cisco Smart Software Manager On-Prem.

Exploitation and Public Announcements

  o The Cisco Product Security Incident Response Team (PSIRT) is not aware of
    any public announcements or malicious use of the vulnerabilities that are
    described in this advisory.

Source

  o These vulnerabilities were found during internal security testing.

Cisco Security Vulnerability Policy

  o To learn about Cisco security vulnerability disclosure policies and
    publications, see the Security Vulnerability Policy . This document also
    contains instructions for obtaining fixed software and receiving security
    vulnerability information from Cisco.

URL

  o https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cssm-multici-pgG5WM5A

Revision History

  o +----------+---------------------------+----------+--------+--------------+
    | Version  |        Description        | Section  | Status |     Date     |
    +----------+---------------------------+----------+--------+--------------+
    | 1.0      | Initial public release.   | -        | Final  | 2021-JAN-20  |
    +----------+---------------------------+----------+--------+--------------+

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBYAj6a+NLKJtyKPYoAQgh9w//Y09TvkRZS/fimnzsj0ePcdGWanJVPfMP
7zHyMHvranq2GBk+sHgSX1zaHNopZNLc98Siy9XXjoUjbSVohRnXb4PU1+mNn6YD
tPhiQB+jtpdoWjRoEWJ5UMzACoiHp8Qraknn4RNhR1B1J2c0xu/yFfekVByV6uWI
MZ/ZnVXwagEOGGpYoVY0sWTRJcwH6TcYL1l/chDYe6bYosPvgLeM5MWhhPyC/uzN
uBEvwyRevZYRlXcyErvsDBJ9cH6kTiVvpEuPLZEKl9vIOOOJPooEwgaM9lHIw6uC
28/UQzHMZNUYIUiHFxBamjTN/bZjhZY/qRj008HFVGFqbwwHFv7Z5KYNdmKksq4Q
tPxIEGenl0vrW/FysrZqEDezweMvekNsOpCKTn5o3GIBAKrf2u3xYGyhQUsaeHjk
P4z/SwZ0q6L20ktdgnp/u8VMJhagmFiUxyG9SILfDAHdHaQYDwiAvo88HogklFLf
xEOsQgURfqAAFzyjHmtM79c4JVc8qqzFZeDtxScbg0P7q5RsuEBfIfgaFYBWZyCQ
ZVcrictU0DvjSt88JK5QUcYx5/0ZUHxtWk98d132C55uB7S2HxCUFzo+qa3RNqLt
GhqFIWt5FJm4uHEa9xkRcGXAYFsJa2gaISHv5SetGd4k60zbiXWlLfAOfv3QOT+L
7o8P7t+p3bA=
=3PBK
-----END PGP SIGNATURE-----