ESB-2019.1036.2 - UPDATE [SUSE] tiff: Multiple vulnerabilities 2019-04-02

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                              ESB-2019.1036.2
               SUSE-SU-2019:0786-1 Security update for tiff
                               2 April 2019

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           tiff
Publisher:         SUSE
Operating System:  SUSE
Impact/Access:     Denial of Service              -- Remote with User Interaction
                   Provide Misleading Information -- Remote with User Interaction
Resolution:        Patch/Upgrade
CVE Names:         CVE-2019-7663 CVE-2019-6128 CVE-2018-19210
                   CVE-2018-17000 CVE-2016-5102 

Reference:         ESB-2019.0790.2
                   ESB-2019.0507

Original Bulletin: 
   https://www.suse.com/support/update/announcement/2019/suse-su-20190786-1.html
   https://www.suse.com/support/update/announcement/2019/suse-su-201914002-1.html

Comment: This bulletin contains two (2) advisories.

Revision History:  April  2 2019: Added SUSE-SU-2019:14002-1
                   March 29 2019: Initial Release

- --------------------------BEGIN INCLUDED TEXT--------------------

SUSE Security Update: Security update for tiff

______________________________________________________________________________

Announcement ID:   SUSE-SU-2019:0786-1
Rating:            moderate
References:        #1108606 #1115717 #1121626 #1125113
Cross-References:  CVE-2018-17000 CVE-2018-19210 CVE-2019-6128 CVE-2019-7663
Affected Products:
                   SUSE Linux Enterprise Module for Packagehub Subpackages 15
                   SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
                   SUSE Linux Enterprise Module for Desktop Applications 15
                   SUSE Linux Enterprise Module for Basesystem 15
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for tiff fixes the following issues:
Security issues fixed:

  o CVE-2018-19210: Fixed a NULL pointer dereference in TIFFWriteDirectorySec
    function (bsc#1115717).
  o CVE-2018-17000: Fixed a NULL pointer dereference in the _TIFFmemcmp
    function (bsc#1108606).
  o CVE-2019-6128: Fixed a memory leak in the TIFFFdOpen function in tif_unix.c
    (bsc#1121626).
  o CVE-2019-7663: Fixed an invalid address dereference in the
    TIFFWriteDirectoryTagTransfer function in libtiff/tif_dirwrite.c (bsc#
    1125113)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  o SUSE Linux Enterprise Module for Packagehub Subpackages 15:
    zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-2019-786=1
  o SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-786=1
  o SUSE Linux Enterprise Module for Desktop Applications 15:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-786=1
  o SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-786=1

Package List:

  o SUSE Linux Enterprise Module for Packagehub Subpackages 15 (aarch64 ppc64le
    s390x x86_64):
       tiff-4.0.9-5.27.5
       tiff-debuginfo-4.0.9-5.27.5
       tiff-debugsource-4.0.9-5.27.5
  o SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
    (aarch64 ppc64le s390x x86_64):
       tiff-4.0.9-5.27.5
       tiff-debuginfo-4.0.9-5.27.5
       tiff-debugsource-4.0.9-5.27.5
  o SUSE Linux Enterprise Module for Desktop Applications 15 (x86_64):
       libtiff5-32bit-4.0.9-5.27.5
       libtiff5-32bit-debuginfo-4.0.9-5.27.5
       tiff-debugsource-4.0.9-5.27.5
  o SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x
    x86_64):
       libtiff-devel-4.0.9-5.27.5
       libtiff5-4.0.9-5.27.5
       libtiff5-debuginfo-4.0.9-5.27.5
       tiff-debuginfo-4.0.9-5.27.5
       tiff-debugsource-4.0.9-5.27.5


References:

  o https://www.suse.com/security/cve/CVE-2018-17000.html
  o https://www.suse.com/security/cve/CVE-2018-19210.html
  o https://www.suse.com/security/cve/CVE-2019-6128.html
  o https://www.suse.com/security/cve/CVE-2019-7663.html
  o https://bugzilla.suse.com/1108606
  o https://bugzilla.suse.com/1115717
  o https://bugzilla.suse.com/1121626
  o https://bugzilla.suse.com/1125113

- ------------------------------------------------------------------------------

SUSE Security Update: Security update for tiff

______________________________________________________________________________

Announcement ID:   SUSE-SU-2019:14002-1
Rating:            low
References:        #1121626 #983268
Cross-References:  CVE-2016-5102 CVE-2019-6128
Affected Products:
                   SUSE Linux Enterprise Software Development Kit 11-SP4
                   SUSE Linux Enterprise Server 11-SP4
                   SUSE Linux Enterprise Point of Sale 11-SP3
                   SUSE Linux Enterprise Debuginfo 11-SP4
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for tiff fixes the following issue:
Security vulnerabilities fixed:

  o CVE-2016-5102: Fixed a buffer overflow in readgifimage() (bsc#983268)
  o CVE-2019-6128: Fixed a memory leak in the TIFFFdOpen function in tif_unix.c
    (bsc#1121626)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  o SUSE Linux Enterprise Software Development Kit 11-SP4:
    zypper in -t patch sdksp4-tiff-14002=1
  o SUSE Linux Enterprise Server 11-SP4:
    zypper in -t patch slessp4-tiff-14002=1
  o SUSE Linux Enterprise Point of Sale 11-SP3:
    zypper in -t patch sleposp3-tiff-14002=1
  o SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-tiff-14002=1

Package List:

  o SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 ia64 ppc64
    s390x x86_64):
       libtiff-devel-3.8.2-141.169.31.1
  o SUSE Linux Enterprise Software Development Kit 11-SP4 (ppc64 s390x x86_64):
       libtiff-devel-32bit-3.8.2-141.169.31.1
  o SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):
       libtiff3-3.8.2-141.169.31.1
       tiff-3.8.2-141.169.31.1
  o SUSE Linux Enterprise Server 11-SP4 (ppc64 s390x x86_64):
       libtiff3-32bit-3.8.2-141.169.31.1
  o SUSE Linux Enterprise Server 11-SP4 (ia64):
       libtiff3-x86-3.8.2-141.169.31.1
  o SUSE Linux Enterprise Point of Sale 11-SP3 (i586):
       libtiff3-3.8.2-141.169.31.1
       tiff-3.8.2-141.169.31.1
  o SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ia64 ppc64 s390x x86_64):
       tiff-debuginfo-3.8.2-141.169.31.1
       tiff-debugsource-3.8.2-141.169.31.1


References:

  o https://www.suse.com/security/cve/CVE-2016-5102.html
  o https://www.suse.com/security/cve/CVE-2019-6128.html
  o https://bugzilla.suse.com/1121626
  o https://bugzilla.suse.com/983268

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBXKKi12aOgq3Tt24GAQi7iBAA0sp80IuqqoO6BbOganmDWJ+RUPd/Rrt4
TSiMqd3HKPrI0fZXuV9gvfx23nGLd6WQwlj+j81Q5iSrK3s1hL2ziyBXauCftJlh
eKS28dKTdJU8/qs2d2emWXJo8QmZvdjXaHACOL0sdl5hNIhLOstFCH9DbHQGZq5F
ciAUawFWV0kjGFiGI+6N/q0BnTluSSPEbXSyB4ywwatBYm90s/CoAgqrh5h6T4d0
aav2xjVjzw8QS/KhNpiQZqS5BO+d4NCSf6DnQZ9sYSuERjsrBZlvANQod3VvYVxd
QVKR4256vj9FHVzchvyGj4mXaoDjHcRzM7B992sNRg0OnoNbOzWRkiVR+KQZRQFj
H/D1GaaBmHsUP8TfYmO5Zq1Je1agiGQ37hsPGmlRul5sNqi+Zxv719iiccDEuo1f
k8A5vE2GxChDIUhOzNY1PkmA8Ry5ZtyA0zudBoCk7AwLOWd40772YAHGP4TU322o
ve8dctBMea2u8EtY+JISKZ7/R36PvbNJqExCbXYzGJXroemwGylNkeZqZw4ARZtu
6rHohtW/U81TINvyX+SEH/jB0JS2vzYgTfkOoDIX/MCfK46F9wJgPk+yTOPBgjnR
tEiL8vU4rs1bjdy8g7F74Ptyvebm0he+ffSKSklMiFGyr5Aw8Qxsi7jWsAfYLigw
gnBvqfZzGHc=
=f0xp
-----END PGP SIGNATURE-----

« Back to bulletins