ESB-2019.0982.2 - UPDATED ALERT [Win][UNIX/Linux] Confluence: Multiple vulnerabilities 2019-04-16

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                              ESB-2019.0982.2
                 Confluence Security Advisory - 2019-03-20
                               16 April 2019

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           Confluence Server
                   Confluence Data Center
Publisher:         Atlassian
Operating System:  UNIX variants (UNIX, Linux, OSX)
                   Windows
Impact/Access:     Execute Arbitrary Code/Commands -- Remote/Unauthenticated
                   Access Confidential Data        -- Remote/Unauthenticated
Resolution:        Patch/Upgrade
CVE Names:         CVE-2019-3396 CVE-2019-3395 

Original Bulletin: 
   https://confluence.atlassian.com/display/DOC/Confluence+Security+Advisory+-+2019-03-20

Revision History:  April 16 2019: ALERT due to exploit code for CVE-2019-3396 
                                  available where members could be adversely 
                                  affected from RCE. 
                   March 26 2019: Initial Release

- --------------------------BEGIN INCLUDED TEXT--------------------

This email refers to the advisory found at
https://confluence.atlassian.com/display/DOC/Confluence+Security+Advisory+-+2019-03-20


CVE ID:

* CVE-2019-3395.
* CVE-2019-3396.


Product: Confluence Server and Confluence Data Center.

Affected Confluence Server and Confluence Data Center product versions:

6.6.0 <= version < 6.6.12
6.12.0 <= version < 6.12.3
6.13.0 <= version < 6.13.3
6.14.0 <= version < 6.14.2


Fixed Confluence Server and Confluence Data Center product versions:

* for 6.6.x, Confluence Server and Data Center 6.6.12 have been
released with a fix for these issues.
* for 6.12.x, Confluence Server and Data Center 6.12.3 have been
released with a fix for these issues.
* for 6.13.x, Confluence Server and Data Center 6.13.3 have been
released with a fix for these issues.
* for 6.14.x, Confluence Server and Data Center 6.14.2 have been
released with a fix for these issues.


Summary:
This advisory discloses critical severity security vulnerabilities. Versions of
Confluence Server and Data Center before 6.6.12 (the fixed version for 6.6.x),
from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version
6.13.0 before 6.13.3 (the fixed version for 6.13.x) and from version 6.14.0
before 6.14.2 (the fixed version for 6.14.x) are affected by these
vulnerabilities.



Customers who have upgraded Confluence to version 6.6.12 or 6.12.3 or
6.13.3 or 6.14.2 are not affected.

Customers who have downloaded and installed Confluence >= 6.6.0 but less
than 6.6.12 (the fixed version for 6.6.x) or who have downloaded and installed
Confluence >= 6.12.0 but less than 6.12.3 (the fixed version for 6.12.x)
or who have downloaded and installed Confluence >= 6.13.0 but less than
6.13.3 (the fixed version for 6.13.x) or who have downloaded and installed
Confluence >= 6.14.0 but less than 6.14.2 (the fixed version for 6.14.x)
please upgrade your Confluence installations immediately to fix these
vulnerabilities.



WebDAV vulnerability (CVE-2019-3395)

Severity:
Atlassian rates the severity level of this vulnerability as critical, according
to the scale published in our Atlassian severity levels. The scale allows us to
rank the severity as critical, high, moderate or low.
This is our assessment and you should evaluate its applicability to your own IT
environment.


Description:

A remote attacker is able to exploit a Server-Side Request Forgery (SSRF)
vulnerability via the WebDAV plugin to send arbitrary HTTP and WebDAV requests
from a Confluence Server or Data Center instance.
Versions of Confluence before version 6.6.7 (the fixed version for
6.6.x), from version 6.7.0 before 6.7.3 (the fixed version for 6.7.x), from
version 6.8.0 before 6.8.5 (the fixed version for 6.8.x) and from version 6.9.0
before 6.9.3 (the fixed version for 6.9.x) are affected by this vulnerability.
This issue can be tracked at: https://jira.atlassian.com/browse/CONFSERVER-57971
.

Remote code execution via Widget Connector macro (CVE-2019-3396)

Severity:
Atlassian rates the severity level of this vulnerability as critical, according
to the scale published in our Atlassian severity levels. The scale allows us to
rank the severity as critical, high, moderate or low.
This is our assessment and you should evaluate its applicability to your own IT
environment.


Description:

There was a server-side template injection vulnerability in Confluence
via Widget Connector. An attacker is able to exploit this issue to achieve path
traversal and remote code execution on systems that run a vulnerable version of
Confluence.
Versions of Confluence before version 6.6.12 (the fixed version for
6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from
version 6.13.0 before 6.13.3 (the fixed version for 6.13.x) and from version
6.14.0 before 6.14.2 (the fixed version for 6.14.x) are affected by this
vulnerability. This issue can be tracked at:
https://jira.atlassian.com/browse/CONFSERVER-57974 .



Fix:

To address these issues, we have released the following versions of
Confluence Server and Data Center containing a fix:

* version 6.6.12
* version 6.12.3
* version 6.13.3
* version 6.14.2

Remediation:

Upgrade Confluence Server and Data Center to version 6.14.2 or higher.

The vulnerabilities and fix versions are described above. If affected, you
should upgrade to the latest version immediately.

If you are running Confluence Server and or Data Center 6.6.x and cannot
upgrade to 6.14.2, upgrade to version 6.6.12.
If you are running Confluence Server and or Data Center 6.12.x and cannot
upgrade to 6.14.2, to version 6.12.3.
If you are running Confluence Server and or Data Center 6.13.x and cannot
upgrade to 6.14.2, upgrade to version 6.13.3.


For a full description of the latest version of Confluence Server and
Data Center, see the release notes found at
https://confluence.atlassian.com/display/DOC/Confluence+Release+Notes. You can
download the latest version of Confluence Server and Confluence Data Center
from the download centre found at
https://www.atlassian.com/software/confluence/download.

Support:
If you have questions or concerns regarding this advisory, please raise a
support request at https://support.atlassian.com/.

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBXLUYHmaOgq3Tt24GAQj4JBAAxJPHTwSk0I/MqKU45Z+CmPGQGNjBaFaB
bWpoKYdqv9QPRNKIdIhTfNm/PbsVqajzAtoO8Lj1aeLoGtgGFvgCywF64F43xavd
Tu8o6vzQPsNKsUqWaKhGKqLLUVcyGn8u9a9zg74GzsazETnl+LCH95ox8Ylx9GAp
OfH12ETiUp4x0bWeysLiK0Z10xWiLRdB409f4KFM3hLrN1Us3N93LrK7n7uXOEzG
2B58GV0M/ySFbgXy9S3yZIL271GJYfecGRfvYVb+xOeuFh6o8QlGSg28OBCpg/Lg
uAssCUtMVl7C0a0b2liqEPygd/w1IMuCRNcT/Oeprl4L6XfYlQaCJyxcijwcr2Oi
TdE9m7OiAFBfGCj2NVUF9y5BL0HKSjszWQNGWTk/PbY3ztoXZW/8Y4xBZnqSzN3J
TOBRmANJsi1YkEDodzaWJoIauOjmwNalibRfJfoM+oWJS8HclWOIty52TvitnJTV
baNauPZAO3qh4euJH1HD1KYem80RYr9Xgn6yapn+BtHTLgpYGF9j23kjdURdgb3u
Qt8u8YrFCsyfdA6EsQRIkfhA+9MveO7FgZ5NGY6xDrcdg2rrnD3f3gc9gDNCN9Ce
uRscvtjpuBJIbXJtc7LpVlSmKRqoU4wcuW1lmTJXQPoFI5pp47Klr8W2JCOtzGf5
uKo5aZVifK4=
=gOeU
-----END PGP SIGNATURE-----

« Back to bulletins