ESB-2019.0400.2 - UPDATE [SUSE] LibVNCServer: Multiple vulnerabilities 2019-02-11

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                              ESB-2019.0400.2
                     Security update for LibVNCServer
                             11 February 2019

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           LibVNCServer
Publisher:         SUSE
Operating System:  SUSE
Impact/Access:     Execute Arbitrary Code/Commands -- Remote/Unauthenticated
                   Denial of Service               -- Remote/Unauthenticated
Resolution:        Patch/Upgrade
CVE Names:         CVE-2018-20750 CVE-2018-20749 CVE-2018-20748

Reference:         ESB-2019.0298
                   ESB-2019.0295

Original Bulletin: 
   https://www.suse.com/support/update/announcement/2019/suse-su-20190283-1/
   https://www.suse.com/support/update/announcement/2019/suse-su-20190313-1.html

Comment: This bulletin contains two (2) advisories.

Revision History:  February 11 2019: Updated affected products
                   February  8 2019: Initial Release

- --------------------------BEGIN INCLUDED TEXT--------------------

   SUSE Security Update: Security update for LibVNCServer
______________________________________________________________________________

Announcement ID:    SUSE-SU-2019:0283-1
Rating:             critical
References:         #1123823 #1123828 #1123832
Cross-References:   CVE-2018-20748 CVE-2018-20749 CVE-2018-20750

Affected Products:
                    SUSE Linux Enterprise Workstation Extension 15
                    SUSE Linux Enterprise Module for Packagehub Subpackages 15
                    SUSE Linux Enterprise Module for Open Buildservice
                    Development Tools 15
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for LibVNCServer fixes the following issues:

   Security issues fixed:

   - CVE-2018-20749: Fixed a heap out of bounds write vulnerability in
     rfbserver.c (bsc#1123828)
   - CVE-2018-20750: Fixed a heap out of bounds write vulnerability in
     rfbserver.c (bsc#1123832)
   - CVE-2018-20748: Fixed multiple heap out-of-bound writes in VNC client
     code (bsc#1123823)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation
   methods like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Workstation Extension 15:

      zypper in -t patch SUSE-SLE-Product-WE-15-2019-283=1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15:

      zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-2019-283=1

   - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-283=1



Package List:

   - SUSE Linux Enterprise Workstation Extension 15 (x86_64):

      LibVNCServer-debugsource-0.9.10-4.6.1
      libvncclient0-0.9.10-4.6.1
      libvncclient0-debuginfo-0.9.10-4.6.1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15 (aarch64 ppc64le
     s390x x86_64):

      LibVNCServer-debugsource-0.9.10-4.6.1
      libvncserver0-0.9.10-4.6.1
      libvncserver0-debuginfo-0.9.10-4.6.1

   - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
     (aarch64 ppc64le s390x x86_64):

      LibVNCServer-debugsource-0.9.10-4.6.1
      LibVNCServer-devel-0.9.10-4.6.1
      libvncserver0-0.9.10-4.6.1
      libvncserver0-debuginfo-0.9.10-4.6.1


References:

   https://www.suse.com/security/cve/CVE-2018-20748.html
   https://www.suse.com/security/cve/CVE-2018-20749.html
   https://www.suse.com/security/cve/CVE-2018-20750.html
   https://bugzilla.suse.com/1123823
   https://bugzilla.suse.com/1123828
   https://bugzilla.suse.com/1123832

- --------------------------------------------------------------------------------

   SUSE Security Update: Security update for LibVNCServer
______________________________________________________________________________

Announcement ID:    SUSE-SU-2019:0313-1
Rating:             critical
References:         #1123823 #1123828 #1123832 
Cross-References:   CVE-2018-20748 CVE-2018-20749 CVE-2018-20750
                   
Affected Products:
                    SUSE OpenStack Cloud 7
                    SUSE Linux Enterprise Software Development Kit 12-SP4
                    SUSE Linux Enterprise Software Development Kit 12-SP3
                    SUSE Linux Enterprise Server for SAP 12-SP2
                    SUSE Linux Enterprise Server 12-SP4
                    SUSE Linux Enterprise Server 12-SP3
                    SUSE Linux Enterprise Server 12-SP2-LTSS
                    SUSE Linux Enterprise Server 12-SP2-BCL
                    SUSE Linux Enterprise Server 12-SP1-LTSS
                    SUSE Linux Enterprise Server 12-LTSS
                    SUSE Enterprise Storage 4
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for LibVNCServer fixes the following issues:

   Security issues fixed:

   - CVE-2018-20749: Fixed a heap out of bounds write vulnerability in
     rfbserver.c (bsc#1123828)
   - CVE-2018-20750: Fixed a heap out of bounds write vulnerability in
     rfbserver.c (bsc#1123832)
   - CVE-2018-20748: Fixed multiple heap out-of-bound writes in VNC client
     code (bsc#1123823)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud 7:

      zypper in -t patch SUSE-OpenStack-Cloud-7-2019-313=1

   - SUSE Linux Enterprise Software Development Kit 12-SP4:

      zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-313=1

   - SUSE Linux Enterprise Software Development Kit 12-SP3:

      zypper in -t patch SUSE-SLE-SDK-12-SP3-2019-313=1

   - SUSE Linux Enterprise Server for SAP 12-SP2:

      zypper in -t patch SUSE-SLE-SAP-12-SP2-2019-313=1

   - SUSE Linux Enterprise Server 12-SP4:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-313=1

   - SUSE Linux Enterprise Server 12-SP3:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-2019-313=1

   - SUSE Linux Enterprise Server 12-SP2-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-2019-313=1

   - SUSE Linux Enterprise Server 12-SP2-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2019-313=1

   - SUSE Linux Enterprise Server 12-SP1-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2019-313=1

   - SUSE Linux Enterprise Server 12-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-2019-313=1

   - SUSE Enterprise Storage 4:

      zypper in -t patch SUSE-Storage-4-2019-313=1



Package List:

   - SUSE OpenStack Cloud 7 (s390x x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      libvncclient0-0.9.9-17.11.1
      libvncclient0-debuginfo-0.9.9-17.11.1
      libvncserver0-0.9.9-17.11.1
      libvncserver0-debuginfo-0.9.9-17.11.1

   - SUSE Linux Enterprise Software Development Kit 12-SP4 (aarch64 ppc64le s390x x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      LibVNCServer-devel-0.9.9-17.11.1

   - SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le s390x x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      LibVNCServer-devel-0.9.9-17.11.1

   - SUSE Linux Enterprise Server for SAP 12-SP2 (ppc64le x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      libvncclient0-0.9.9-17.11.1
      libvncclient0-debuginfo-0.9.9-17.11.1
      libvncserver0-0.9.9-17.11.1
      libvncserver0-debuginfo-0.9.9-17.11.1

   - SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      libvncclient0-0.9.9-17.11.1
      libvncclient0-debuginfo-0.9.9-17.11.1
      libvncserver0-0.9.9-17.11.1
      libvncserver0-debuginfo-0.9.9-17.11.1

   - SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      libvncclient0-0.9.9-17.11.1
      libvncclient0-debuginfo-0.9.9-17.11.1
      libvncserver0-0.9.9-17.11.1
      libvncserver0-debuginfo-0.9.9-17.11.1

   - SUSE Linux Enterprise Server 12-SP2-LTSS (ppc64le s390x x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      libvncclient0-0.9.9-17.11.1
      libvncclient0-debuginfo-0.9.9-17.11.1
      libvncserver0-0.9.9-17.11.1
      libvncserver0-debuginfo-0.9.9-17.11.1

   - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      libvncclient0-0.9.9-17.11.1
      libvncclient0-debuginfo-0.9.9-17.11.1
      libvncserver0-0.9.9-17.11.1
      libvncserver0-debuginfo-0.9.9-17.11.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (ppc64le s390x x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      libvncclient0-0.9.9-17.11.1
      libvncclient0-debuginfo-0.9.9-17.11.1
      libvncserver0-0.9.9-17.11.1
      libvncserver0-debuginfo-0.9.9-17.11.1

   - SUSE Linux Enterprise Server 12-LTSS (ppc64le s390x x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      libvncclient0-0.9.9-17.11.1
      libvncclient0-debuginfo-0.9.9-17.11.1
      libvncserver0-0.9.9-17.11.1
      libvncserver0-debuginfo-0.9.9-17.11.1

   - SUSE Enterprise Storage 4 (x86_64):

      LibVNCServer-debugsource-0.9.9-17.11.1
      libvncclient0-0.9.9-17.11.1
      libvncclient0-debuginfo-0.9.9-17.11.1
      libvncserver0-0.9.9-17.11.1
      libvncserver0-debuginfo-0.9.9-17.11.1


References:

   https://www.suse.com/security/cve/CVE-2018-20748.html
   https://www.suse.com/security/cve/CVE-2018-20749.html
   https://www.suse.com/security/cve/CVE-2018-20750.html
   https://bugzilla.suse.com/1123823
   https://bugzilla.suse.com/1123828
   https://bugzilla.suse.com/1123832

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBXGC4iGaOgq3Tt24GAQgBqRAAvK1NTca5WnNKPn3ebhHR4Ajv1cFgWmx2
q6tj9b4oxmVIrQ9h0WsD60Jrkm3wcL2CDqTuRygaRoClunKyi6fZzU4JGSNr0DP2
dTmJj3/ShynNjKWHtVDrgFvFjxKXHKm1ZbmHPWd9jHQXOB2sBwJYzsbec8h+xgiK
Q+JAsuIzL2PoUbvRsxXlRdJCMJ798CB4lUzi+kDJKc4T4AUwupCjQTE8XRiRJHGR
wVn3K52WroHsSxwSj+8yuGK8Gie5U4ZkimkrLYxBp2Kel4QmCkObuQ1oMqbD0uYY
xz7TNqpkThcQldxT2YIoU6bskbWKJHYvrP+VdGOe54sRBFAwslWziclmkYZvnKJU
ecAsnjn91jqEY4WHLSHB1kUmKdBL0AQGgyP9LZLTtB2+5KGfBFKGefOG4dtBeXhq
uf+xYxMXu7fJfP+4VQCupf7/hZLpTGw4B/ibqzv2ZAb6ssWvTn13x8AgnY6R6vbE
lAM0AKLEAUDm+WTg4qgoZ7NLnFBoQAH4J2+SOGI5yJ5Kx02dG1bkDAUdBmo+MU7K
xxGhL7v8ZfmdIdKI7r3yjukp+e0p1U4mdtlOIb8UdgTnw9DGTzs636vxXwo+98cJ
9xreePGOZynhDO4sroIVFrmIDv3dKv1dmvWaUDS1ARf+upY/RGJDd/tNYyvRxjxb
rpKEBG+ybA0=
=Oj69
-----END PGP SIGNATURE-----

« Back to bulletins