ESB-2018.3433 - [Win][Linux][AIX] IBM Digital Business Automation Workflow: Multiple vulnerabilities 2018-11-02

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2018.3433
Multiple vulnerabilities have been identified in IBM WebSphere Application
       Server shipped with IBM Digital Business Automation Workflow
                              family products
                              2 November 2018

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           IBM Digital Business Automation Workflow
Publisher:         IBM
Operating System:  AIX
                   Linux variants
                   Windows
Impact/Access:     Cross-site Scripting     -- Existing Account      
                   Unauthorised Access      -- Remote/Unauthenticated
                   Access Confidential Data -- Existing Account      
Resolution:        Patch/Upgrade
CVE Names:         CVE-2018-1794 CVE-2018-1793 CVE-2018-1777
                   CVE-2018-1770 CVE-2014-7810 

Reference:         ESB-2018.3333
                   ESB-2018.3324
                   ESB-2018.3320
                   ESB-2018.3284
                   ESB-2018.3243
                   ESB-2018.3240
                   ESB-2018.3222
                   ESB-2018.3215

Original Bulletin: 
   https://www.ibm.com/support/docview.wss?uid=ibm10735823
   https://www.ibm.com/support/docview.wss?uid=ibm10735663
   https://www.ibm.com/support/docview.wss?uid=ibm10735825
   https://www.ibm.com/support/docview.wss?uid=ibm10735659
   https://www.ibm.com/support/docview.wss?uid=ibm10735821

Comment: This bulletin contains five (5) IBM security advisories.

- --------------------------BEGIN INCLUDED TEXT--------------------

Security Bulletin: A vulnerability has been identified in IBM WebSphere
Application Server shipped with IBM Digital Business Automation Workflow family
products (CVE-2018-1793)

Document information

More support for: IBM Business Automation Workflow

Software version: 18.0.0.0, 18.0.0.1

Operating system(s): AIX, Linux, Windows

Reference #: 0735823

Modified date: 01 November 2018

Security Bulletin


Summary

WebSphere Application Server is shipped as a component of IBM Business
Automation Workflow, IBM Business Process Manager, and IBM Business Process
Manager Enterprise Service Bus. Information about a security vulnerability
affecting IBM WebSphere Application Server Traditional have been published in a
security bulletin.

Vulnerability Details

Please consult the security bulletin Cross-site scripting vulnerability in SAML
ear in WebSphere Application Server (CVE-2018-1793) vulnerability details and
information about fixes.

Affected Products and Versions

- - IBM Business Automation Workflow V18.0.0.0 through V18.0.0.1

- - IBM Business Process Manager V8.6.0.0 through V8.6.0.0 Cumulative Fix 2018.03

- - IBM Business Process Manager V8.5.7.0 through V8.5.7.0 Cumulative Fix 2017.06

- - IBM Business Process Manager V8.5.6.0 through V8.5.6.0 CF2

- - IBM Business Process Manager V8.5.5.0

- - IBM Business Process Manager V8.5.0.0 through V8.5.0.2

- - IBM Business Process Manager V8.0.0.0 through V8.0.1.3

- - IBM Business Process Manager V7.5.0.0 through V7.5.1.2

- - IBM Business Process Manager Enterprise Service Bus V8.6.0.0

- - WebSphere Enterprise Service Bus Registry Edition V7.5.0.0 through V7.5.1.2

- - WebSphere Lombardi Edition V7.2.0.0 through V7.2.0.5 (and earlier unsupported
releases)

- - WebSphere Enterprise Service Bus V7.0.0.0 through V7.0.0.5

- - WebSphere Enterprise Service Bus Registry Edition V7.0.0.0 through V7.0.0.5

- - WebSphere Enterprise Service Bus V7.5.0.0 through V7.5.1.2


Note that Cumulative Fixes cannot automatically install interim fixes for the
base Application Server. It is important to follow the complete installation
instructions and manually ensure that recommended security fixes are installed.


For earlier and unsupported versions of the products, IBM recommends upgrading
to a fixed, supported version of the product.

Workarounds and Mitigations

None

Important Note

IBM strongly suggests that all System z customers be subscribed to the System z
Security Portal to receive the latest critical System z security and integrity
service. If you are not subscribed, see the instructions on the System z
Security web site. Security and integrity APARs and associated fixes will be
posted to this portal. IBM suggests reviewing the CVSS scores and applying all
security or integrity fixes as soon as possible to minimize any potential risk.

Reference

Complete CVSS v3 Guide
On-line Calculator v3

Related Information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Change History

01 November 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY
OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF
ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

- ---

Security Bulletin: A vulnerability has been identified in IBM WebSphere
Application Server shipped with IBM Digital Business Automation Workflow family
products (CVE-2018-1770)

Document information

More support for: IBM Business Automation Workflow

Software version: 18.0.0.0, 18.0.0.1

Operating system(s): AIX, Linux, Windows

Reference #: 0735663

Modified date: 01 November 2018

Security Bulletin


Summary

WebSphere Application Server is shipped as a component of IBM Business
Automation Workflow, IBM Business Process Manager, and IBM Business Process
Manager Enterprise Service Bus. Information about a security vulnerability
affecting IBM WebSphere Application Server Traditional have been published in a
security bulletin.

Vulnerability Details

Please consult the security bulletin Potential traversal vulnerability in IBM
WebSphere Application Server Admin Console (CVE-2018-1770) vulnerability
details and information about fixes.

Affected Products and Versions

- - IBM Business Automation Workflow V18.0.0.0 through V18.0.0.1

- - IBM Business Process Manager V8.6.0.0 through V8.6.0.0 Cumulative Fix 2018.03

- - IBM Business Process Manager V8.5.7.0 through V8.5.7.0 Cumulative Fix 2017.06

- - IBM Business Process Manager V8.5.6.0 through V8.5.6.0 CF2

- - IBM Business Process Manager V8.5.5.0

- - IBM Business Process Manager V8.5.0.0 through V8.5.0.2

- - IBM Business Process Manager V8.0.0.0 through V8.0.1.3

- - IBM Business Process Manager V7.5.0.0 through V7.5.1.2

- - IBM Business Process Manager Enterprise Service Bus V8.6.0.0

- - WebSphere Enterprise Service Bus Registry Edition V7.5.0.0 through V7.5.1.2

- - WebSphere Lombardi Edition V7.2.0.0 through V7.2.0.5 (and earlier unsupported
releases)

- - WebSphere Enterprise Service Bus V7.0.0.0 through V7.0.0.5

- - WebSphere Enterprise Service Bus Registry Edition V7.0.0.0 through V7.0.0.5

- - WebSphere Enterprise Service Bus V7.5.0.0 through V7.5.1.2


Note that Cumulative Fixes cannot automatically install interim fixes for the
base Application Server. It is important to follow the complete installation
instructions and manually ensure that recommended security fixes are installed.


For earlier and unsupported versions of the products, IBM recommends upgrading
to a fixed, supported version of the product.

Workarounds and Mitigations

None

Important Note

IBM strongly suggests that all System z customers be subscribed to the System z
Security Portal to receive the latest critical System z security and integrity
service. If you are not subscribed, see the instructions on the System z
Security web site. Security and integrity APARs and associated fixes will be
posted to this portal. IBM suggests reviewing the CVSS scores and applying all
security or integrity fixes as soon as possible to minimize any potential risk.

Reference

Complete CVSS v3 Guide
On-line Calculator v3

Related Information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Change History

01 November 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY
OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF
ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

- ---

Security Bulletin: A vulnerability has been identified in IBM WebSphere
Application Server shipped with IBM Digital Business Automation Workflow family
products (CVE-2018-1777)

Document information

More support for: IBM Business Automation Workflow

Software version: 18.0.0.0, 18.0.0.1

Operating system(s): AIX, Linux, Windows

Reference #: 0735825

Modified date: 01 November 2018

Security Bulletin


Summary

WebSphere Application Server is shipped as a component of IBM Business
Automation Workflow, IBM Business Process Manager, and IBM Business Process
Manager Enterprise Service Bus. Information about a security vulnerability
affecting IBM WebSphere Application Server Traditional have been published in a
security bulletin.

Vulnerability Details

Please consult the security bulletin Potential cross-site scripting
vulnerability in the WebSphere Application Server Admin Console (CVE-2018-1777)
 vulnerability details and information about fixes.

Affected Products and Versions

- - IBM Business Automation Workflow V18.0.0.0 through V18.0.0.1

- - IBM Business Process Manager V8.6.0.0 through V8.6.0.0 Cumulative Fix 2018.03

- - IBM Business Process Manager V8.5.7.0 through V8.5.7.0 Cumulative Fix 2017.06

- - IBM Business Process Manager V8.5.6.0 through V8.5.6.0 CF2

- - IBM Business Process Manager V8.5.5.0

- - IBM Business Process Manager V8.5.0.0 through V8.5.0.2

- - IBM Business Process Manager V8.0.0.0 through V8.0.1.3

- - IBM Business Process Manager V7.5.0.0 through V7.5.1.2

- - IBM Business Process Manager Enterprise Service Bus V8.6.0.0

- - WebSphere Enterprise Service Bus Registry Edition V7.5.0.0 through V7.5.1.2

- - WebSphere Lombardi Edition V7.2.0.0 through V7.2.0.5 (and earlier unsupported
releases)

- - WebSphere Enterprise Service Bus V7.0.0.0 through V7.0.0.5

- - WebSphere Enterprise Service Bus Registry Edition V7.0.0.0 through V7.0.0.5

- - WebSphere Enterprise Service Bus V7.5.0.0 through V7.5.1.2


Note that Cumulative Fixes cannot automatically install interim fixes for the
base Application Server. It is important to follow the complete installation
instructions and manually ensure that recommended security fixes are installed.


For earlier and unsupported versions of the products, IBM recommends upgrading
to a fixed, supported version of the product.

Workarounds and Mitigations

None

Important Note

IBM strongly suggests that all System z customers be subscribed to the System z
Security Portal to receive the latest critical System z security and integrity
service. If you are not subscribed, see the instructions on the System z
Security web site. Security and integrity APARs and associated fixes will be
posted to this portal. IBM suggests reviewing the CVSS scores and applying all
security or integrity fixes as soon as possible to minimize any potential risk.

Reference

Complete CVSS v3 Guide
On-line Calculator v3

Related Information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Change History

01 November 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY
OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF
ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

- ---

Security Bulletin: A vulnerability has been identified in IBM WebSphere
Application Server shipped with IBM Digital Business Automation Workflow family
products (CVE-2014-7810)

Document information

More support for: IBM Business Automation Workflow

Software version: 18.0.0.0, 18.0.0.1

Operating system(s): AIX, Linux, Windows

Reference #: 0735659

Modified date: 01 November 2018

Security Bulletin


Summary

WebSphere Application Server Liberty is shipped as part of the optional
components Process Federation Server and User Management Service (new in BAW
18.0.0.1) in IBM Business Automation Workflow and IBM Business Process Manager.
Information about a security vulnerability affecting IBM WebSphere Application
Server Traditional and WebSphere Application Server Liberty have been published
in a security bulletin.

Vulnerability Details

Please consult the security bulletin Potential bypass security vulnerability in
Expression Language library used by WebSphere Application Server
(CVE-2014-7810) for vulnerability details and information about fixes.

Affected Products and Versions

- - IBM Business Automation Workflow V18.0.0.0 through V18.0.0.1

- - IBM Business Process Manager V8.6.0.0 through V8.6.0.0 Cumulative Fix 2018.03

- - IBM Business Process Manager V8.5.7.0 through V8.5.7.0 Cumulative Fix 2017.06

- - IBM Business Process Manager V8.5.6.0 through V8.5.6.0 CF2

- - IBM Business Process Manager V8.5.5.0

- - IBM Business Process Manager V8.5.0.0 through V8.5.0.2

- - IBM Business Process Manager V8.0.0.0 through V8.0.1.3

- - IBM Business Process Manager V7.5.0.0 through V7.5.1.2

- - IBM Business Process Manager Enterprise Service Bus V8.6.0.0

- - WebSphere Enterprise Service Bus Registry Edition V7.5.0.0 through V7.5.1.2

- - WebSphere Lombardi Edition V7.2.0.0 through V7.2.0.5 (and earlier unsupported
releases)

- - WebSphere Enterprise Service Bus V7.0.0.0 through V7.0.0.5

- - WebSphere Enterprise Service Bus Registry Edition V7.0.0.0 through V7.0.0.5

- - WebSphere Enterprise Service Bus V7.5.0.0 through V7.5.1.2


Note that Cumulative Fixes cannot automatically install interim fixes for the
base Application Server. It is important to follow the complete installation
instructions and manually ensure that recommended security fixes are installed.


For earlier and unsupported versions of the products, IBM recommends upgrading
to a fixed, supported version of the product.

Workarounds and Mitigations

None

Important Note

IBM strongly suggests that all System z customers be subscribed to the System z
Security Portal to receive the latest critical System z security and integrity
service. If you are not subscribed, see the instructions on the System z
Security web site. Security and integrity APARs and associated fixes will be
posted to this portal. IBM suggests reviewing the CVSS scores and applying all
security or integrity fixes as soon as possible to minimize any potential risk.

Reference

Complete CVSS v3 Guide
On-line Calculator v3

Related Information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Change History

01 November 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY
OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF
ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

- ---

Security Bulletin: A vulnerability has been identified in IBM WebSphere
Application Server shipped with IBM Digital Business Automation Workflow family
products (CVE-2018-1794)

Document information

More support for: IBM Business Automation Workflow

Software version: 18.0.0.0, 18.0.0.1

Operating system(s): AIX, Linux, Windows

Reference #: 0735821

Modified date: 01 November 2018

Security Bulletin


Summary

WebSphere Application Server is shipped as a component of IBM Business
Automation Workflow, IBM Business Process Manager, and IBM Business Process
Manager Enterprise Service Bus. Information about a security vulnerability
affecting IBM WebSphere Application Server Traditional have been published in a
security bulletin.

Vulnerability Details

Please consult the security bulletin Cross-site scripting vulnerability in
OAuth ear in WebSphere Application Server (CVE-2018-1794) vulnerability details
and information about fixes.

Affected Products and Versions

- - IBM Business Automation Workflow V18.0.0.0 through V18.0.0.1

- - IBM Business Process Manager V8.6.0.0 through V8.6.0.0 Cumulative Fix 2018.03

- - IBM Business Process Manager V8.5.7.0 through V8.5.7.0 Cumulative Fix 2017.06

- - IBM Business Process Manager V8.5.6.0 through V8.5.6.0 CF2

- - IBM Business Process Manager V8.5.5.0

- - IBM Business Process Manager V8.5.0.0 through V8.5.0.2

- - IBM Business Process Manager V8.0.0.0 through V8.0.1.3

- - IBM Business Process Manager V7.5.0.0 through V7.5.1.2

- - IBM Business Process Manager Enterprise Service Bus V8.6.0.0

- - WebSphere Enterprise Service Bus Registry Edition V7.5.0.0 through V7.5.1.2

- - WebSphere Lombardi Edition V7.2.0.0 through V7.2.0.5 (and earlier unsupported
releases)

- - WebSphere Enterprise Service Bus V7.0.0.0 through V7.0.0.5

- - WebSphere Enterprise Service Bus Registry Edition V7.0.0.0 through V7.0.0.5

- - WebSphere Enterprise Service Bus V7.5.0.0 through V7.5.1.2


Note that Cumulative Fixes cannot automatically install interim fixes for the
base Application Server. It is important to follow the complete installation
instructions and manually ensure that recommended security fixes are installed.


For earlier and unsupported versions of the products, IBM recommends upgrading
to a fixed, supported version of the product.

Workarounds and Mitigations

None

Important Note

IBM strongly suggests that all System z customers be subscribed to the System z
Security Portal to receive the latest critical System z security and integrity
service. If you are not subscribed, see the instructions on the System z
Security web site. Security and integrity APARs and associated fixes will be
posted to this portal. IBM suggests reviewing the CVSS scores and applying all
security or integrity fixes as soon as possible to minimize any potential risk.

Reference

Complete CVSS v3 Guide
On-line Calculator v3

Related Information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Change History

01 November 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY
OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF
ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBW9ubAGaOgq3Tt24GAQjbPBAA1TA+K4GiOfHtevZiCWGIzLnkOXpzPb5P
S1UkRMJ2X8YcOpLaj2m/buE+tA+esprv5mjmBUPDET+V0fFoZvPAQh0FkPIdXuD4
t3hsPzFwCEevNfjvqa3BSZpKAARdsIsnVVRkM9tYuy1VGZ5iFm6e6qPx3xw8+yuE
f2POLIrE7VL9Q6e2oE1eyvjqhhG14lzvdG49iYauBNeTtQGLprDrWtdNVs0Dm/1t
iLCNdrgx0N6SB1CZUWHaD0Yt8F7qqz5jSgXXNmEMqCNYqxvWqyW71XW6KB19CMjr
4vw39H6YC+MeIT8ek1o7f1th/uLE4IRPKFt30gX5Z4FazzcMmiCV0Yp33kEQlPAM
eE+DfQLcZZIkL6XJK+/P21gXEztzPXYAsBMHw6crRyFb5L8c56IIFLsKweMs6Nsl
1f+cUSBOut1c+lhRqm4qU6TXuhDwjk7y6DhhGdK9KaPaxx1Rgk/hcTp/z1jdtMBi
Q86tT/HdhBCYSIgtkI9n/LLJT2M+Vt8nPo5ViXBuEbdvTJbS8Hszzwcee7ZNnK7q
Wa5nGvkQ8WaPnnugw3iPVF/my4SeF0hoTYjAqCfstbuRlDB8tGIkIbkhGRYmrZt6
QOZAa/GG8uXvt7f222znGbGFAB4kr+9Uctie+wU39qh6p5v39HAzICq+fZJ0cZWl
L6fdNjs+gL4=
=2MU1
-----END PGP SIGNATURE-----

« Back to bulletins