ESB-2018.3295 - [Win] IBM IMS Enterprise Suite: Multiple vulnerabilities 2018-10-26

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2018.3295
  Security Bulletin: Vulnerability in IBM Java SDK affects IMS Enterprise
      Suite: Explorer for Development (CVE-2018-1656, CVE-2018-12539)
                              26 October 2018

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           IBM IMS Enterprise Suite
Publisher:         IBM
Operating System:  Windows
Impact/Access:     Execute Arbitrary Code/Commands -- Existing Account            
                   Create Arbitrary Files          -- Remote with User Interaction
Resolution:        Patch/Upgrade
CVE Names:         CVE-2018-12539 CVE-2018-1656 

Reference:         ESB-2018.3245
                   ESB-2018.3197
                   ESB-2018.3196
                   ESB-2018.3193
                   ESB-2018.3192
                   ESB-2018.3161
                   ESB-2018.3160

Original Bulletin: 
   https://www.ibm.com/support/docview.wss?uid=ibm10732027

- --------------------------BEGIN INCLUDED TEXT--------------------

Security Bulletin: Vulnerability in IBM Java SDK affects IMS(TM) Enterprise Suite:
Explorer for Development (CVE-2018-1656, CVE-2018-12539)

Document information

More support for: IMS Enterprise Suite

Component: IMS Enterprise Suite: Explorer for Development

Software version: 3.3.1, 3.2

Operating system(s): Windows

Reference #: 0732027

Modified date: 26 October 2018

Security Bulletin


Summary

There is a vulnerability in IBM(R) SDK Java(TM) Technology Edition, Version 8.0.5.15
and earlier that is used by IMS(TM) Enterprise Suite: Explorer for Development.
This issue was disclosed as part of the IBM Java SDK updates in July 2018.

Vulnerability Details

CVE-2018-1656 (CVSS 7.4)

Description

The IBM Java Runtime Environment's Diagnostic Tooling Framework for Java (DTFJ)
does not protect against path traversal attacks when extracting compressed dump
files.

The fix ensures that malicious zip files are handled gracefully.


CVE-2018-12539 (CVSS 8.4)

Description

The IBM Java Runtime Environment's Late Attach mechanism can be compromised by
an attacker with access to the same local environment as the target JVM. The
attack allows arbitrary code to be injected.

Various security enhancements ensure that the Late Attach mechanism cannot be
compromised in this way.

Affected Products and Versions

Explorer for Development of the IMS(TM) Enterprise Suite Versions 3.3.1 and
earlier.

Remediation/Fixes

    Product        VRMF       APAR    Download URL


IMS Enterprise                        https://developer.ibm.com/mainframe/products/
Suite Explorer   3.3.1.10     N/A     downloads/eclipse-tools/
for Development
     V3.3


IMS Enterprise                        https://developer.ibm.com/mainframe/products/
Suite Explorer                N/A     downloads/eclipse-tools/
for Development 3.2.1.16
     V3.2

Reference

Complete CVSS v3 Guide
On-line Calculator v3

Related Information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Acknowledgement

None

Change History

19 October 2018: Original version published.
26 October 2018: Updated with version 3.2.1.16.

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY
OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF
ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBW9Kn42aOgq3Tt24GAQgouxAAkJMqF2pzgj7c8YkMpLXNe6GPdEnecYF+
uN22tUCubDwOlyNqlh/Cu1JQI4MI67ffsgKW13ql3BJwmBjtUUgeAjhF1QTO+W/a
D3apBc3ErWYoGbGBIJ7oNuSHj2OTQCTATFj7anJ3T4QSMBCXsBetVvIMb+l6HcTj
VcHoa351zAfn9BoEZN7HWxLdnfjiEfV6quEMFnzO0SvlmzpITZgUmFOAW0AlQfGi
CdmtfZzQFVCbL/k/uNJnrsOYIPnCPCguBuXZIk62JpSsB6h6H35eJm4BFHjN1NGL
2T2jENN09zDrPkljj/eN/fXRe0UtBfR4G54ffE6DXqXRmeVoFfpsQW2hdVsfV9GX
mZOrt+tH16tSxFDwVX6kMEuUu3AUHeBsQ75BLzU1OYLzmf/6vI46py6EK/J7waiU
9lcRDHhwU0fh4mRP6N8pS8MaaxOphZf0jXcHCAInX1rLZGmV2brS3S8+8Yj+J9BN
D+VfRozISqIpujEFlFOiyr8CmvndAc4BWhLE7CAAUOGi7z9YF3rpd0xGEXr19REW
ktBpq3JQ9okEoR11YgR+daDjReG7k6JxTir1o2VU50JLckU2ngYSAxQ4GoROE7+9
DIEaM21m/ap4yVX2AJwysag21eB8MGsmDeTipSHwSxwE+N+ySvEqZJ2bRh2G2aUk
qHUmWSZdYb4=
=Gl4Q
-----END PGP SIGNATURE-----

« Back to bulletins