ESB-2018.3089 - [Win][Linux][IBM i][HP-UX][Solaris][AIX] IBM WebSphere Application Server: Unauthorised access - Remote/unauthenticated 2018-10-11

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2018.3089
 Security Bulletin: Potential bypass security vulnerability in Expression
   Language library used by WebSphere Application Server (CVE-2014-7810)
                              11 October 2018

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           IBM WebSphere Application Server
Publisher:         IBM
Operating System:  AIX
                   HP-UX
                   IBM i
                   Linux variants
                   Solaris
                   Windows
                   z/OS
Impact/Access:     Unauthorised Access -- Remote/Unauthenticated
Resolution:        Patch/Upgrade
CVE Names:         CVE-2014-7810  

Reference:         ESB-2016.0793
                   ESB-2016.0540
                   ESB-2015.3177
                   ESB-2015.2739

Original Bulletin: 
   http://www.ibm.com/support/docview.wss?uid=ibm10729557

- --------------------------BEGIN INCLUDED TEXT--------------------

Security Bulletin: Potential bypass security vulnerability in Expression
Language library used by WebSphere Application Server (CVE-2014-7810)

Document information

More support for: WebSphere Application Server

Software version: 7.0, 8.0, 8.5, 9.0, Liberty

Operating system(s): AIX, HP-UX, IBM i, Linux, Solaris, Windows, z/OS

Software edition: Advanced, Base, Developer, Enterprise, Express, Liberty,
Network Deployment, Single Server

Reference #: 0729557

Modified date: 10 October 2018

Summary

There is a potential bypass security vulnerability in the expression language
library used by WebSphere Application Server (CVE-2014-7810)

Vulnerability Details

CVEID: CVE-2014-7810
DESCRIPTION: Apache Tomcat could allow a remote attacker to bypass security
restrictions, caused by the use of expression language. An attacker could
exploit this vulnerability to bypass the protections of a Security Manager.
CVSS Base Score: 5
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/
103155 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:N/AC:L/Au:N/C:N/I:P/A:N)

Affected Products and Versions

This vulnerability affects the following versions and releases of IBM
WebSphere Application Server:

  o Liberty
  o Version 9.0
  o Version 8.5
  o Version 8.0
  o Version 7.0

Remediation/Fixes

The recommended solution is to apply the interim fix, Fix Pack or PTF
containing the APARs for each named product as soon as practical.

For WebSphere Application Server Liberty:
. Upgrade to minimal fix pack levels as required by interim fix and then apply
Interim Fix PH02063
- --OR--
. Apply Liberty Fix Pack 18.0.0.4 or later (targeted availability 4Q 2018)
 

For WebSphere Application Server traditional and WebSphere Application Server
Hypervisor Edition:

For V9.0.0.0 through 9.0.0.9:
. Upgrade to minimal fix pack levels as required by interim fix and then apply
Interim Fix PH02063
- --OR--
. Apply Fix Pack 9.0.0.10 or later (targeted availability 4Q 2018).

For V8.5.0.0 through 8.5.5.14:
. Upgrade to minimal fix pack levels as required by interim fix and then apply
Interim Fix PH02063
- --OR--
. Apply Fix Pack 8.5.5.15 or later (targeted availability 1Q 2019).

For V8.0.0.0 through 8.0.0.15:
. Upgrade to 8.0.0.15 and then apply Interim Fix PH02063

For V7.0.0.0 through 7.0.0.45:
. Upgrade to 7.0.0.45 and then apply Interim Fix PH02063

WebSphere Application Server V7 and V8 are no longer in full support; IBM
recommends upgrading to a fixed, supported version/release/platform of the
product.

Change History

10 October 2018: original document published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY
OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT
OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBW77DlWaOgq3Tt24GAQhMcBAApTxQLTMVgNYUh1Lmuy60TtHcVrEQYw8c
BuETM60Aatz/TYQnM52QTtRP7lhUlCvgJrIp6j0+YFhVIIpw7ffZ971AgsKNVfpX
KhOPicct0ybsyJa/9RUtm8WzfyqEwMoy5eowj6Z2aP7fb9ksHEECh8APNEQ57EHr
87tp+w/Y1FyRuHm80Fgh05u3RxlY3/AnHQiPpRCtHJj0shTRyv/DyeEhp6FzD/pp
typKQh+33dj7AvjD65S+UuC1nzGobkbKy5c+4lah1Rl+FbHCLcmfAD12srI1dgjS
4ByfDPGhleo8+bKxVfV3BenXna0uHEAgA9eBdFqvY1P9+Uui+LdrtCE3TwTDpd4Z
yWhBTi0uzrTshY1QGkQ1KGK2XWHO2hQPsQ9LlXqqXOTMQNHWO5i+/mlWCkdexeri
k/2+m3tkKkHQJ8V/prS+xF0cGOVZKXsdDhKjC9Nba3RGU+Q1CNpxYYqfxq87/hy8
FvGtoJZp7BxJWWcjpRoBh7hvk6h9jz4srMVCm2vSnDZjvan8M6bHmgCOpRPXfQ+8
jwfdEZIX7Rz0pB4lPlwAmEaFv8ua+I36jxOfnPMXxd9INOUxBsZF/fyoOivxwitB
Gbx2BAs1Agcawk27o2VH5YyDkB19S93S2m2aetlTWhUMg/xDOK0j2rbnLQQt8PUm
VzgfpMFoP5g=
=SpRY
-----END PGP SIGNATURE-----

« Back to bulletins