ESB-2018.2035 - [Win][Linux][HP-UX][Solaris][AIX] IBM Db2: Multiple vulnerabilities 2018-07-12

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2018.2035
               IBM Db2 tools patch security vulnerabilities
                               12 July 2018

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           IBM Db2
Publisher:         IBM
Operating System:  AIX
                   HP-UX
                   Linux variants
                   Solaris
                   Windows
Impact/Access:     Access Privileged Data          -- Remote/Unauthenticated
                   Execute Arbitrary Code/Commands -- Existing Account      
                   Increased Privileges            -- Existing Account      
Resolution:        Patch/Upgrade
CVE Names:         CVE-2018-1566 CVE-2018-1515 CVE-2018-1488
                   CVE-2017-3738 CVE-2017-3737 CVE-2016-0701

Reference:         ESB-2016.0905
                   ESB-2016.0250

Original Bulletin: 
   http://www.ibm.com/support/docview.wss?uid=swg22016141
   http://www.ibm.com/support/docview.wss?uid=swg22016140
   http://www.ibm.com/support/docview.wss?uid=swg22016182
   http://www.ibm.com/support/docview.wss?uid=ibm10716907

Comment: This bulletin contains four (4) IBM security advisories.

- --------------------------BEGIN INCLUDED TEXT--------------------

Security Bulletin: Buffer overflow in IBM Db2 tool db2licm (CVE-2018-1488).

Security Bulletin

Document information
Software version: 10.5, 11.1
Operating system(s): AIX, HP-UX, Linux, Solaris, Windows
Software edition: Advanced Enterprise Server, Advanced Workgroup Server,
Enterprise Server, Express, Express-C, Personal, Workgroup Server
Reference #: 2016141
Modified date: 11 July 2018

Summary

The Db2 tool db2licm is vulnerable to buffer overflow.

Vulnerability Details

CVEID: CVE-2018-1488
DESCRIPTION: IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server)
is vulnerable to a buffer overflow, which could allow an authenticated local
attacker to execute arbitrary code on the system as root.
CVSS Base Score: 8.4
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/
140973 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

All fix pack levels of IBM Db2 V10.5 and V11.1 editions on all platforms are
affected.

Remediation/Fixes

The recommended solution is to apply the appropriate fix for this
vulnerability.

FIX:
The fix for DB2 V11.1 is in V11.1.3.3 iFix001, available for download from Fix
Central.

Customers running any vulnerable fixpack level of an affected Program, V10.5,
can download the special build containing the interim fix for this issue from
Fix Central. These special builds are available based on the most recent
fixpack level for each impacted release: V10.5 FP9. They can be applied to any
affected fixpack level of the appropriate release to remediate this
vulnerability.
 

                                        
+----------------------------------------------------------------------------------------------+
|Release      |Fixed in |APAR     |Download URL                                                |
|             |fix pack |         |                                                            |
|-------------+---------+---------+------------------------------------------------------------|
|V10.5        |FP10     |IT24478  |https://www-01.ibm.com/support/docview.wss?uid=swg24045012  |
|-------------+---------+---------+------------------------------------------------------------|
|V11.1.3.3    |iFix001  |IT24473  |http://www-01.ibm.com/support/docview.wss?uid=swg24044872   |
+----------------------------------------------------------------------------------------------+


Note: The fix for the remaining platforms will be made available shortly.

Workarounds and Mitigations

None.

Acknowlegement

The vulnerability was reported to IBM by Rich Mirch.

Change History

May 22, 2018: Original Verson Published. July 11, 2018: Updated 10.5 version
with a link to 10.5 FP10 image.

- -------------------------------------------------------------------------------

Security Bulletin: Buffer overflow in the db2convert tool shipped with IBM
Db2 (CVE-2018-1515).

Security Bulletin

Document information
Software version: 10.5, 11.1
Operating system(s): AIX, HP-UX, Linux, Solaris, Windows
Software edition: Advanced Enterprise Server, Advanced Workgroup Server,
Enterprise Server, Express, Express-C, Personal, Workgroup Server
Reference #: 2016140
Modified date: 11 July 2018

Summary

The Db2 tool db2convert is affected by a buffer overflow vulnerability. As
installed this tool does not run with elevated privileges (setuid) and when
called directly the vulnerability does not lead to privilege escalation.
However, if a customer?s own application or script runs with elevated
privileges and executes db2convert, the vulnerability may lead to privilege
escalation. This tool is not called by Db2 in such a manner. The vulnerability
only exists for local users, it cannot be remotely exploited.

Vulnerability Details

CVEID: CVE-2018-1515
DESCRIPTION: IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server),
under specific or unusual conditions, could allow a local user to overflow a
buffer which may result in a privilege escalation to the DB2 instance owner.
CVSS Base Score: 7.4
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/
141624 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

All fix pack levels of IBM Db2 V10.5 and V11.1 editions on all platforms are
affected.

Remediation/Fixes

The recommended solution is to apply the appropriate fix for this
vulnerability.

FIX:
The fix for DB2 V11.1 is in V11.1.3.3 iFix001, available for download from Fix
Central.

Customers running any vulnerable fixpack level of an affected Program, V10.5,
can download the special build containing the interim fix for this issue from
Fix Central. These special builds are available based on the most recent
fixpack level for each impacted release: V10.5 FP9. They can be applied to any
affected fixpack level of the appropriate release to remediate this
vulnerability.

+----------------------------------------------------------------------------------------------+
|Release      |Fixed in |APAR     |Download URL                                                |
|             |fix pack |         |                                                            |
|-------------+---------+---------+------------------------------------------------------------|
|V10.5        |FP10     |IT24645  |https://www-01.ibm.com/support/docview.wss?uid=swg24045012  |
|-------------+---------+---------+------------------------------------------------------------|
|V11.1.3.3    |iFix001  |IT24642  |http://www-01.ibm.com/support/docview.wss?uid=swg24044872   |
+----------------------------------------------------------------------------------------------+

Workarounds and Mitigations

Customers can delete db2convert if not using this tool.

Change History

May 22, 2018: Original Version Published. July 11, 2018: Updated 10.5 version
with a link to 10.5 FP10 image.

- -------------------------------------------------------------------------------

Security Bulletin: Format string vulnerability in IBM Db2 tool db2support
(CVE-2018-1566).

Security Bulletin

Document information
Software version: 9.7, 10.1, 10.5, 11.1
Operating system(s): AIX, HP-UX, Linux, Solaris, Windows
Software edition: Advanced Enterprise Server, Advanced Workgroup Server,
Enterprise Server, Express, Express-C, Personal, Workgroup Server
Reference #: 2016182
Modified date: 11 July 2018

Summary

Db2 tool db2support is affected by format string vulnerability. As installed
this tool does not run with elevated privileges (setuid) and when called
directly the vulnerability does not lead to privilege escalation. However, if a
customer?s own application or script runs with elevated privileges and executes
db2support, the vulnerability may lead to privilege escalation. This tool is
not called by Db2 in such a manner. The vulnerability only exists for local
users, it cannot be remotely exploited.

Vulnerability Details

CVEID: CVE-2018-1566
DESCRIPTION: IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server)
could allow a local user to execute arbitrary code due to a format string
error.
CVSS Base Score: 8.4
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/
143023 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

All fix pack levels of IBM Db2 V9.7, V10.1, V10.5, and V11.1 editions on all
platforms are affected.

Remediation/Fixes

The recommended solution is to apply the appropriate fix for this
vulnerability.

FIX:

Customers running any vulnerable fixpack level of an affected Program, V9.7,
V10.1, and V10.5, can download the special build containing the interim fix for
this issue from Fix Central. These special builds are available based on the
most recent fixpack level for each impacted release: DB2 V9.7 FP11, V10.1 FP6,
V10.5 FP9 and V11.1.3 iFix001. They can be applied to any affected fixpack
level of the appropriate release to remediate this vulnerability.

+----------------------------------------------------------------------------------------------+
|Release      |Fixed in |APAR     |Download URL                                                |
|             |fix pack |         |                                                            |
|-------------+---------+---------+------------------------------------------------------------|
|V9.7         |TBD      |IT24826  |Special Build for V9.7 FP11:                                |
|             |         |         |                                                            |
|             |         |         |AIX 64-bit                                                  |
|             |         |         |HP-UX 64-bit                                                |
|             |         |         |Linux 32-bit, x86-32                                        |
|             |         |         |Linux 64-bit, x86-64                                        |
|             |         |         |Linux 64-bit, POWER? big endian                             |
|             |         |         |Linux 64-bit, System z?, System z9? or zSeries?             |
|             |         |         |Solaris 64-bit, SPARC                                       |
|             |         |         |Solaris 64-bit, x86-64                                      |
|             |         |         |Windows 32-bit, x86                                         |
|             |         |         |Windows 64-bit, x86                                         |
|-------------+---------+---------+------------------------------------------------------------|
|V10.1        |TBD      |IT24825  |Special Build for V10.1 FP6:                                |
|             |         |         |                                                            |
|             |         |         |AIX 64-bit                                                  |
|             |         |         |HP-UX 64-bit                                                |
|             |         |         |Linux 32-bit, x86-32                                        |
|             |         |         |Linux 64-bit, x86-64                                        |
|             |         |         |Linux 64-bit, POWER? big endian                             |
|             |         |         |Linux 64-bit, System z?, System z9? or zSeries?             |
|             |         |         |Solaris 64-bit, SPARC                                       |
|             |         |         |Solaris 64-bit, x86-64                                      |
|             |         |         |Windows 32-bit, x86                                         |
|             |         |         |Windows 64-bit, x86                                         |
|-------------+---------+---------+------------------------------------------------------------|
|V10.5        |FP10     |IT24824  |https://www-01.ibm.com/support/docview.wss?uid=swg24045012  |
|-------------+---------+---------+------------------------------------------------------------|
|V11.1.3      |TBD      |IT24823  |Special Build for V11.1.3.3 iFix001:                        |
|             |         |         |                                                            |
|             |         |         |AIX 64-bit                                                  |
|             |         |         |Linux 32-bit, x86-32                                        |
|             |         |         |Linux 64-bit, x86-64                                        |
|             |         |         |Linux 64-bit, POWER? little endian                          |
|             |         |         |Linux 64-bit, System z?, System z9? or zSeries?             |
|             |         |         |Solaris 64-bit, SPARC                                       |
|             |         |         |Windows 32-bit, x86                                         |
|             |         |         |Windows 64-bit, x86                                         |
+----------------------------------------------------------------------------------------------+

Workarounds and Mitigations

None.

Change History

July 6, 2018: Original Version Published. July 6, 2018: Db2 V10.1 Windows
32-bit download link added. July 10, 2018: Db2 V9.7 Windows 32-bit and 64-bit
download link added. July 11, 2018: Updated 10.5 version with a link to 10.5
FP10 image.

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY
OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF
ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

- --------------------------------------------------------------------------------

Security Bulletin: Vulnerability in OpenSSL affects FlashCopy Manager shipped
with IBM Db2 LUW (CVE-2017-3738, CVE-2017-3737).

Security Bulletin

Document information
Software version: 10.1, 10.5, 11.1
Operating system(s): AIX, Linux
Reference #: 0716907
Modified date: 11 July 2018

Summary

Security vulnerabilities have been identified in OpenSSL that affect IBM Tivoli
Storage FlashCopy Manager (FCM) shipped as a component of IBM Db2.

Vulnerability Details

CVEID: CVE-2017-3738
DESCRIPTION: OpenSSL could allow a remote attacker to obtain sensitive
information, caused by an overflow bug in the AVX2 Montgomery multiplication
procedure used in exponentiation with 1024-bit moduli. An attacker could
exploit this vulnerability to obtain information about the private key. Note:
In order to exploit this vulnerability, the server would have to share the
DH1024 private key among multiple clients, which is no longer an option since
CVE-2016-0701.
CVSS Base Score: 3.1
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/
136078 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N)

CVEID: CVE-2017-3737
DESCRIPTION: An unspecified vulnerability in multiple Oracle products could
allow an unauthenticated attacker to cause low confidentiality impact, low
integrity impact, and high availability impact.
CVSS Base Score: 5.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/
136077 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)

Affected Products and Versions

IBM Db2 Advanced Copy Services included in IBM Db2 and Db2 Connect v10.1, v10.5
and v11.1 server editions running on AIX and Linux are affected.

Only users of DB2 Advanced Copy Services (snapshot backup) are affected by this
vulnerability. IBM Db2 includes a restricted version of IBM Tivoli Storage
FlashCopy Manager, i.e. FCM v4.1, the version affected by this vulnerability.
IBM Db2 Advanced Copy Services in conjunction with IBM Tivoli Storage FCM 4.1,
on all current fix packs of IBM Db2 v10.1, v10.5 and v11.1, are affected. AIX
installations of Db2 may have this package installed by default, though it may
not be in use on the system. FCM is not automatically installed on Linux and
other platforms for IBM Db2 v11.1.

Remediation/Fixes

If you use Db2 Advanced Copy Services (snapshot backup) with the restricted
version of FCM included with Db2, then obtain the updated and remediated
restricted version of FCM (v.4 1).

The FCM package containing the fix for Db2 v11.1 and Db2 v10.5 can be found on
Passport Advantage .

+-------------------------------------------------------------------------------+
|Package Name                           |Part Number                            |
|---------------------------------------+---------------------------------------|
|IBM? FlashCopy Limited function for AIX|CNUR4ML                                |
|SDK for AIX? (DB2_FC_11.1_AIX)         |                                       |
|---------------------------------------+---------------------------------------|
|IBM? FlashCopy Limited function for    |CNUR5ML                                |
|xLinux SDK for Linux? on AMD64 and     |                                       |
|Intel? EM64T systems (x64), for AIX?   |                                       |
|(DB2_FC_11.1_Linux)                    |                                       |
+-------------------------------------------------------------------------------+

The FCM package containing the fix For Db2 v10.5 can be found in Fix Central
for v10.5 by searching for the keyword FCM.

+-----------------------------------------------------------------------------+
|Platform  |Description                                                       |
|----------+------------------------------------------------------------------|
|AIX       |DB2 10.5 Fix Pack 10 for AIX (64 bit), Aix distros for FCM        |
|----------+------------------------------------------------------------------|
|Linux     |DB2 10.5 Fix Pack 10 for Linux/x86-64 (64 bit), Linux distros for |
|          |FCM                                                               |
+-----------------------------------------------------------------------------+

The FCM packages for Db2 v10.5 can be used with both Db2 v10.1 and Db2 v10.5 on
any fix pack.

Please note that for the AIX platform, Db2 v10.1 and Db2 v10.5 up to FP8,
installing the fixpack will overwrite the FCM in sqllib/acs with a vulnerable
version of FCM. You need to reapply the FCM fix after each fixpack update. As
of Db2 v10.5 FP9, fixpack updates will remove all files under the directory
sqllib/acs. You will need to install the latest FCM after each fixpack update.

For installation instructions, please follow the documentation provided within
the IBM Db2 information center:

http://www-01.ibm.com/support/knowledgecenter/SSEPGG_10.1.0/
com.ibm.db2.luw.admin.ha.doc/doc/c0053160.html

Workarounds and Mitigations

None.

Change History

July 11, 2018: Original version published.

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY
OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF
ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBW0br6maOgq3Tt24GAQhaCw//aI932b9BHKEGVgCMel1jDkHng0+PRMOU
LCsGQvTIFMU4/9P2AWg4kRFGXqZyIxoukO185uKDVqXcX5zWtOFTpt+GoyNLCzft
UvxWvFoSMtIPo45oZm/iI8aejdvxZKyzg7V9GaDJY2PQBN2rbA0zqlAsOQcTN0ex
qLEA7+C+G+S5LhIW36G5iSgX04PlA0JXmnZ0ydfa5jvF9efK+C6o2Raf0atwcAUR
utK5RWfjNr5jgZgyGkEj8zlewWPPQ5TZrN2ioqf4GpMj/F/driRWnpFRdok1wUCF
THCPsDhvzDaDqoCGBXSPnf/JZhyAV5YsdZ9D36+ta8D1zvp3mjd/xmOAV7keRq04
aY9YzmuLdxjJ143R5RQ1IRA9UI0djQDtHIwmwH4Q/5kX4g+LRKb5EN5xGHIVlTVn
9uawCM1EnaHvlafZefVWQOIU7iGdS5nOXKw/1uPnTvk9PcUTo2XWPc2MlfDMNAYR
hYforoA/UXVwv/B1WefHzSBQo8gtUXrMTpB44RX3n7gb1579X8JV8Wjf1FvzniG0
6+y7akacPJuc+UD2txR2S1zVJn0mTaDt/Un4pF1O7squeNIrhC70bjASHXJNEg/A
ZfL24d0V6QlWxALRMTZUTNk1A+gOT08swfvtJTItrdnNUKHe9pVOq2Mf5VMCpCrH
6D3BhwlaETo=
=d52R
-----END PGP SIGNATURE-----

« Back to bulletins