ESB-2018.1953.2 - UPDATE [Debian] mercurial: Multiple vulnerabilities 2018-07-30

Printable version
PGP/GPG verifiable version

Hash: SHA256

             AUSCERT External Security Bulletin Redistribution

                  [DLA 1414-1] mercurial security update
                               30 July 2018


        AusCERT Security Bulletin Summary

Product:           mercurial
Publisher:         Debian
Operating System:  Debian GNU/Linux 8
Impact/Access:     Execute Arbitrary Code/Commands -- Remote with User Interaction
                   Unauthorised Access             -- Remote/Unauthenticated      
Resolution:        Patch/Upgrade
CVE Names:         CVE-2018-1000132 CVE-2017-17458 CVE-2017-9462

Reference:         ESB-2017.2211

Original Bulletin:

Revision History:  July 30 2018: Fixed regression introduced by update for CVE-2017-17458
                   July  6 2018: Initial Release

- --------------------------BEGIN INCLUDED TEXT--------------------

Package        : mercurial
Version        : 3.1.2-2+deb8u6
CVE ID         : CVE-2017-17458

The fix for arbitrary code execution documented in CVE-2017-17458 was
incomplete in the previous upload. A more exhaustive change was
implemented upstream and completely disables non-Mercurial
subrepositories unless users changed the subrepos.allowed setting.

For Debian 8 "Jessie", this problem has been fixed in version

We recommend that you upgrade your mercurial packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:

- ---

Package        : mercurial
Version        : 3.1.2-2+deb8u5
CVE ID         : CVE-2017-9462 CVE-2017-17458 CVE-2018-1000132
Debian Bug     : 861243 892964 901050

Some security vulnerabilities were found in Mercurial which allow
authenticated users to trigger arbitrary code execution and
unauthorized data access in certain server configuration. Malformed
patches and repositories can also lead to crashes and arbitrary code
execution on clients.


    In Mercurial before 4.1.3, "hg serve --stdio" allows remote
    authenticated users to launch the Python debugger, and
    consequently execute arbitrary code, by using --debugger as a
    repository name.


    In Mercurial before 4.4.1, it is possible that a specially
    malformed repository can cause Git subrepositories to run
    arbitrary code in the form of a .git/hooks/post-update script
    checked into the repository. Typical use of Mercurial prevents
    construction of such repositories, but they can be created


    Mercurial version 4.5 and earlier contains a Incorrect Access
    Control (CWE-285) vulnerability in Protocol server that can result
    in Unauthorized data access. This attack appear to be exploitable
    via network connectivity. This vulnerability appears to have been
    fixed in 4.5.1.


    mpatch: be more careful about parsing binary patch data


    mpatch: protect against underflow in mpatch_apply


    mpatch: ensure fragment start isn't past the end of orig

For Debian 8 "Jessie", these problems have been fixed in version

We recommend that you upgrade your mercurial packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

Australian Computer Emergency Response Team
The University of Queensland
Qld 4072

Internet Email:
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.


« Back to bulletins