ESB-2018.1520.2 - UPDATE [Win][Linux][IBM i][Solaris][AIX] IBM WebSphere Commerce: Multiple vulnerabilities 2018-05-18

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                              ESB-2018.1520.2
             IBM WebSphere Commerce receives security updates
                                18 May 2018

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           IBM WebSphere Commerce
Publisher:         IBM
Operating System:  AIX
                   IBM i
                   Linux variants
                   Solaris
                   Windows
Impact/Access:     Access Privileged Data          -- Remote/Unauthenticated      
                   Execute Arbitrary Code/Commands -- Remote with User Interaction
                   Denial of Service               -- Remote/Unauthenticated      
Resolution:        Patch/Upgrade
CVE Names:         CVE-2018-1301 CVE-2017-15715 CVE-2017-15710
                   CVE-2017-1741 CVE-2017-1681 

Reference:         ESB-2018.1502
                   ESB-2018.1295
                   ESB-2018.0334
                   ESB-2018.0309
                   ESB-2018.0294

Original Bulletin: 
   http://www.ibm.com/support/docview.wss?uid=swg22013944
   http://www.ibm.com/support/docview.wss?uid=swg22016279
   http://www.ibm.com/support/docview.wss?uid=swg22016245
   http://www.ibm.com/support/docview.wss?uid=swg22016244
   http://www.ibm.com/support/docview.wss?uid=swg22014986

Comment: This bulletin contains five (5) IBM security advisories.

Revision History:  May 18 2018: Added the HTTP Server advisory.
                   May 17 2018: Initial Release

- --------------------------BEGIN INCLUDED TEXT--------------------

Security Bulletin: A Security Vulnerability has been Identified in IBM
WebSphere Application Server Shipped with IBM WebSphere Commerce
(CVE-2017-1681)

Security Bulletin

Document information
Software version: 7.0, 8.0
Operating system(s): AIX, IBM i, Linux, Solaris, Windows
Software edition: All Editions
Reference #: 2013944
Modified date: 16 May 2018

Summary

IBM WebSphere Application Server is shipped as a component of IBM WebSphere
Commerce. Information about a potential security vulnerability affecting the
WebSphere Application Server was published in a security bulletin.

Vulnerability Details

Consult the security bulletin Information disclosure in WebSphere Application
Server (CVE-2017-1681) for vulnerability details and information about fixes.

Affected Products and Versions

WebSphere Commerce versions 7.0.0.0 or higher fix pack
WebSphere Commerce versions 8.0.0.0 or higher fix pack or higher mod pack

Remediation/Fixes

+-----------------------------------------------------------------------------+
|Principal Product  |Affected Supporting Product |Affected Supporting Product |
|and Version(s)     |and Version                 |Security Bulletin           |
|-------------------+----------------------------+----------------------------|
|WebSphere Commerce |WebSphere Application Server|Information disclosure in   |
|V7.0               |7.0.0                       |WebSphere Application Server|
|                   |WebSphere Application Server|(CVE-2017-1681)             |
|                   |8.5.5                       |                            |
|-------------------+----------------------------+----------------------------|
|WebSphere Commerce |WebSphere Application Server|Information disclosure in   |
|V8.0               |8.5.5                       |WebSphere Application Server|
|                   |                            |(CVE-2017-1681)             |
+-----------------------------------------------------------------------------+

Workarounds and Mitigations

None

Change History

16 May 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF
ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY
ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

                          Cross reference information
Segment        Product        Component      Platform      Version   Edition
Commerce WebSphere Commerce   Security  Windows            8.0,    All Editions
         Developer Enterprise                              7.0
Commerce WebSphere Commerce   Security  AIX, IBM i, Linux, 8.0,    Professional
         Professional                   Solaris, Windows   7.0     Edition
Commerce WebSphere Commerce - Security  IBM i, Linux,      7.0     Express
         Express                        Windows

- -------------------------------------------------------------------------------

Security Bulletin: A Security Vulnerability has been Identified in IBM
WebSphere Application Server Shipped with IBM WebSphere Commerce
(CVE-2017-1741)

Security Bulletin

Document information
Software version: 7.0, 8.0
Operating system(s): AIX, IBM i, Linux, Solaris, Windows
Software edition: All Editions
Reference #: 2016279
Modified date: 16 May 2018

Summary

IBM WebSphere Application Server is shipped as a component of IBM WebSphere
Commerce. Information about a potential security vulnerability affecting the
WebSphere Application Server was published in a security bulletin

Vulnerability Details

Consult the security bulletin Information disclosure in WebSphere Application
Server Admin Console (CVE-2017-1741) for vulnerability details and information
about fixes.

Affected Products and Versions

WebSphere Commerce versions 7.0.0.0 or higher fix pack
WebSphere Commerce versions 8.0.0.0 or higher fix pack or higher mod pack

Remediation/Fixes

+-----------------------------------------------------------------------------+
|Principal Product  |Affected Supporting Product |Affected Supporting Product |
|and Version(s)     |and Version                 |Security Bulletin           |
|-------------------+----------------------------+----------------------------|
|WebSphere Commerce |WebSphere Application Server|Information disclosure in   |
|V7.0               |7.0.0                       |WebSphere Application Server|
|                   |WebSphere Application Server|Admin Console               |
|                   |8.5.5                       |(CVE-2017-1741)             |
|-------------------+----------------------------+----------------------------|
|WebSphere Commerce |WebSphere Application Server|Information disclosure in   |
|V8.0               |8.5.5                       |WebSphere Application Server|
|                   |                            |Admin Console               |
|                   |                            |(CVE-2017-1741)             |
+-----------------------------------------------------------------------------+

Workarounds and Mitigations

None

Change History

16 May 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF
ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY
ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

                          Cross reference information
Segment        Product        Component      Platform      Version   Edition
Commerce WebSphere Commerce - Security  IBM i, Linux,      7.0     Express
         Express                        Windows
Commerce WebSphere Commerce   Security  Windows            8.0,    All Editions
         Developer Enterprise                              7.0
Commerce WebSphere Commerce   Security  AIX, IBM i, Linux, 8.0,    Professional
         Professional                   Solaris, Windows   7.0     Edition


- -------------------------------------------------------------------------------

Security Bulletin: Multiple Security Vulnerabilities have been Identified in
IBM HTTP Server Shipped with WebSphere Commerce (CVE-2017-15710,
CVE-2017-15715, CVE-2018-1301)

Security Bulletin

Document information
Software version: 7.0, 8.0
Operating system(s): AIX, IBM i, Linux, Solaris, Windows
Software edition: All Editions
Reference #: 2016245
Modified date: 16 May 2018

Summary

IBM HTTP Server is shipped as a component of WebSphere Commerce. Information
about multiple security vulnerabilities affecting IBM HTTP Server was published
in a security bulletin.

Vulnerability Details

Consult the security bulletin Multiple vulnerabilities in the IBM HTTP Server
(CVE-2017-15710, CVE-2017-15715, CVE-2018-1301) for vulnerability details and
information about fixes.

Affected Products and Versions

WebSphere Commerce versions 8.0.0.0 or higher fix pack or higher mod pack
WebSphere Commerce versions 7.0.0.0 - 7.0.0.9

Remediation/Fixes

+-----------------------------------------------------------------------------+
|Principal Product  |Affected Supporting Product |Affected Supporting Product |
|and Version(s)     |and Version                 |Security Bulletin           |
|-------------------+----------------------------+----------------------------|
|WebSphere Commerce |IBM HTTP Server             |Multiple vulnerabilities in |
|V7.0               |                            |the IBM HTTP Server         |
|                   |  * Version 7               |(CVE-2017-15710,            |
|                   |  * Version 8.5.5           |CVE-2017-15715,             |
|                   |                            |CVE-2018-1301)              |
|-------------------+----------------------------+----------------------------|
|WebSphere Commerce |IBM HTTP Server             |Multiple vulnerabilities in |
|V8.0               |                            |the IBM HTTP Server         |
|                   |  * Version 8.5.5           |(CVE-2017-15710,            |
|                   |                            |CVE-2017-15715,             |
|                   |                            |CVE-2018-1301)              |
+-----------------------------------------------------------------------------+

Workarounds and Mitigations

None

Change History

16 May 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF
ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY
ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

                          Cross reference information
Segment        Product        Component      Platform      Version   Edition
Commerce WebSphere Commerce -           IBM i, Linux,      7.0     Express
         Express                        Windows
Commerce WebSphere Commerce   Security  Windows            8.0,    All Editions
         Developer Enterprise                              7.0
Commerce WebSphere Commerce             AIX, IBM i, Linux, 8.0,    Professional
         Professional                   Solaris, Windows   7.0     Edition


- -------------------------------------------------------------------------------

Security Bulletin: Multiple Vulnerabilities in IBM Java SDK Affect WebSphere
Application Server January 2017 CPU Shipped with WebSphere Commerce

Security Bulletin

Document information
Software version: 7.0, 8.0
Operating system(s): AIX, IBM i, Linux, Solaris, Windows
Software edition: Enterprise
Reference #: 2016244
Modified date: 16 May 2018

Summary

IBM Java SDK included with WebSphere Application Server is shipped as a
component of WebSphere Commerce. Information about multiple security
vulnerabilities affecting IBM Java SDK has been published in a security
bulletin.

Vulnerability Details

Consult the security bulletin Multiple Vulnerabilities in IBM? Java SDK affects
WebSphere Application Server January 2018 CPU for vulnerability details and
information about fixes.

Affected Products and Versions

WebSphere Commerce versions 8.0.0.0 or higher fix pack or higher mod pack
WebSphere Commerce versions 7.0.0.0 - 7.0.0.9

Remediation/Fixes

+-----------------------------------------------------------------------------+
|Principal Product  |Affected Supporting Product |Affected Supporting Product |
|and Version(s)     |and Version                 |Security Bulletin           |
|-------------------+----------------------------+----------------------------|
|WebSphere Commerce |WebSphere Application Server|Multiple Vulnerabilities in |
|V7.0               |7.0.0                       |IBM? Java SDK affects       |
|                   |WebSphere Application Server|WebSphere Application Server|
|                   |8.5.5                       |January 2018 CPU            |
|-------------------+----------------------------+----------------------------|
|WebSphere Commerce |WebSphere Application Server|Multiple Vulnerabilities in |
|V8.0               |8.5.5                       |IBM? Java SDK affects       |
|                   |                            |WebSphere Application Server|
|                   |                            |January 2018 CPU            |
+-----------------------------------------------------------------------------+

Workarounds and Mitigations

None

Change History

16 May 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF
ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY
ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

                          Cross reference information
Segment        Product        Component      Platform      Version   Edition
Commerce WebSphere Commerce - Security  IBM i, Linux,      7.0     Express
         Express                        Windows
Commerce WebSphere Commerce   Security  AIX, IBM i, Linux, 8.0,    Professional
         Professional                   Solaris, Windows   7.0     Edition
Commerce WebSphere Commerce   Security  Windows            8.0,    All Editions
         Developer Enterprise                              7.0

- --------------------------------------------------------------------------------

Security Bulletin: A Security Vulnerability has been Identified in IBM HTTP
Server Shipped with WebSphere Commerce (CVE-2017-12613)

Security Bulletin

Document information
Software version: 7.0, 8.0
Operating system(s): AIX, IBM i, Linux, Solaris, Windows
Software edition: All Editions
Reference #: 2014986
Modified date: 17 May 2018

Summary

IBM HTTP Server is shipped as a component of WebSphere Commerce. Information
about a security vulnerability affecting IBM HTTP Server was published in a
security bulletin.

Vulnerability Details

Consult the security bulletin Information disclosure in IBM HTTP Server
(CVE-2017-12613) for vulnerability details and information about fixes.

Affected Products and Versions

WebSphere Commerce versions 8.0.0.0 or higher fix pack or higher mod pack
WebSphere Commerce versions 7.0.0.0 - 7.0.0.9

Remediation/Fixes

+-----------------------------------------------------------------------------+
|Principal Product  |Affected Supporting Product |Affected Supporting Product |
|and Version(s)     |and Version                 |Security Bulletin           |
|-------------------+----------------------------+----------------------------|
|WebSphere Commerce |IBM HTTP Server             |Information disclosure in   |
|V7.0               |                            |IBM HTTP Server             |
|                   |  * Version 7               |(CVE-2017-12613)            |
|                   |  * Version 8.5.5           |                            |
|-------------------+----------------------------+----------------------------|
|WebSphere Commerce |IBM HTTP Server             |Information disclosure in   |
|V8.0               |                            |IBM HTTP Server             |
|                   |  * Version 8.5.5           |(CVE-2017-12613)            |
+-----------------------------------------------------------------------------+

Workarounds and Mitigations

None

Change History

17 May 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF
ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY
ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

                          Cross reference information
Segment        Product        Component      Platform      Version   Edition
Commerce WebSphere Commerce - Security  IBM i, Linux,      7.0     Express
         Express                        Windows
Commerce WebSphere Commerce   Security  Windows            8.0,    All Editions
         Developer Enterprise                              7.0
Commerce WebSphere Commerce   Security  AIX, IBM i, Linux, 8.0,    Professional
         Professional                   Solaris, Windows   7.0     Edition

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBWv4ua4x+lLeg9Ub1AQg+/g/+OtuawJ992woyaOosI77lmHDjYbJygwou
psgQ/O1eNJmDCvZNAp8cqF0RgwkCq6u4oo3+bkBwanxwQrqzwyg6RHqW+XFPTMeR
+di17g6JOL/7/D2J9elfk8ruChaek0kKzM8hGJu0r7cfuqfBmj7CWNVMwiecd3Ow
l80ppHSReBvYBt7YEcp+HD82vxxa7LiP2rfLuYskgc1UO0bd/4UFeZjpjIyAfF7q
MwT5B+KL722kxinCFPY4MAHLOqTBJ8+m2RIFnsQhCrTaufH0GDV7b4XYSiLIckqI
H7svdy5pEOx4yQjpIcqQdESoSIaB9ITDNLBExdnWC6Wi5pxgTwED0GKXes521wLW
VAUa3z183CC4am0Otqb+wQjo/TdXiNuKiC/kYdmHXQ6fLuU2OH0wBsqOJjZE88Hc
ZgcABtWxMzP0EBdxzay1MADAZerPYxEkhgjF6vGTv3Lji/xSyk40Aqw+qWl4nlJn
AhhMeolTWxU0xQirNyO9Gm6VscbfuSxkhK6en0f5e7igq1aP4QWAXpRnqdgB5SG+
WRM84U925GjjbJKc/RM/qw1kBLx7f3RmTmDUC2hHVsC5P5CgyEvtvrtwcbnJwktu
Xojsmjh6+DIHWv00Z13i9YBKJl4XpWTcUEnARK6X9uYWqH0V2cyldlBEEU6PSOpB
IOtU2DhudFU=
=0IL1
-----END PGP SIGNATURE-----

« Back to bulletins