ESB-2018.1022 - [Appliance] F5 BIG-IP Products: Execute arbitrary code/commands - Remote/unauthenticated 2018-04-05

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2018.1022
                K16920:OpenSSL vulnerability CVE-2014-8176
                               5 April 2018

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           F5 BIG-IP Products
Publisher:         F5 Networks
Operating System:  Network Appliance
Impact/Access:     Execute Arbitrary Code/Commands -- Remote/Unauthenticated
                   Denial of Service               -- Remote/Unauthenticated
Resolution:        Patch/Upgrade
CVE Names:         CVE-2014-8176  

Reference:         ASB-2015.0081
                   ASB-2015.0065
                   ESB-2015.3100
                   ESB-2015.2696
                   ESB-2015.2491

Original Bulletin: 
   https://support.f5.com/csp/article/K16920

- --------------------------BEGIN INCLUDED TEXT--------------------

K16920:OpenSSL vulnerability CVE-2014-8176

Security Advisory

Original Publication Date: 08 Jul, 2015

Latest   Publication Date: 05 Apr, 2018

Security Advisory Description

The dtls1_clear_queues function in ssl/d1_lib.c in OpenSSL before 0.9.8za,
1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h frees data structures without
considering that application data can arrive between a ChangeCipherSpec
message and a Finished message, which allows remote DTLS peers to cause a
denial of service (memory corruption and application crash) or possibly have
unspecified other impact via unexpected application data. (CVE-2014-8176)

Impact

A malicious Datagram Transport Layer Security (DTLS) client or server can send
a specially crafted message to the peer, which may cause the application to
stop responding or can result in arbitrary code execution.


Security Advisory Status

F5 Product Development has assigned ID 527641 (BIG-IP) to this vulnerability
and has evaluated the currently supported releases for potential
vulnerability.

To determine if your release is known to be vulnerable, the components or
features that are affected by the vulnerability, and for information about
releases or hotfixes that address the vulnerability, refer to the following
table.

+--------------+----------+----------+----------+----------------------------+
|              |Versions  |Versions  |          |                            |
|Product       |known to  |known to  |Severity  |Vulnerable component or     |
|              |be        |be not    |          |feature                     |
|              |vulnerable|vulnerable|          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |          |13.1.0    |          |                            |
|              |          |12.0.0 -  |          |                            |
|              |          |12.1.3    |          |Control plane:              |
|              |          |11.5.2 -  |          |*The BIG-IP sod daemon is   |
|              |11.5.0 -  |11.6.3    |          |vulnerable if using Common  |
|              |11.5.1    |11.5.1 HF3|High      |Criteria mode, or when the  |
|              |          |11.5.0 HF4|          |failover.secure database    |
|              |          |11.0.0 -  |          |variable is enabled.        |
|              |          |11.4.1    |          |                            |
|BIG-IP LTM    |          |10.1.0 -  |          |                            |
|              |          |10.2.4    |          |                            |
|              |          |          |          |                            |
|              +----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |11.5.0 -  |13.1.0    |          |Data plane:                 |
|              |11.5.1    |12.0.0 -  |          |UDP virtual servers using   |
|              |11.0.0 -  |12.1.3    |High      |Client SSL or Server SSL    |
|              |11.4.1    |11.5.2 -  |          |profiles that enable with   |
|              |10.1.0 -  |11.6.3    |          |COMPAT ciphers are          |
|              |10.2.4    |11.5.1 HF3|          |vulnerable.                 |
|              |          |11.5.0 HF4|          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |          |13.1.0    |          |                            |
|              |          |12.0.0 -  |          |                            |
|              |          |12.1.3    |          |Control plane:              |
|              |          |11.5.2 -  |          |*The BIG-IP sod daemon is   |
|              |11.5.0 -  |11.6.3    |          |vulnerable if using Common  |
|              |11.5.1    |11.5.1 HF3|High      |Criteria mode, or when the  |
|              |          |11.5.0 HF4|          |failover.secure database    |
|              |          |11.0.0 -  |          |variable is enabled.        |
|              |          |11.4.1    |          |                            |
|BIG-IP AAM    |          |10.1.0 -  |          |                            |
|              |          |10.2.4    |          |                            |
|              |          |          |          |                            |
|              +----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |11.5.0 -  |13.1.0    |          |Data plane:                 |
|              |11.5.1    |12.0.0 -  |          |UDP virtual servers using   |
|              |11.0.0 -  |12.1.3    |High      |Client SSL or Server SSL    |
|              |11.4.1    |11.5.2 -  |          |profiles that enable with   |
|              |10.1.0 -  |11.6.3    |          |COMPAT ciphers are          |
|              |10.2.4    |11.5.1 HF3|          |vulnerable.                 |
|              |          |11.5.0 HF4|          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |          |13.1.0    |          |                            |
|              |          |12.0.0 -  |          |Control plane:              |
|              |          |12.1.3    |          |*The BIG-IP sod daemon is   |
|              |11.5.0 -  |11.5.2 -  |          |vulnerable if using Common  |
|              |11.5.1    |11.6.3    |High      |Criteria mode, or when the  |
|              |          |11.5.1 HF3|          |failover.secure database    |
|              |          |11.5.0 HF4|          |variable is enabled.        |
|              |          |11.3.0 -  |          |                            |
|BIG-IP AFM    |          |11.4.1    |          |                            |
|              |          |          |          |                            |
|              +----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |          |13.1.0    |          |Data plane:                 |
|              |11.5.0 -  |12.0.0 -  |          |UDP virtual servers using   |
|              |11.5.1    |12.1.3    |High      |Client SSL or Server SSL    |
|              |11.3.0 -  |11.5.2 -  |          |profiles that enable with   |
|              |11.4.1    |11.6.3    |          |COMPAT ciphers are          |
|              |          |11.5.1 HF3|          |vulnerable.                 |
|              |          |11.5.0 HF4|          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |          |13.1.0    |          |                            |
|              |          |12.0.0 -  |          |Control plane:              |
|              |          |12.1.3    |          |*The BIG-IP sod daemon is   |
|BIG-IP        |11.5.0 -  |11.5.2 -  |          |vulnerable if using Common  |
|Analytics     |11.5.1    |11.6.3    |High      |Criteria mode, or when the  |
|              |          |11.5.1 HF3|          |failover.secure database    |
|              |          |11.5.0 HF4|          |variable is enabled.        |
|              |          |11.0.0 -  |          |                            |
|              |          |11.4.1    |          |                            |
|              |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |          |13.1.0    |          |                            |
|              |          |12.0.0 -  |          |                            |
|              |          |12.1.3    |          |Control plane:              |
|              |          |11.5.2 -  |          |*The BIG-IP sod daemon is   |
|              |11.5.0 -  |11.6.3    |          |vulnerable if using Common  |
|              |11.5.1    |11.5.1 HF3|High      |Criteria mode, or when the  |
|              |          |11.5.0 HF4|          |failover.secure database    |
|              |          |11.0.0 -  |          |variable is enabled.        |
|              |          |11.4.1    |          |                            |
|BIG-IP APM    |          |10.1.0 -  |          |                            |
|              |          |10.2.4    |          |                            |
|              |          |          |          |                            |
|              +----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |11.5.0 -  |13.1.0    |          |Data plane:                 |
|              |11.5.1    |12.0.0 -  |          |UDP virtual servers using   |
|              |11.0.0 -  |12.1.3    |High      |Client SSL or Server SSL    |
|              |11.4.1    |11.5.2 -  |          |profiles that enable with   |
|              |10.1.0 -  |11.6.3    |          |COMPAT ciphers are          |
|              |10.2.4    |11.5.1 HF3|          |vulnerable.                 |
|              |          |11.5.0 HF4|          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |          |13.1.0    |          |                            |
|              |          |12.0.0 -  |          |                            |
|              |          |12.1.3    |          |Control plane:              |
|              |          |11.5.2 -  |          |*The BIG-IP sod daemon is   |
|              |11.5.0 -  |11.6.3    |          |vulnerable if using Common  |
|              |11.5.1    |11.5.1 HF3|High      |Criteria mode, or when the  |
|              |          |11.5.0 HF4|          |failover.secure database    |
|              |          |11.0.0 -  |          |variable is enabled.        |
|              |          |11.4.1    |          |                            |
|BIG-IP ASM    |          |10.1.0 -  |          |                            |
|              |          |10.2.4    |          |                            |
|              |          |          |          |                            |
|              +----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |11.5.0 -  |13.1.0    |          |Data plane:                 |
|              |11.5.1    |12.0.0 -  |          |UDP virtual servers using   |
|              |11.0.0 -  |12.1.3    |High      |Client SSL or Server SSL    |
|              |11.4.1    |11.5.2 -  |          |profiles that enable with   |
|              |10.1.0 -  |11.6.3    |          |COMPAT ciphers are          |
|              |10.2.4    |11.5.1 HF3|          |vulnerable.                 |
|              |          |11.5.0 HF4|          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|BIG-IP DNS    |None      |13.1.0    |Not       |None                        |
|              |          |12.0.0 -  |vulnerable|                            |
|              |          |12.1.3    |          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |          |          |Data plane:                 |
|              |11.0.0 -  |          |          |UDP virtual servers using   |
|BIG-IP Edge   |11.3.0    |None      |High      |Client SSL or Server SSL    |
|Gateway       |10.1.0 -  |          |          |profiles that enable with   |
|              |10.2.4    |          |          |COMPAT ciphers are          |
|              |          |          |          |vulnerable.                 |
+--------------+----------+----------+----------+----------------------------+
+--------------+----------+----------+----------+----------------------------+
|              |          |11.5.2 -  |          |                            |
|              |          |11.6.3    |          |Control plane:              |
|              |          |11.5.1 HF3|          |*The BIG-IP sod daemon is   |
|              |11.5.0 -  |11.5.0 HF4|          |vulnerable if using Common  |
|BIG-IP GTM    |11.5.1    |11.0.0 -  |High      |Criteria mode, or when the  |
|              |          |11.4.1    |          |failover.secure database    |
|              |          |10.1.0 -  |          |variable is enabled.        |
|              |          |10.2.4    |          |                            |
|              |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |          |13.1.0    |          |                            |
|              |          |12.0.0 -  |          |                            |
|              |          |12.1.3    |          |Control plane:              |
|              |          |11.5.2 -  |          |*The BIG-IP sod daemon is   |
|BIG-IP Link   |11.5.0 -  |11.6.3    |          |vulnerable if using Common  |
|Controller    |11.5.1    |11.5.1 HF3|High      |Criteria mode, or when the  |
|              |          |11.5.0 HF4|          |failover.secure database    |
|              |          |11.0.0 -  |          |variable is enabled.        |
|              |          |11.4.1    |          |                            |
|              |          |10.1.0 -  |          |                            |
|              |          |10.2.4    |          |                            |
|              |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |          |13.1.0    |          |                            |
|              |          |12.0.0 -  |          |Control plane:              |
|              |          |12.1.3    |          |*The BIG-IP sod daemon is   |
|              |11.5.0 -  |11.5.2 -  |          |vulnerable if using Common  |
|              |11.5.1    |11.6.3    |High      |Criteria mode, or when the  |
|              |          |11.5.1 HF3|          |failover.secure database    |
|              |          |11.5.0 HF4|          |variable is enabled.        |
|              |          |11.3.0 -  |          |                            |
|BIG-IP PEM    |          |11.4.1    |          |                            |
|              |          |          |          |                            |
|              +----------+----------+----------+----------------------------+
|              |          |13.0.0 -  |          |                            |
|              |          |13.1.0    |          |Data plane:                 |
|              |11.5.0 -  |12.0.0 -  |          |UDP virtual servers using   |
|              |11.5.1    |12.1.3    |High      |Client SSL or Server SSL    |
|              |11.3.0 -  |11.5.2 -  |          |profiles that enable with   |
|              |11.4.1    |11.6.3    |          |COMPAT ciphers are          |
|              |          |11.5.1 HF3|          |vulnerable.                 |
|              |          |11.5.0 HF4|          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |          |          |Data plane:                 |
|              |11.0.0 -  |          |          |UDP virtual servers using   |
|              |11.4.1    |          |          |Client SSL or Server SSL    |
|BIG-IP PSM    |10.1.0 -  |None      |High      |profiles that enable with   |
|              |10.2.4    |          |          |COMPAT ciphers are          |
|              |          |          |          |vulnerable.                 |
|              |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |          |          |Data plane:                 |
|              |11.0.0 -  |          |          |UDP virtual servers using   |
|BIG-IP        |11.3.0    |          |          |Client SSL or Server SSL    |
|WebAccelerator|10.1.0 -  |None      |High      |profiles that enable with   |
|              |10.2.4    |          |          |COMPAT ciphers are          |
|              |          |          |          |vulnerable.                 |
|              |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |          |          |Data plane:                 |
|              |11.0.0 -  |          |          |UDP virtual servers using   |
|              |11.3.0    |          |          |Client SSL or Server SSL    |
|BIG-IP WOM    |10.1.0 -  |None      |High      |profiles that enable with   |
|              |10.2.4    |          |          |COMPAT ciphers are          |
|              |          |          |          |vulnerable.                 |
|              |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|ARX           |None      |6.0.0 -   |Not       |None                        |
|              |          |6.4.0     |vulnerable|                            |
+--------------+----------+----------+----------+----------------------------+
|Enterprise    |None      |3.0.0 -   |Not       |None                        |
|Manager       |          |3.1.1     |vulnerable|                            |
+--------------+----------+----------+----------+----------------------------+
|FirePass      |None      |7.0.0     |Not       |None                        |
|              |          |6.1.0     |vulnerable|                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IQ Cloud  |None      |4.0.0 -   |Not       |None                        |
|              |          |4.5.0     |vulnerable|                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IQ Device |None      |4.2.0 -   |Not       |None                        |
|              |          |4.5.0     |vulnerable|                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IQ        |None      |4.0.0 -   |Not       |None                        |
|Security      |          |4.5.0     |vulnerable|                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IQ ADC    |None      |4.5.0     |Not       |None                        |
|              |          |          |vulnerable|                            |
+--------------+----------+----------+----------+----------------------------+
|LineRate      |None      |2.5.0 -   |Not       |None                        |
|              |          |2.6.2     |vulnerable|                            |
+--------------+----------+----------+----------+----------------------------+
|F5 WebSafe    |None      |1.0.0     |Not       |None                        |
|              |          |          |vulnerable|                            |
+--------------+----------+----------+----------+----------------------------+
|              |          |4.0.0 -   |          |                            |
|Traffix SDC   |None      |5.1.0     |Not       |None                        |
|              |          |3.3.2 -   |vulnerable|                            |
|              |          |3.5.1     |          |                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IP Edge   |          |2.0.0 -   |Not       |                            |
|Clients for   |None      |2.0.8     |vulnerable|None                        |
|Android       |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IP Edge   |          |2.0.0 -   |          |                            |
|Clients for   |None      |2.0.9     |Not       |None                        |
|Apple iOS     |          |1.0.3 -   |vulnerable|                            |
|              |          |1.0.6     |          |                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IP Edge   |          |7090.x -  |**Not     |                            |
|Clients for   |None      |7150.x    |vulnerable|None                        |
|Linux         |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IP Edge   |          |7090.x -  |** Not    |                            |
|Clients for   |None      |7150.x    |vulnerable|None                        |
|MAC OS X      |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IP Edge   |          |7090.x -  |** Not    |                            |
|Clients for   |None      |7150.x    |vulnerable|None                        |
|Windows       |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IP Edge   |          |1.0.0 -   |Not       |                            |
|Portal for    |None      |1.0.2     |vulnerable|None                        |
|Android       |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+
|BIG-IP Edge   |          |1.0.0 -   |Not       |                            |
|Portal for    |None      |1.0.3     |vulnerable|None                        |
|Apple iOS     |          |          |          |                            |
+--------------+----------+----------+----------+----------------------------+

* The failover.secure system database variable is only available in BIG-IP
11.5.0 and later, and is disabled by default. However, Common Criteria mode
enables the failover.secure database variable.

^** BIG-IP Edge Client will be vulnerable only when connected to a malicious
server.


Security Advisory Recommended Actions

If the previous table lists a version in the Versions known to be not
vulnerable column, you can eliminate this vulnerability by upgrading to the
listed version. If the listed version is older than the version you are
currently running, or if the table does not list any version in the column,
then no upgrade candidate currently exists.

BIG-IP

To mitigate this vulnerability for vulnerable BIG-IP versions, you can disable
the failover.secure system database variable to prevent exposure. For UDP
virtual servers using Client SSL or Server SSL profiles, the system is only
vulnerable to this issue when configured with COMPAT ciphers.

For more information about SSL profiles and cipher configuration, refer to the
following articles:

  o K13187: COMPAT SSL ciphers are no longer included in standard cipher
    strings
  o K13171: Configuring the cipher strength for SSL profiles (11.x)


Supplemental Information

  o K9970: Subscribing to email notifications regarding F5 products
  o K9957: Creating a custom RSS feed to view new and updated documents
  o K4918: Overview of the F5 critical issue hotfix policy
  o K4602: Overview of the F5 security vulnerability response policy
  o K167: Downloading software and firmware from F5
  o K13123: Managing BIG-IP product hotfixes (11.x - 13.x)
  o K9502: BIG-IP hotfix and point release matrix

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBWsV5uIx+lLeg9Ub1AQgOGg/+I+MtEDdQhSL1rZC7skjzbiK0mb73dhnX
QhX5MPEkSqxUVKTDVfI+XjcydcwlBHGovMVH8VuHHCP/FjvnGQyBxbkK6yh6gJOe
oQxpJCBvZh81UR3zuKuYd6VOxWRZBZ1m/GJPglQtR4uu6JVplokSufGpIvNhFqSt
8t244uzHIq2/blr6hkjP/e9zOETwR52DmQMklaurGlaVN9Nv7pDk2guXJHXzjnYn
nPugR+TSImEjqlZSXfwq6dhqBsdftvWEtArcMs5qm889OTGAoxX30/O69mjG6sPP
u3j4ElY5A7GiCOk1ij0Ge78j6z75KdBfgbzMS2x3NpRtp3Te8El+tnP/2KkHW+se
AuPILL3ns0HzZaJSLOOL6Pq14GWEPcCTZha/4eCVejlIexak8AKU1u3kd8sOZWJb
rxG/q1BMroNmyrRXIv0A/+jzrTqfA6N183oyuTTiHy5qZIGyFaoDaUvk8NVd1wcS
NM1rvVke02aJNvxCi6tVEQ14e1EN2cMc0YtVmHfC/B8vZyP+LKhHabD5lSrKVNPj
JP/4TgRl6GH+SOCfEokOJ7pE9uHMx6wb3NCb3e4W++7TcwWjH/EDgdBXDCQmT5Vi
dc8hd2OmX1jtXyGgdZ8nUyWKgNUh789GLmI8Ql9SwH1NFh2TNoEJrnk1NIaGOcgg
RBsOtKBqFtw=
=4MZr
-----END PGP SIGNATURE-----

« Back to bulletins