ESB-2018.0288 - [SUSE] kernel: Multiple vulnerabilities 2018-01-30

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2018.0288
        SUSE Security Update: Security updates for the Linux Kernel
                              30 January 2018

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           kernel
Publisher:         SUSE
Operating System:  SUSE
Impact/Access:     Root Compromise   -- Existing Account
                   Denial of Service -- Existing Account
Resolution:        Patch/Upgrade
CVE Names:         CVE-2017-17712 CVE-2017-16939 CVE-2017-15868

Reference:         ESB-2018.0057
                   ESB-2018.0012
                   ESB-2017.3104

Original Bulletin: 
   https://www.suse.com/support/update/announcement/2018/suse-su-20180265-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180266-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180267-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180268-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180269-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180270-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180271-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180272-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180273-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180274-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180275-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180276-1/
   https://www.suse.com/support/update/announcement/2018/suse-su-20180277-1/

Comment: This bulletin contains thirteen (13) SUSE security advisories.

- --------------------------BEGIN INCLUDED TEXT--------------------

   SUSE Security Update: Security update for the Linux Kernel (Live Patch 20 for SLE 12 SP1)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0266-1
Rating:             important
References:         #1069708 #1071471 
Cross-References:   CVE-2017-15868 CVE-2017-16939
Affected Products:
                    SUSE Linux Enterprise Server for SAP 12-SP1
                    SUSE Linux Enterprise Server 12-SP1-LTSS
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for the Linux Kernel 3.12.74-60_64_57 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-15868: The bnep_add_connection function in
     net/bluetooth/bnep/core.c in did not ensure that an l2cap socket is
     available, which allowed local users to gain privileges via a crafted
     application (bsc#1071471).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 12-SP1:

      zypper in -t patch SUSE-SLE-SAP-12-SP1-2018-189=1

   - SUSE Linux Enterprise Server 12-SP1-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2018-189=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Server for SAP 12-SP1 (x86_64):

      kgraft-patch-3_12_74-60_64_57-default-6-2.1
      kgraft-patch-3_12_74-60_64_57-xen-6-2.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (x86_64):

      kgraft-patch-3_12_74-60_64_57-default-6-2.1
      kgraft-patch-3_12_74-60_64_57-xen-6-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-15868.html
   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1071471


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 19 for SLE 12)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0265-1
Rating:             important
References:         #1069708 #1071471 
Cross-References:   CVE-2017-15868 CVE-2017-16939
Affected Products:
                    SUSE Linux Enterprise Server 12-LTSS
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for the Linux Kernel 3.12.61-52_66 fixes one issue.

   The following security issues were fixed:

   - CVE-2017-15868: The bnep_add_connection function in
     net/bluetooth/bnep/core.c did not ensure that an l2cap socket is
     available, which allowed local users to gain privileges via a crafted
     application (bsc#1071471).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server 12-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-2018-185=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Server 12-LTSS (x86_64):

      kgraft-patch-3_12_61-52_66-default-11-2.1
      kgraft-patch-3_12_61-52_66-xen-11-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-15868.html
   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1071471


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 23 for SLE 12 SP1)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0267-1
Rating:             important
References:         #1071471 
Cross-References:   CVE-2017-15868
Affected Products:
                    SUSE Linux Enterprise Server for SAP 12-SP1
                    SUSE Linux Enterprise Server 12-SP1-LTSS
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for the Linux Kernel 3.12.74-60_64_66 fixes one issue.

   The following security issue was fixed:

   - CVE-2017-15868: The bnep_add_connection function in
     net/bluetooth/bnep/core.c in did not ensure that an l2cap socket is
     available, which allowed local users to gain privileges via a crafted
     application (bsc#1071471).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 12-SP1:

      zypper in -t patch SUSE-SLE-SAP-12-SP1-2018-186=1

   - SUSE Linux Enterprise Server 12-SP1-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2018-186=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Server for SAP 12-SP1 (x86_64):

      kgraft-patch-3_12_74-60_64_66-default-2-2.1
      kgraft-patch-3_12_74-60_64_66-xen-2-2.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (x86_64):

      kgraft-patch-3_12_74-60_64_66-default-2-2.1
      kgraft-patch-3_12_74-60_64_66-xen-2-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-15868.html
   https://bugzilla.suse.com/1071471


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 18 for SLE 12 SP1)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0268-1
Rating:             important
References:         #1069708 #1071471 
Cross-References:   CVE-2017-15868 CVE-2017-16939
Affected Products:
                    SUSE Linux Enterprise Server for SAP 12-SP1
                    SUSE Linux Enterprise Server 12-SP1-LTSS
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for the Linux Kernel 3.12.74-60_64_51 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-15868: The bnep_add_connection function in
     net/bluetooth/bnep/core.c in did not ensure that an l2cap socket is
     available, which allowed local users to gain privileges via a crafted
     application (bsc#1071471).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 12-SP1:

      zypper in -t patch SUSE-SLE-SAP-12-SP1-2018-193=1

   - SUSE Linux Enterprise Server 12-SP1-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2018-193=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Server for SAP 12-SP1 (x86_64):

      kgraft-patch-3_12_74-60_64_51-default-6-2.1
      kgraft-patch-3_12_74-60_64_51-xen-6-2.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (x86_64):

      kgraft-patch-3_12_74-60_64_51-default-6-2.1
      kgraft-patch-3_12_74-60_64_51-xen-6-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-15868.html
   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1071471


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 8 for SLE 12 SP2)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0269-1
Rating:             important
References:         #1069708 #1070307 #1073230 
Cross-References:   CVE-2017-16939 CVE-2017-17712
Affected Products:
                    SUSE Linux Enterprise Live Patching 12
______________________________________________________________________________

   An update that solves two vulnerabilities and has one
   errata is now available.

Description:

   This update for the Linux Kernel 4.4.59-92_20 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-17712: The raw_sendmsg() function had a race condition that
     lead to uninitialized stack pointer usage. This allowed a local user to
     execute code and gain privileges (bsc#1073230).
   - CVE-2017-16939: The XFRM dump policy implementation allowed local users
     to gain privileges or cause a denial of service (use-after-free) via a
     crafted SO_RCVBUF setsockopt system call in conjunction with
     XFRM_MSG_GETPOLICY Netlink messages (bsc#1069708).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Live Patching 12:

      zypper in -t patch SUSE-SLE-Live-Patching-12-2018-197=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Live Patching 12 (x86_64):

      kgraft-patch-4_4_59-92_20-default-8-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://www.suse.com/security/cve/CVE-2017-17712.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1070307
   https://bugzilla.suse.com/1073230


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 22 for SLE 12 SP1)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0270-1
Rating:             important
References:         #1069708 #1071471 
Cross-References:   CVE-2017-15868 CVE-2017-16939
Affected Products:
                    SUSE Linux Enterprise Server for SAP 12-SP1
                    SUSE Linux Enterprise Server 12-SP1-LTSS
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for the Linux Kernel 3.12.74-60_64_63 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-15868: The bnep_add_connection function in
     net/bluetooth/bnep/core.c in did not ensure that an l2cap socket is
     available, which allowed local users to gain privileges via a crafted
     application (bsc#1071471).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 12-SP1:

      zypper in -t patch SUSE-SLE-SAP-12-SP1-2018-187=1

   - SUSE Linux Enterprise Server 12-SP1-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2018-187=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Server for SAP 12-SP1 (x86_64):

      kgraft-patch-3_12_74-60_64_63-default-3-2.1
      kgraft-patch-3_12_74-60_64_63-xen-3-2.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (x86_64):

      kgraft-patch-3_12_74-60_64_63-default-3-2.1
      kgraft-patch-3_12_74-60_64_63-xen-3-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-15868.html
   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1071471


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 21 for SLE 12 SP1)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0271-1
Rating:             important
References:         #1069708 #1071471 
Cross-References:   CVE-2017-15868 CVE-2017-16939
Affected Products:
                    SUSE Linux Enterprise Server for SAP 12-SP1
                    SUSE Linux Enterprise Server 12-SP1-LTSS
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for the Linux Kernel 3.12.74-60_64_60 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-15868: The bnep_add_connection function in
     net/bluetooth/bnep/core.c in did not ensure that an l2cap socket is
     available, which allowed local users to gain privileges via a crafted
     application (bsc#1071471).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 12-SP1:

      zypper in -t patch SUSE-SLE-SAP-12-SP1-2018-188=1

   - SUSE Linux Enterprise Server 12-SP1-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2018-188=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Server for SAP 12-SP1 (x86_64):

      kgraft-patch-3_12_74-60_64_60-default-5-2.1
      kgraft-patch-3_12_74-60_64_60-xen-5-2.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (x86_64):

      kgraft-patch-3_12_74-60_64_60-default-5-2.1
      kgraft-patch-3_12_74-60_64_60-xen-5-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-15868.html
   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1071471


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 12 for SLE 12 SP2)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0272-1
Rating:             important
References:         #1069708 #1070307 #1073230 
Cross-References:   CVE-2017-16939 CVE-2017-17712
Affected Products:
                    SUSE Linux Enterprise Live Patching 12
______________________________________________________________________________

   An update that solves two vulnerabilities and has one
   errata is now available.

Description:

   This update for the Linux Kernel 4.4.74-92_35 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-17712: The raw_sendmsg() function had a race condition that
     lead to uninitialized stack pointer usage. This allowed a local user to
     execute code and gain privileges (bsc#1073230).
   - CVE-2017-16939: The XFRM dump policy implementation allowed local users
     to gain privileges or cause a denial of service (use-after-free) via a
     crafted SO_RCVBUF setsockopt system call in conjunction with
     XFRM_MSG_GETPOLICY Netlink messages (bsc#1069708).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Live Patching 12:

      zypper in -t patch SUSE-SLE-Live-Patching-12-2018-195=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Live Patching 12 (x86_64):

      kgraft-patch-4_4_74-92_35-default-6-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://www.suse.com/security/cve/CVE-2017-17712.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1070307
   https://bugzilla.suse.com/1073230


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 12 for SLE 12 SP1)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0274-1
Rating:             important
References:         #1069708 #1071471 
Cross-References:   CVE-2017-15868 CVE-2017-16939
Affected Products:
                    SUSE Linux Enterprise Server for SAP 12-SP1
                    SUSE Linux Enterprise Server 12-SP1-LTSS
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for the Linux Kernel 3.12.69-60_64_29 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-15868: The bnep_add_connection function in
     net/bluetooth/bnep/core.c in did not ensure that an l2cap socket is
     available, which allowed local users to gain privileges via a crafted
     application (bsc#1071471).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 12-SP1:

      zypper in -t patch SUSE-SLE-SAP-12-SP1-2018-190=1

   - SUSE Linux Enterprise Server 12-SP1-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2018-190=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Server for SAP 12-SP1 (x86_64):

      kgraft-patch-3_12_69-60_64_29-default-11-2.1
      kgraft-patch-3_12_69-60_64_29-xen-11-2.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (x86_64):

      kgraft-patch-3_12_69-60_64_29-default-11-2.1
      kgraft-patch-3_12_69-60_64_29-xen-11-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-15868.html
   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1071471


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 7 for SLE 12 SP2)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0273-1
Rating:             important
References:         #1069708 #1070307 #1073230 
Cross-References:   CVE-2017-16939 CVE-2017-17712
Affected Products:
                    SUSE Linux Enterprise Live Patching 12
______________________________________________________________________________

   An update that solves two vulnerabilities and has one
   errata is now available.

Description:

   This update for the Linux Kernel 4.4.59-92_17 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-17712: The raw_sendmsg() function had a race condition that
     lead to uninitialized stack pointer usage. This allowed a local user to
     execute code and gain privileges (bsc#1073230).
   - CVE-2017-16939: The XFRM dump policy implementation allowed local users
     to gain privileges or cause a denial of service (use-after-free) via a
     crafted SO_RCVBUF setsockopt system call in conjunction with
     XFRM_MSG_GETPOLICY Netlink messages (bsc#1069708).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Live Patching 12:

      zypper in -t patch SUSE-SLE-Live-Patching-12-2018-196=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Live Patching 12 (x86_64):

      kgraft-patch-4_4_59-92_17-default-8-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://www.suse.com/security/cve/CVE-2017-17712.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1070307
   https://bugzilla.suse.com/1073230


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 14 for SLE 12 SP1)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0275-1
Rating:             important
References:         #1069708 #1071471 
Cross-References:   CVE-2017-15868 CVE-2017-16939
Affected Products:
                    SUSE Linux Enterprise Server for SAP 12-SP1
                    SUSE Linux Enterprise Server 12-SP1-LTSS
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for the Linux Kernel 3.12.69-60_64_35 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-15868: The bnep_add_connection function in
     net/bluetooth/bnep/core.c in did not ensure that an l2cap socket is
     available, which allowed local users to gain privileges via a crafted
     application (bsc#1071471).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 12-SP1:

      zypper in -t patch SUSE-SLE-SAP-12-SP1-2018-192=1

   - SUSE Linux Enterprise Server 12-SP1-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2018-192=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Server for SAP 12-SP1 (x86_64):

      kgraft-patch-3_12_69-60_64_35-default-9-2.1
      kgraft-patch-3_12_69-60_64_35-xen-9-2.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (x86_64):

      kgraft-patch-3_12_69-60_64_35-default-9-2.1
      kgraft-patch-3_12_69-60_64_35-xen-9-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-15868.html
   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1071471


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 13 for SLE 12 SP1)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0276-1
Rating:             important
References:         #1069708 #1071471 
Cross-References:   CVE-2017-15868 CVE-2017-16939
Affected Products:
                    SUSE Linux Enterprise Server for SAP 12-SP1
                    SUSE Linux Enterprise Server 12-SP1-LTSS
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for the Linux Kernel 3.12.69-60_64_32 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-15868: The bnep_add_connection function in
     net/bluetooth/bnep/core.c in did not ensure that an l2cap socket is
     available, which allowed local users to gain privileges via a crafted
     application (bsc#1071471).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 12-SP1:

      zypper in -t patch SUSE-SLE-SAP-12-SP1-2018-191=1

   - SUSE Linux Enterprise Server 12-SP1-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2018-191=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Server for SAP 12-SP1 (x86_64):

      kgraft-patch-3_12_69-60_64_32-default-10-2.1
      kgraft-patch-3_12_69-60_64_32-xen-10-2.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (x86_64):

      kgraft-patch-3_12_69-60_64_32-default-10-2.1
      kgraft-patch-3_12_69-60_64_32-xen-10-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-15868.html
   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1071471


   SUSE Security Update: Security update for the Linux Kernel (Live Patch 13 for SLE 12 SP2)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2018:0277-1
Rating:             important
References:         #1069708 #1070307 #1073230 
Cross-References:   CVE-2017-16939 CVE-2017-17712
Affected Products:
                    SUSE Linux Enterprise Live Patching 12
______________________________________________________________________________

   An update that solves two vulnerabilities and has one
   errata is now available.

Description:

   This update for the Linux Kernel 4.4.74-92_38 fixes several issues.

   The following security issues were fixed:

   - CVE-2017-17712: The raw_sendmsg() function had a race condition that
     lead to uninitialized stack pointer usage. This allowed a local user to
     execute code and gain privileges (bsc#1073230).
   - CVE-2017-16939: The XFRM dump policy implementation allowed local users
     to gain privileges or cause a denial of service (use-after-free) via a
     crafted SO_RCVBUF setsockopt system call in conjunction with
     XFRM_MSG_GETPOLICY Netlink messages (bsc#1069708).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Live Patching 12:

      zypper in -t patch SUSE-SLE-Live-Patching-12-2018-194=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Live Patching 12 (x86_64):

      kgraft-patch-4_4_74-92_38-default-5-2.1


References:

   https://www.suse.com/security/cve/CVE-2017-16939.html
   https://www.suse.com/security/cve/CVE-2017-17712.html
   https://bugzilla.suse.com/1069708
   https://bugzilla.suse.com/1070307
   https://bugzilla.suse.com/1073230

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBWm/GUIx+lLeg9Ub1AQjB0hAAl87Kzo6FZaqWTK8UW8ETKgPflDUmoBpW
dm4fh1lVyn/lQlQvhTTcNokUKln3AxPTfsIFM3QysA94K49F2GL/HsuJkNvx25GX
AGTk7U1pzY4ZaqKFZXeHB1qODcsCSrjWCs2eFz6jsz4g18HHtjJJTynximaQyffv
sQGyLX+DA3Gez5ivej5lwEi6R5PBSxyHZdUl8rqMXo22SGFmwUkZEvejCWsmuL7X
x7MOamNJP8Cw0m2X3z0jd9pRTBl5tHcDXuKrEd+BCzPXUCUdoVLu1nUZnr7ydSGN
qdFnt9/9GURrz3lrZVGPe2v00TeQdMmQpfrZt2sIuQ7EPYCePEsUqh/2wEsRV/5i
daQNGCm+4VO8dk5qsFYkd9TpyL+gG3KUJ1FaYzuCFsKNbK/klSkWIMcLMY09xB6o
6JInGCgEYT/a+m2E+vcLH6jBTOvi6nursWaHfXdnv1EMb3bjRlykQwV4txqtoY0K
ezYCzCd1qw3fSdTSWe4O1uw3UAJWa0ieRrlMjbd3shc5sp6gK8VsdydH4/uVr+SK
DR2dbmC7Lb0eX4PqoedguKBH6DisNnfTywLzeiDtsispbP/9SbdWONO6l3JQaS3j
NvF/w9FS2+EYuSMxQB/JFlIRcnUeSMhFve8qQ6VtgVhOk7ehQ41lBcEtCV8xT4C3
5JFf7VwPmZM=
=WNWB
-----END PGP SIGNATURE-----

« Back to bulletins