ESB-2018.0008 - [Appliance] F5 BIG-IP Products: Unauthorised access - Remote/unauthenticated 2018-01-02

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2018.0008
            K34125394: Apache HTTPD vulnerability CVE-2017-3167
                              2 January 2018

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           F5 BIG-IP Products
Publisher:         F5 Networks
Operating System:  Network Appliance
Impact/Access:     Unauthorised Access -- Remote/Unauthenticated
Resolution:        Patch/Upgrade
CVE Names:         CVE-2017-3167  

Reference:         ASB-2017.0219
                   ASB-2017.0181
                   ESB-2017.1603
                   ESB-2017.1583
                   ESB-2017.1533

Original Bulletin: 
   https://support.f5.com/csp/article/K34125394

- --------------------------BEGIN INCLUDED TEXT--------------------

K34125394: Apache HTTPD vulnerability CVE-2017-3167

Security Advisory

Original Publication Date: Jul 13, 2017

Updated Date: Dec 22, 2017

Security Advisory Description

In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, use of the
ap_get_basic_auth_pw() by third-party modules outside of the authentication
phase may lead to authentication requirements being bypassed. (CVE-2017-3167)

Impact

When the vulnerability is exploited, an attacker may bypass authentication and
gain unauthorized access to the affected system.

Security Advisory Status

F5 Product Development has assigned ID 673595 (BIG-IP), ID 673639 (Enterprise
Manager), and ID 431234 (ARX) to this vulnerability. Additionally, BIG-IP
iHealth may list Heuristic H34125394 on the Diagnostics > Identified > High
screen.

To determine if your release is known to be vulnerable, the components or
features that are affected by the vulnerability, and for information about
releases or hotfixes that address the vulnerability, refer to the following
table:

+--------------+--------------+---------------+----------+--------------------+
|              |Versions known|Versions known |          |Vulnerable component|
|Product       |to be         |to be not      |Severity  |or feature          |
|              |vulnerable    |vulnerable     |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|              |13.0.0        |               |          |                    |
|              |12.0.0 -      |               |          |Apache HTTPD        |
|BIG-IP LTM    |12.1.2        |13.1.0         |High      |(Configuration      |
|              |11.4.1 -      |               |          |utility, iControl)  |
|              |11.6.1        |               |          |                    |
|              |11.2.1        |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|              |13.0.0        |               |          |                    |
|              |12.0.0 -      |               |          |Apache HTTPD        |
|BIG-IP AAM    |12.1.2        |13.1.0         |High      |(Configuration      |
|              |11.4.1 -      |               |          |utility, iControl)  |
|              |11.6.1        |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|              |13.0.0        |               |          |                    |
|              |12.0.0 -      |               |          |Apache HTTPD        |
|BIG-IP AFM    |12.1.2        |13.1.0         |High      |(Configuration      |
|              |11.4.1 -      |               |          |utility, iControl)  |
|              |11.6.1        |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|              |13.0.0        |               |          |                    |
|              |12.0.0 -      |               |          |Apache HTTPD        |
|BIG-IP        |12.1.2        |13.1.0         |High      |(Configuration      |
|Analytics     |11.4.1 -      |               |          |utility, iControl)  |
|              |11.6.1        |               |          |                    |
|              |11.2.1        |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|              |13.0.0        |               |          |                    |
|              |12.0.0 -      |               |          |Apache HTTPD        |
|BIG-IP APM    |12.1.2        |13.1.0         |High      |(Configuration      |
|              |11.4.1 -      |               |          |utility, iControl)  |
|              |11.6.1        |               |          |                    |
|              |11.2.1        |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|              |13.0.0        |               |          |                    |
|              |12.0.0 -      |               |          |Apache HTTPD        |
|BIG-IP ASM    |12.1.2        |13.1.0         |High      |(Configuration      |
|              |11.4.1 -      |               |          |utility, iControl)  |
|              |11.6.1        |               |          |                    |
|              |11.2.1        |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|              |13.0.0        |               |          |Apache HTTPD        |
|BIG-IP DNS    |12.0.0 -      |13.1.0         |High      |(Configuration      |
|              |12.1.2        |               |          |utility, iControl)  |
+--------------+--------------+---------------+----------+--------------------+
|BIG-IP Edge   |              |               |          |Apache HTTPD        |
|Gateway       |11.2.1        |None           |High      |(Configuration      |
|              |              |               |          |utility, iControl)  |
+--------------+--------------+---------------+----------+--------------------+
|              |11.4.1 -      |               |          |Apache HTTPD        |
|BIG-IP GTM    |11.6.1        |None           |High      |(Configuration      |
|              |11.2.1        |               |          |utility, iControl)  |
+--------------+--------------+---------------+----------+--------------------+
|              |13.0.0        |               |          |                    |
|              |12.0.0 -      |               |          |Apache HTTPD        |
|BIG-IP Link   |12.1.2        |13.1.0         |High      |(Configuration      |
|Controller    |11.4.1 -      |               |          |utility, iControl)  |
|              |11.6.1        |               |          |                    |
|              |11.2.1        |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|              |13.0.0        |               |          |                    |
|              |12.0.0 -      |               |          |Apache HTTPD        |
|BIG-IP PEM    |12.1.2        |13.1.0         |High      |(Configuration      |
|              |11.4.1 -      |               |          |utility, iControl)  |
|              |11.6.1        |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|              |              |               |          |Apache HTTPD        |
|BIG-IP PSM    |11.4.1        |None           |High      |(Configuration      |
|              |              |               |          |utility, iControl)  |
+--------------+--------------+---------------+----------+--------------------+
|BIG-IP        |              |               |          |Apache HTTPD        |
|WebAccelerator|11.2.1        |None           |High      |(Configuration      |
|              |              |               |          |utility, iControl)  |
+--------------+--------------+---------------+----------+--------------------+
|              |13.0.0        |               |          |                    |
|              |12.0.0 -      |               |          |Apache HTTPD        |
|BIG-IP WebSafe|12.1.2        |13.1.0         |High      |(Configuration      |
|              |11.6.0 -      |               |          |utility, iControl)  |
|              |11.6.1        |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|              |              |               |          |Management API      |
|ARX           |6.2.0 - 6.4.0 |None           |High      |(disabled by        |
|              |              |               |          |default)            |
+--------------+--------------+---------------+----------+--------------------+
|Enterprise    |              |               |          |Apache HTTPD        |
|Manager       |3.1.1         |None           |High      |(Configuration      |
|              |              |               |          |utility, iControl)  |
+--------------+--------------+---------------+----------+--------------------+
|BIG-IQ Cloud  |None          |4.4.0 - 4.5.0  |Not       |None                |
|              |              |               |vulnerable|                    |
+--------------+--------------+---------------+----------+--------------------+
|BIG-IQ Device |None          |4.4.0 - 4.5.0  |Not       |None                |
|              |              |               |vulnerable|                    |
+--------------+--------------+---------------+----------+--------------------+
|BIG-IQ        |None          |4.4.0 - 4.5.0  |Not       |None                |
|Security      |              |               |vulnerable|                    |
+--------------+--------------+---------------+----------+--------------------+
|BIG-IQ ADC    |None          |4.5.0          |Not       |None                |
|              |              |               |vulnerable|                    |
+--------------+--------------+---------------+----------+--------------------+
|BIG-IQ        |              |5.0.0 - 5.2.0  |Not       |                    |
|Centralized   |None          |4.6.0          |vulnerable|None                |
|Management    |              |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|BIG-IQ Cloud  |              |               |Not       |                    |
|and           |None          |1.0.0          |vulnerable|None                |
|Orchestration |              |               |          |                    |
+--------------+--------------+---------------+----------+--------------------+
|F5 iWorkflow  |None          |2.0.0 - 2.2.0  |Not       |None                |
|              |              |               |vulnerable|                    |
+--------------+--------------+---------------+----------+--------------------+
|LineRate      |None          |2.5.0 - 2.6.2  |Not       |None                |
|              |              |               |vulnerable|                    |
+--------------+--------------+---------------+----------+--------------------+
|Traffix SDC   |None          |5.0.0 - 5.1.0  |Not       |None                |
|              |              |4.0.0 - 4.4.0  |vulnerable|                    |
+--------------+--------------+---------------+----------+--------------------+

Security Advisory Recommended Actions

If you are running a version listed in the Versions known to be vulnerable
column, you can eliminate this vulnerability by upgrading to a version listed
in the Versions known to be not vulnerable column. If the table lists only an
older version than what you are currently running, or does not list a
non-vulnerable version, then no upgrade candidate currently exists.

Mitigation

To mitigate this vulnerability, you should permit management access to F5
products only over a secure network and restrict command line access for
affected systems to the trusted users. For more information, refer to K13309:
Restricting access to the Configuration utility by source IP address (11.x -
13.x) and K13092: Overview of securing access to the BIG-IP system.

Supplemental Information

  o K9970: Subscribing to email notifications regarding F5 products
  o K9957: Creating a custom RSS feed to view new and updated documents
  o K4602: Overview of the F5 security vulnerability response policy
  o K4918: Overview of the F5 critical issue hotfix policy
  o K167: Downloading software and firmware from F5

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBWkrSjox+lLeg9Ub1AQgu8w//Rv9wkyV+DSCzauAxb2TLzXBjTrNGg6SG
RUvdQ04xj+xkzI2+yt8R8ly/7vwdLHvKr4l3NXN50P5OTCxrh/NLW/gjA/1hdddk
Mc4PlYOxp7w/7BtuE6a/vYPCCnPeSpOhV7nLKCWAjVYxkyCRDblRNfA8W/zwZDdA
9iDiKohmSdndbvzYplV8thWJf7/1n1qWJM0xeC45npQnY6JqEUs0ptaWiT35q8Mp
ggSnN3w3t2Q6ccaWmK3SMtMDC95tSXIYcm8v0S37Zfg+NdteDGw9+H85VN7Lya/5
hr2cQPRZOzAKba7kmQ12bUbUHSzy6vFfccoAA4Rcj3p5U4+/rtF8ZzFGGPAgpoKs
ZGAFRmN2jBuHTkEL2JitXRj2+oJYgoqn5UhNj6w8N5rulpQF/cGl09ngeHD1MZhT
TdDwy5xiy+aviGHrYETZtEKnmpPym0ZdfhpK8gCyqA0yY/H4NX4vznLFtSdlOAom
43F6zvaXs6mRKdfRhFQXWyGxb4iOCpZf34X5h7hBp+whl/G4qKneTwpbQVPH4aJI
rdsYo7YJLyX5QJ0ZFHeUKPZmEIkAbr3k22pHbwXIwvZcXDobeKfWrc/GSembi4dH
1xcjUFnjvkMWvqFT+zU5r4x1nQEJVUu3nBd84GQJshel4fl/2bdJ2DUTY67XsdjA
HdNAhF470Fg=
=OHhw
-----END PGP SIGNATURE-----

« Back to bulletins