ESB-2017.3146 - [SUSE] opensaml: Multiple vulnerabilities 2017-12-08

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2017.3146
            SUSE Security Update: Security update for opensaml
                              8 December 2017

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           opensaml
Publisher:         SUSE
Operating System:  SUSE
Impact/Access:     Provide Misleading Information -- Remote/Unauthenticated
                   Access Confidential Data       -- Remote/Unauthenticated
                   Reduced Security               -- Remote/Unauthenticated
Resolution:        Patch/Upgrade
CVE Names:         CVE-2017-16853  

Reference:         ESB-2017.2953.2

Original Bulletin: 
   https://www.suse.com/support/update/announcement/2017/suse-su-20173234-1/

- --------------------------BEGIN INCLUDED TEXT--------------------

   SUSE Security Update: Security update for opensaml
______________________________________________________________________________

Announcement ID:    SUSE-SU-2017:3234-1
Rating:             important
References:         #1068685 
Cross-References:   CVE-2017-16853
Affected Products:
                    SUSE Linux Enterprise Software Development Kit 12-SP3
                    SUSE Linux Enterprise Software Development Kit 12-SP2
                    SUSE Linux Enterprise Server for Raspberry Pi 12-SP2
                    SUSE Linux Enterprise Server 12-SP3
                    SUSE Linux Enterprise Server 12-SP2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for opensaml fixes the following issues:

   Security issue fixed:

   - CVE-2017-16853: Fix the DynamicMetadataProvider class to properly
     configure itself with the MetadataFilter plugins, to avoid possible MITM
     attacks (bsc#1068685).


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Software Development Kit 12-SP3:

      zypper in -t patch SUSE-SLE-SDK-12-SP3-2017-2011=1

   - SUSE Linux Enterprise Software Development Kit 12-SP2:

      zypper in -t patch SUSE-SLE-SDK-12-SP2-2017-2011=1

   - SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:

      zypper in -t patch SUSE-SLE-RPI-12-SP2-2017-2011=1

   - SUSE Linux Enterprise Server 12-SP3:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-2017-2011=1

   - SUSE Linux Enterprise Server 12-SP2:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-2011=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le s390x x86_64):

      libsaml-devel-2.5.5-3.3.1
      opensaml-debugsource-2.5.5-3.3.1

   - SUSE Linux Enterprise Software Development Kit 12-SP2 (aarch64 ppc64le s390x x86_64):

      libsaml-devel-2.5.5-3.3.1
      opensaml-debugsource-2.5.5-3.3.1

   - SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (aarch64):

      libsaml8-2.5.5-3.3.1
      libsaml8-debuginfo-2.5.5-3.3.1
      opensaml-bin-2.5.5-3.3.1
      opensaml-bin-debuginfo-2.5.5-3.3.1
      opensaml-debugsource-2.5.5-3.3.1
      opensaml-schemas-2.5.5-3.3.1

   - SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):

      libsaml8-2.5.5-3.3.1
      libsaml8-debuginfo-2.5.5-3.3.1
      opensaml-bin-2.5.5-3.3.1
      opensaml-bin-debuginfo-2.5.5-3.3.1
      opensaml-debugsource-2.5.5-3.3.1
      opensaml-schemas-2.5.5-3.3.1

   - SUSE Linux Enterprise Server 12-SP2 (aarch64 ppc64le s390x x86_64):

      libsaml8-2.5.5-3.3.1
      libsaml8-debuginfo-2.5.5-3.3.1
      opensaml-bin-2.5.5-3.3.1
      opensaml-bin-debuginfo-2.5.5-3.3.1
      opensaml-debugsource-2.5.5-3.3.1
      opensaml-schemas-2.5.5-3.3.1


References:

   https://www.suse.com/security/cve/CVE-2017-16853.html
   https://bugzilla.suse.com/1068685

- --

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBWioLHYx+lLeg9Ub1AQjIiw//YsAKIaM5zRpmCaZb0ijkS+LuHdkU9s5w
Ldun70s2al1zGZpoiOjiMsgLNn4Kz8KT5elzvDfiYv/TZU3W/MxSArCNBCmddfCa
3sSTB/Y0voaE2Y4HcVTWBKCE6rKOXNxegJUxOT7wR1L1croIcwDnRG5+EK9rY2LE
y3QIWaBERvVuhNdCVYCJrIFuZU2Pc945tArdKQIs8ICJInzaVaQ8nGkeT3zzXemJ
SrwsZVh/Gote5MO6ssULMO0Dw04N1oiFYCWc44jdrrVMIHqub37Ip9Khs/JTrNgn
rBvk90WtUC3DetDYXNp++vmsWLJHh218HvWHqKzvRfiPp01fHmTWZdDTDjzlUvTU
RWkFW+ntriOeCb9mng/ryKdyQdKyL0uYptFUEgap62Rm28SiMqkYnC23mj/XIwGO
Mb8KNGmZyy5aXVGWQYjIpes7tLkcnqjRQEMgPMbv8tojhRMmESnlPIjNiAR4ObLj
6ziASieqjUjfro4ZyAzUVpiSfQbQtC3iPu9M7QMDaMRzFRBcZVZ78n6UtA72duTY
nA/8yKVCq+d95clB7MDwjsW7TPbxLb2zmcmfopkqQqmCqs25ijkrUptolIlUuICq
89feKmmG/QuP4HVQvoAqrMnA0UaWQ876n+ZO8RR1Z0exbkSIO8JXf1iSrqFJRrmo
7JmsnOMErr4=
=lJB5
-----END PGP SIGNATURE-----

« Back to bulletins