ESB-2017.2931 - ALERT [Cisco] Cisco Voice Operating System: Root compromise - Remote/unauthenticated 2017-11-16

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2017.2931
            Known Root Credentials Enabled After Some Upgrades
                             16 November 2017

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           Cisco Voice Operating System
Publisher:         Cisco Systems
Operating System:  Cisco
Impact/Access:     Root Compromise -- Remote/Unauthenticated
Resolution:        Patch/Upgrade
CVE Names:         CVE-2017-12337  

Original Bulletin: 
   https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20171115-vos

- --------------------------BEGIN INCLUDED TEXT--------------------

Cisco Voice Operating System-Based Products Unauthorized Access Vulnerability

Severity: Critical
Advisory ID: cisco-sa-20171115-vos
First Published: 2017 November 15 16:00  GMT
Version 1.0: Final
Workarounds: No workarounds available
Cisco Bug IDs: CSCvg22923 CSCvg55112 CSCvg55128 CSCvg22923 CSCvg55112
	       CSCvg55128 CSCvg55145 CSCvg58619 CSCvg64453 CSCvg64456
	       CSCvg64464 CSCvg64475 CSCvg68797

CVE-2017-12337
CWE-287

CVSS Score:
Base 9.8
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:X/RL:X/RC:X

CVE-2017-12337
CWE-287

Summary

  * A vulnerability in the upgrade mechanism of Cisco collaboration products
    based on the Cisco Voice Operating System software platform could allow an
    unauthenticated, remote attacker to gain unauthorized, elevated access to
    an affected device.

    The vulnerability occurs when a refresh upgrade or Prime Collaboration
    Deployment (PCD) migration is performed on an affected device. When a
    refresh upgrade or PCD migration is completed successfully, an engineering
    flag remains enabled and could allow root access to the device with a known
    password.

    If the vulnerable device is subsequently upgraded using the standard
    upgrade method to an Engineering Special Release, service update, or a new
    major release of the affected product, this vulnerability is remediated by
    that action.

    Note: Engineering Special Releases that are installed as COP files, as
    opposed to the standard upgrade method, do not remediate this
    vulnerability.

    An attacker who can access an affected device over SFTP while it is in a
    vulnerable state could gain root access to the device. This access could
    allow the attacker to compromise the affected system completely.

    Cisco has released software updates that address this vulnerability. There
    are no workarounds that address this vulnerability.

    This advisory is available at the following link:
    https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/
    cisco-sa-20171115-vos

Affected Products

  * Vulnerable Products

    This vulnerability affects the following Cisco Voice Operating System (VOS)
    -based products when they have been upgraded by using the refresh upgrade
    (RU) method or migrated by using the Prime Collaboration Deployment (PCD)
    method:
      + Cisco Unified Communications Manager (UCM)
      + Cisco Unified Communication Manager Session Management Edition (SME)
      + Cisco Emergency Responder
      + Cisco Unity Connection
      + Cisco Unified Communications Manager IM and Presence Service (IM&P;
        earlier releases were known as Cisco Unified Presence)
      + Cisco Prime License Manager
      + Cisco Hosted Collaboration Mediation Fulfillment
      + Cisco Unified Contact Center Express (UCCx)
      + Cisco SocialMiner
      + Cisco Unified Intelligence Center (UIC)
      + Cisco Finesse
      + Cisco MediaSense
    The PCD migration method affects only Cisco UCM, SME, and IM&P.

    Determining the Upgrade or Migration Method

    The Cisco VOS-based products identified in the preceding vulnerable
    products list are affected by this vulnerability if they were refresh
    upgraded or migrated by using the PCD methods. Note that a VOS-based
    product must go through a refresh upgrade if the underlying operating
    system is also being upgraded to a new major release.

    If the VOS-based product was standard upgraded to an Engineering Special,
    service update, or a new major release of the affected product that does
    not require major upgrades to the underlying operating system, this
    vulnerability will be remediated by that standard upgrade action.

    Refresh Upgrade Method Verification

    To verify whether the product has been exposed to the vulnerability by the
    refresh upgrade method, issue the following command at the CLI to view the
    system-history.log file:

        admin: file view install system-history.log


    The following example shows a refresh upgrade entry in the
    system-history.log file:

        02/28/2013 14:56:05 | root: Upgrade (refresh) 10.0.0.97016-27 Success


    The following example shows a standard upgrade entry in the
    system-history.log file:

        10/13/2017 18:56:07 | root: Upgrade 12.0.1.20000-3 Success


    PCD Migration Method Verification

    To verify whether the product has been exposed to this vulnerability by the
    PCD migration method, issue the following command at the CLI to view the
    install.log file:

        admin: file view install install.log


    The following example shows a PCD migration log entry in the install.log
    file:

        10/16/2017 13:59:13 post_install|Starting post_install processing - VOS_INSTALL_CONTEXT = M1|


    The following example shows a normal fresh install log entry in the
    install.log file:

        08/15/2011 08:56:03 post_install|Starting post_install processing - VOS_INSTALL_CONTEXT = install|


    Underlying Operating System Upgraded to a New Major Release

    A VOS-based product will undergo a refresh upgrade if the underlying
    operating system is also upgraded to a new major release.

    The following examples show major operating system releases that are
    associated with major affected product releases:

    +----------------------------------------------------+
    | Cisco UCM, Cisco Unity Connection,  | Operating    |
    | and Cisco Unified Presence Server/  | System Major |
    | Cisco IM&P Major Release            | Release      |
    |-------------------------------------+--------------|
    | 8.6                                 | RHEL 5       |
    |                                     | Update 5     |
    |-------------------------------------+--------------|
    | 9.x                                 | RHEL 5       |
    |                                     | Update 7     |
    |-------------------------------------+--------------|
    | 10.x                                | RHEL 6       |
    |                                     | Update 2     |
    |-------------------------------------+--------------|
    | 11.x                                | RHEL 6       |
    |                                     | Update 5     |
    |-------------------------------------+--------------|
    | 12.x                                | CentOS 6     |
    |                                     | Update 6     |
    +----------------------------------------------------+

    Because an upgrade from RHEL 6 to CentOS 6 is not considered a major
    operating system release change, product updates between these operating
    system releases will use the standard upgrade method.

    Prime Collaboration Deployment Cluster Migration

    Prime Collaboration Deployment is a free application that is designed to
    assist in the management of various Cisco Unified Communications
    applications. The PCD migrate cluster task is supported only for the
    following Cisco products and to only certain cluster migration destination
    versions.
      + UCM destination version 10.x, 11.0(1), 11.5(x), 12.0(1)
      + IM&P destination version 10.x, 11.0(1), 11.5(x), 12.0(1)

    Refer to the product documentation for information about specific upgrade
    and migration methods.

    Determining the Current Software Release for the Cisco Unified Platform

    The following Cisco products run on the Cisco Unified platform:
      + Unified Communications Manager
      + Unified Communications Manager Session Management Edition
      + Emergency Responder
      + Unity Connection
      + Unified Communications Manager IM and Presence Service
      + Prime License Manager
      + Hosted Collaboration Mediation Fulfillment

    To determine which Cisco VOS-based product software release is running on
    the Cisco Unified platform, an administrator can issue the show version
    active command at the CLI.

    In the following example, the software release is 11.5.1.10000-86.

        ciscocm: show version active
        Active Master Version: 11.5.1.10000-86


    An administrator can use the user interface to determine which Cisco
    VOS-based product software release is running:
     1. Log in to the web-based interface
     2. Click the Help menu
     3. Click About to view the system software release


    Determining the Current Software Release for the Cisco Contact Center
    Platform

    The following Cisco products run on the Cisco Contact Center platform:
      + Unified Contact Center Express
      + SocialMiner
      + Unified Intelligence Center
      + Finesse
      + MediaSense

    To determine which Cisco VOS-based product software release is running on
    the Contact Center platform, an administrator can issue the show version
    active command at the CLI.

    In the following example, the software release is 11.5.1.10000-86.

        admin: show version active
        Active Master Version: 11.5.1.10000-86


    An administrator can use the user interface to determine which Cisco
    Contact Center platform-based product software release is running:
     1. Log in to the Contact Center Express server
     2. Go to the Cisco Unified Communications operating system administration
        window
     3. Choose Show > Software


    Products Confirmed Not Vulnerable

    No other Cisco products are currently known to be affected by this
    vulnerability.

    Cisco has confirmed that this vulnerability does not affect the following
    products:
      + Cisco Identity Service (IdS) 11.5 and 11.6
      + Cisco Prime Collaboration Deployment
      + Cisco Prime Collaboration Provisioning
      + Cisco Prime Collaboration Assurance
      + Cisco Virtualized Voice Browser

Workarounds

  * There are no workarounds that address this vulnerability.

Fixed Software

  * Cisco has released free software updates that address the vulnerability
    described in this advisory. Customers may only install and expect support
    for software versions and feature sets for which they have purchased a
    license. By installing, downloading, accessing, or otherwise using such
    software upgrades, customers agree to follow the terms of the Cisco
    software license:
    http://www.cisco.com/en/US/docs/general/warranty/English/EU1KEN_.html
     
    Additionally, customers may only download software for which they have a
    valid license, procured from Cisco directly, or through a Cisco authorized
    reseller or partner. In most cases this will be a maintenance upgrade to
    software that was previously purchased. Free security software updates do
    not entitle customers to a new software license, additional software
    feature sets, or major revision upgrades.

    When considering software upgrades, customers are advised to regularly
    consult the advisories for Cisco products, which are available from the
    Cisco Security Advisories and Alerts page, to determine exposure and a
    complete upgrade solution.

    In all cases, customers should ensure that the devices to be upgraded
    contain sufficient memory and confirm that current hardware and software
    configurations will continue to be supported properly by the new release.
    If the information is not clear, customers are advised to contact the Cisco
    Technical Assistance Center (TAC) or their contracted maintenance
    providers.


    Customers Without Service Contracts

    Customers who purchase directly from Cisco but do not hold a Cisco service
    contract and customers who make purchases through third-party vendors but
    are unsuccessful in obtaining fixed software through their point of sale
    should obtain upgrades by contacting the Cisco TAC:
    http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

    Customers should have the product serial number available and be prepared
    to provide the URL of this advisory as evidence of entitlement to a free
    upgrade.


    Fixed Releases and Software Downloads

    Cisco Unified Communications Manager - Cisco Bug ID CSCvg22923

    Cisco Unified Communications Manager software can be downloaded from the
    Software Center on Cisco.com by navigating to Products > Unified
    Communications > Call Control > Unified Communications Manager
    (CallManager).

    +-----------------------------------------------------+
    | Cisco Unified  | Remediation Solutions for This     |
    | Communications | Advisory                           |
    | Manager Major  |                                    |
    | Release        |                                    |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 8.6            | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |                | perform a service update.          |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 9.0            | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |                | perform a service update.          |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 9.1            | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |                | perform a service update           |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 10.0           | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |                | or perform a service update.       |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 10.5           | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |                | or perform a service update.       |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 11.0           | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |                | or perform a service update.       |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 11.5           | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |                | or perform a service update.       |
    |----------------+------------------------------------|
    | 12.0           | Vulnerable; apply COP file         |
    |                | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    +-----------------------------------------------------+


    Cisco Unified Communications Manager Session Management Edition - Cisco Bug
    ID CSCvg22923

    Cisco Unified Communications Manager Session Management Edition (SME)
    software can be downloaded from the Software Center on Cisco.com by
    navigating to Products > Unified Communications > Call Control > Unified
    Communications Manager Session Management Edition > Unified Communications
    Manager / Cisco Unity Connection Utilities.

    +-----------------------------------------------------+
    | Cisco Unified  | Remediation Solutions for This     |
    | Communications | Advisory                           |
    | Manager SME    |                                    |
    | Major Release  |                                    |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 8.6            | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |                | perform a service update.          |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 9.0            | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |                | perform a service update.          |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 9.1            | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |                | perform a service update.          |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 10.0           | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |                | or perform a service update.       |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 10.5           | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |                | or perform a service update.       |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 11.0           | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |                | or perform a service update.       |
    |----------------+------------------------------------|
    |                | Vulnerable; apply COP file         |
    | 11.5           | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |                | or perform a service update.       |
    |----------------+------------------------------------|
    | 12.0           | Vulnerable; apply COP file         |
    |                | ciscocm.CSCvg22923-v1.0.k3.cop.sgn |
    +-----------------------------------------------------+


    Cisco Emergency Responder - Cisco Bug ID CSCvg55112

    Cisco Emergency Responder software can be downloaded from the Software
    Center on Cisco.com by navigating to Products > Unified Communications >
    Telephony Extensions > Emergency Responder.

    +----------------------------------------------------+
    | Cisco        | Remediation Solutions for This      |
    | Emergency    | Advisory                            |
    | Responder    |                                     |
    | Major        |                                     |
    | Release      |                                     |
    |--------------+-------------------------------------|
    |              | Vulnerable; apply COP file          |
    | 8.6          | ciscocm.CSCvg22923-v1.2.cop.sgn or  |
    |              | perform a service update.           |
    |--------------+-------------------------------------|
    |              | Vulnerable; apply COP file          |
    | 8.7          | ciscocm.CSCvg22923-v1.2.cop.sgn     |
    |              | or perform a service update.        |
    |--------------+-------------------------------------|
    |              | Vulnerable; apply COP file          |
    | 9.0          | ciscocm.CSCvg22923-v1.2.cop.sgn or  |
    |              | perform a service update.           |
    |--------------+-------------------------------------|
    |              | Vulnerable; apply COP file          |
    | 10.0         | ciscocm.CSCvg22923-v1.2.k3.cop.sgn  |
    |              | or perform a service update.        |
    |--------------+-------------------------------------|
    |              | Vulnerable; apply COP file          |
    | 10.5         | ciscocm.CSCvg22923-v1.2.k3.cop.sgn  |
    |              | or perform a service update.        |
    |--------------+-------------------------------------|
    |              | Vulnerable; apply COP file          |
    | 11.0         | ciscocm.CSCvg22923-v1.2.k3.cop.sgn  |
    |              | or perform a service update.        |
    |--------------+-------------------------------------|
    |              | Vulnerable; apply COP file          |
    | 11.5         | ciscocm.CSCvg22923-v1.2.k3.cop.sgn  |
    |              | or perform a service update.        |
    |--------------+-------------------------------------|
    | 12.0         | Vulnerable; apply COP file          |
    |              | ciscocm.CSCvg22923-v1.2.k3.cop.sgn. |
    +----------------------------------------------------+


    Cisco Unity Connection - Cisco Bug ID CSCvg55128

    Cisco Unity Connection software can be downloaded from the Software Center
    on Cisco.com by navigating to Products > Unified Communications > Unified
    Communications Applications > Messaging > Unity Connection.

    +----------------------------------------------------+
    | Cisco Unity   | Remediation Solutions for This     |
    | Connection    | Advisory                           |
    | Major Release |                                    |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 8.6           | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |               | perform a service update.          |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 9.0           | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |               | perform a service update.          |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 9.1           | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |               | perform a service update.          |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 10.0          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 10.5          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 11.0          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 11.5          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 12.0          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    +----------------------------------------------------+


    Cisco Unified Communications Manager IM and Presence Service - Cisco Bug ID
    CSCvg22923

    Cisco Unified Communications Manager IM and Presence Service software can
    be downloaded from the Software Center on Cisco.com by navigating to
    Products > Unified Communications > Unified Communications Applications >
    Presence Software > Unified Communications Manager IM & Presence Service.

    +----------------------------------------------------+
    | Cisco Unified | Remediation Solutions for This     |
    | IM and        | Advisory                           |
    | Presence      |                                    |
    | Service Major |                                    |
    | Release       |                                    |
    |---------------+------------------------------------|
    | 8.6 (Unified  | Vulnerable; apply COP file         |
    | Presence)     | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |               | perform a service update.          |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 9.0           | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |               | perform a service update.          |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 9.1           | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |               | perform a service update.          |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 10.0          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 10.5          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 11.0          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 11.5          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 12.0          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    +----------------------------------------------------+


    Cisco Prime License Manager - Cisco Bug ID CSCvg58619

    Cisco Prime License Manager software can be downloaded from the Software
    Center on Cisco.com by navigating to Products > Unified Communications >
    Unified Communications Management > Prime License Manager > Prime License
    Manager Software Updates.

    +----------------------------------------------------+
    | Cisco Prime   | Remediation Solutions for This     |
    | License       | Advisory                           |
    | Manager Major |                                    |
    | Release       |                                    |
    |---------------+------------------------------------|
    | 9.0           |                                    |
    | (Enterprise   | Not vulnerable                     |
    | License       |                                    |
    | Manager)      |                                    |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 10.0          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 10.5          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 11.0          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 11.5          | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    +----------------------------------------------------+


    Cisco Hosted Collaboration Mediation Fulfillment - Cisco Bug ID CSCvg68797

    Cisco Hosted Collaboration Mediation Fulfillment software can be downloaded
    from the Software Center on Cisco.com by navigating to Products > Unified
    Communications > Call Control > Hosted Collaboration > Hosted Collaboration
    Solution (HCS).

    +----------------------------------------------------+
    | Cisco Hosted  | Remediation Solutions for This     |
    | Collaboration | Advisory                           |
    | Solution      |                                    |
    | Major Release |                                    |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 9.2           | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |               | perform a service update.          |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 9.2(1)        | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |               | perform a service update.          |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 9.2(1)SU1     | ciscocm.CSCvg22923-v1.2.cop.sgn or |
    |               | perform a service update.          |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 10.0(1)       | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 10.1(1)       | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 10.1(2)       | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    |               | Vulnerable; apply COP file         |
    | 10.6(1)       | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    |               | or perform a service update.       |
    |---------------+------------------------------------|
    | 11.5          | Vulnerable; apply COP file         |
    |               | ciscocm.CSCvg22923-v1.2.k3.cop.sgn |
    +----------------------------------------------------+


    Cisco Unified Contact Center Express - Cisco Bug ID CSCvg55145

    Cisco Unified Contact Center Express software can be downloaded from the
    Software Center on Cisco.com by navigating to Products > Customer
    Collaboration > Contact Center Solutions > Unified Contact Center Express.

    +------------------------------------------------------------+
    | Cisco   | Remediation Solutions for This Advisory          |
    | Unified |                                                  |
    | Contact |                                                  |
    | Center  |                                                  |
    | Express |                                                  |
    | Major   |                                                  |
    | Release |                                                  |
    |---------+--------------------------------------------------|
    | 8.5(1)  | Not vulnerable                                   |
    |---------+--------------------------------------------------|
    | 9.0(1)  | Not vulnerable                                   |
    |---------+--------------------------------------------------|
    | 9.0(2)  | Not vulnerable                                   |
    |---------+--------------------------------------------------|
    |         | Vulnerable; apply COP file                       |
    | 10.0(1) | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |         | or perform a service update.                     |
    |---------+--------------------------------------------------|
    |         | Vulnerable; apply COP file                       |
    | 10.5(1) | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |         | or perform a service update.                     |
    |---------+--------------------------------------------------|
    |         | Vulnerable; apply COP file                       |
    | 10.6(1) | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |         | or perform a service update.                     |
    |---------+--------------------------------------------------|
    |         | Vulnerable; apply COP file                       |
    | 11.0(1) | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |         | or perform a service update.                     |
    |---------+--------------------------------------------------|
    |         | Vulnerable; apply COP file                       |
    | 11.5(1) | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |         | or perform a service update.                     |
    |---------+--------------------------------------------------|
    | 11.6(1) | Vulnerable; apply COP file                       |
    |         | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    +------------------------------------------------------------+


    Cisco SocialMiner - Cisco Bug ID CSCvg64453

    Cisco SocialMiner software can be downloaded from the Software Center on
    Cisco.com by navigating to Products > Customer Collaboration > Options for
    Contact Center Solutions > SocialMiner > SocialMiner Software.

    +-------------------------------------------------------------------+
    | Cisco       | Remediation Solutions for This Advisory             |
    | SocialMiner |                                                     |
    | Major       |                                                     |
    | Release     |                                                     |
    |-------------+-----------------------------------------------------|
    | 8.5         | Not vulnerable                                      |
    |-------------+-----------------------------------------------------|
    | 9.0         | Not vulnerable                                      |
    |-------------+-----------------------------------------------------|
    | 10.0        | Not vulnerable                                      |
    |-------------+-----------------------------------------------------|
    | 10.5        | Not vulnerable                                      |
    |-------------+-----------------------------------------------------|
    | 10.6        | Vulnerable; apply COP file                          |
    |             | ciscosm-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |             | or perform a service update.                        |
    |-------------+-----------------------------------------------------|
    | 11.0        | Vulnerable; apply COP file                          |
    |             | ciscosm-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    +-------------------------------------------------------------------+


    Cisco Unified Intelligence Center and Cisco Unified Intelligence Center
    with Live Data - Cisco Bug ID CSCvg64464

    Cisco Unified Intelligence Center software can be downloaded from the
    Software Center on Cisco.com by navigating to Products > Customer
    Collaboration > Options for Contact Center Solutions > Unified Intelligence
    Center > Unified Intelligence Center Software.

    +-----------------------------------------------------------------+
    | Cisco        | Remediation Solutions for This Advisory          |
    | Unified      |                                                  |
    | Intelligence |                                                  |
    | Center Major |                                                  |
    | Release      |                                                  |
    |--------------+--------------------------------------------------|
    | 8.5          | Not vulnerable                                   |
    |--------------+--------------------------------------------------|
    | 9.0          | Not vulnerable                                   |
    |--------------+--------------------------------------------------|
    | 9.1          | Not vulnerable                                   |
    |--------------+--------------------------------------------------|
    | 10.0         | Not vulnerable                                   |
    |--------------+--------------------------------------------------|
    | 10.5         | Not vulnerable                                   |
    |--------------+--------------------------------------------------|
    |              | Vulnerable; apply COP file                       |
    | 11.0         | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |              | or perform a service update.                     |
    |--------------+--------------------------------------------------|
    |              | Vulnerable; apply COP file                       |
    | 11.5         | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |              | or perform a service update.                     |
    |--------------+--------------------------------------------------|
    | 11.6         | Vulnerable; apply COP file                       |
    |              | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    +-----------------------------------------------------------------+


    Cisco Finesse - Cisco Bug ID CSCvg64475

    Cisco Finesse software can be downloaded from the Software Center on
    Cisco.com by navigating to Products > Customer Collaboration > Options for
    Contact Center Solutions > Finesse > Finesse Software.

    +------------------------------------------------------------+
    | Cisco   | Remediation Solutions for This Advisory          |
    | Finesse |                                                  |
    | Major   |                                                  |
    | Release |                                                  |
    |---------+--------------------------------------------------|
    | 8.5     | Not vulnerable                                   |
    |---------+--------------------------------------------------|
    | 9.0     | Not vulnerable                                   |
    |---------+--------------------------------------------------|
    | 10.0    | Not vulnerable                                   |
    |---------+--------------------------------------------------|
    | 10.5    | Not vulnerable                                   |
    |---------+--------------------------------------------------|
    |         | Vulnerable; apply COP file                       |
    | 11.0    | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |         | or perform a service update.                     |
    |---------+--------------------------------------------------|
    |         | Vulnerable; apply COP file                       |
    | 11.5    | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |         | or perform a service update.                     |
    |---------+--------------------------------------------------|
    | 11.6    | Vulnerable; apply COP file                       |
    |         | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    +------------------------------------------------------------+


    Cisco MediaSense - Cisco Bug ID CSCvg64456

    Cisco MediaSense software can be downloaded from the Software Center on
    Cisco.com by navigating to Products > Customer Collaboration > Options for
    Contact Center Solutions > MediaSense > MediaSense Software.

    +---------------------------------------------------------------+
    | Cisco      | Remediation Solutions for This Advisory          |
    | MediaSense |                                                  |
    | Major      |                                                  |
    | Release    |                                                  |
    |------------+--------------------------------------------------|
    | 8.5        | Not vulnerable                                   |
    |------------+--------------------------------------------------|
    | 9.0        | Not vulnerable                                   |
    |------------+--------------------------------------------------|
    | 10.0       | Not vulnerable                                   |
    |------------+--------------------------------------------------|
    | 10.5       | Not vulnerable                                   |
    |------------+--------------------------------------------------|
    |            | Vulnerable; apply COP file                       |
    | 11.0       | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    |            | or perform a service update.                     |
    |------------+--------------------------------------------------|
    | 11.5       | Vulnerable; apply COP file                       |
    |            | ucos-psirt-root-access-CSCvg55145-k3-1.1.cop.sgn |
    +---------------------------------------------------------------+


Exploitation and Public Announcements

  * The Cisco Product Security Incident Response Team (PSIRT) is not aware of
    any public announcements or malicious use of the vulnerability that is
    described in this advisory.

Source

  * Cisco would like to thank Quentin Rhoads-Herrera and Rich Mirch of the
    State Farm Penetration Testing Team for reporting this vulnerability.

URL

  * https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/
    cisco-sa-20171115-vos

- -------------------------------------------------------------------------------

Legal Disclaimer

  * THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND
    OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR
    FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT
    OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES
    THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

    A standalone copy or paraphrase of the text of this document that omits the
    distribution URL is an uncontrolled copy and may lack important information
    or contain factual errors. The information in this document is intended for
    end users of Cisco products.

Cisco Security Vulnerability Policy

  * To learn about Cisco security vulnerability disclosure policies and
    publications, see the Security Vulnerability Policy. This document also
    contains instructions for obtaining fixed software and receiving security
    vulnerability information from Cisco.

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBWg0kZox+lLeg9Ub1AQjOPw/+L/l8s0+skuQmOnh53HtvLDzatN0C63/U
oUgQinCMSiAsNmbUJmTJKs7w4rbqT3kuHwnwRx+n8o7A0GtgYFEstuIsRg3SBJe8
xnUMndKQtDgmyoPsp7u1gj/O70dk4fxusPIW5kxnlO3upN8ZOgun6lLom4ryvoyC
KhHETVzd1ogOBn5B9Q/mJwqwyMO3gJdjSU5PTxBCt1CUci9D00nnw+WSYKakD8YE
knP8OyWWsP4YCngdZdRvrhq6SS7JwmccZwnFrbPYfuru17SNKN+iKUjmPcR4Uz5v
/vrcLUySmzr/tqEuq7+nTJtloP0filTgYG2u+tafv6s9L6Y+zSEdw0u3bzB1jBJS
gVz8zSdK7bDS+Ti+TD4YMG8F5tm4CBrUNGpUbeoQ4aWFn3gqekyQcP/cfvNYEi8U
hKOrlvxR0FVD/T5yklc1UIHO+Xjjc7XWU+DXwkh/9m+rTmhCWD3otX6h07pOUP7S
fbPD29Z4SHnnr1EE23Lj2aeUBwio1I/T04JJUcNj5p9qFGxYEL0iCRzQlf6UjfdS
zRe7jVuwXiPBjjIocIAQXKm/Uo7H1pNy5++OcibOdpHAkLamTLs/W+T6ocSBvJEi
ZayrXE3HAtuwIcpkV1zJCuW4DbKjtgt+po1+KAzULumNCFCqcRpeDFYP1QSpgW8O
Hgg6FiqFiqs=
=U3yL
-----END PGP SIGNATURE-----

« Back to bulletins