ESB-2017.2703.4 - UPDATE [Appliance] F5 products: Multiple vulnerabilities 2018-04-05

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                              ESB-2017.2703.4
    Multiple kernel vulnerabilities have been identified in F5 Products
                               5 April 2018

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           F5 products
Publisher:         F5 Networks
Operating System:  Network Appliance
Impact/Access:     Root Compromise   -- Existing Account      
                   Denial of Service -- Remote/Unauthenticated
                   Reduced Security  -- Existing Account      
Resolution:        Patch/Upgrade
CVE Names:         CVE-2016-8399 CVE-2016-7097 CVE-2016-0774
                   CVE-2015-8104 CVE-2015-7613 CVE-2015-5307
                   CVE-2015-3636 CVE-2015-3339 CVE-2015-2925
                   CVE-2015-2922 CVE-2015-1805 CVE-2011-5321

Reference:         ASB-2017.0032
                   ASB-2016.0089
                   ASB-2016.0074
                   ESB-2015.1497
                   ESB-2015.1440
                   ESB-2015.1137

Original Bulletin: 
   https://support.f5.com/csp/article/K21632201
   https://support.f5.com/csp/article/K51518670
   https://support.f5.com/csp/article/K95345942
   https://support.f5.com/csp/article/K17246
   https://support.f5.com/csp/article/K90230486
   https://support.f5.com/csp/article/K08440897
   https://support.f5.com/csp/article/K31603170
   https://support.f5.com/csp/article/K23030550
   https://support.f5.com/csp/article/K31026324

Comment: This bulletin contains nine (9) F5 Networks security advisories.

Revision History:  April     5 2018: Re-introduced bulletin K23030550
                   April     5 2018: Updated Bulletin K31603170
                   December 22 2017: Updated source text with patched versions
                   October  26 2017: Initial Release

- --------------------------BEGIN INCLUDED TEXT--------------------

K21632201: Linux kernel vulnerability CVE-2011-5321

Security Advisory

Original Publication Date: Apr 08, 2016

Updated Date: Oct 25, 2017

Security Advisory Description

The tty_open function in drivers/tty/tty_io.c in the Linux kernel before 3.1.1
mishandles a driver-lookup failure, which allows local users to cause a denial
of service (NULL pointer dereference and system crash) or possibly have
unspecified other impact via crafted access to a device file under the /dev/pts
directory. (CVE-2011-5321)

Impact

A local, unprivileged user may exploit this vulnerability and create a
situation where the system stops responding.

In the default configuration, only an administrator user has advanced shell
access. If a non-administrator user is given advanced shell access in a
non-default configuration, then the possibility of privilege escalation
increases the exposure of this vulnerability.

Security Advisory Status

F5 Product Development has assigned ID 533413 (BIG-IP), ID 542392 (BIG-IQ), ID
542393 (Enterprise Manager), and INSTALLER-2305 (Traffix SDC) to this
vulnerability, and has evaluated the currently supported releases for potential
vulnerability. Additionally, BIG-IP iHealth may list Heuristic H21632201 on the
Diagnostics > Identified > Low screen.

To determine if your release is known to be vulnerable, the components or
features that are affected by the vulnerability, and for information about
releases or hotfixes that address the vulnerability, refer to the following
table:

+---------------+----------------+-----------------+----------+----------------+
|               |Versions known  |Versions known to|          |Vulnerable      |
|Product        |to be vulnerable|be not vulnerable|Severity  |component or    |
|               |                |                 |          |feature         |
+---------------+----------------+-----------------+----------+----------------+
|               |                |12.1.0 - 13.0.0  |          |                |
|               |12.0.0          |12.0.0 HF1       |          |                |
|               |11.6.0          |11.6.1           |          |                |
|BIG-IP LTM     |11.1.0 - 11.5.4 |11.5.5           |Low       |Kernel          |
|               |HF1             |11.5.4 HF2       |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |12.1.0 - 13.0.0  |          |                |
|               |11.6.0          |12.0.0 HF1       |          |                |
|BIG-IP AAM     |11.4.0 - 11.5.4 |11.6.1           |Low       |Kernel          |
|               |HF1             |11.5.5           |          |                |
|               |                |11.5.4 HF2       |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |12.1.0 - 13.0.0  |          |                |
|               |11.6.0          |12.0.0 HF1       |          |                |
|BIG-IP AFM     |11.3.0 - 11.5.4 |11.6.1           |Low       |Kernel          |
|               |HF1             |11.5.5           |          |                |
|               |                |11.5.4 HF2       |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |12.1.0 - 13.0.0  |          |                |
|               |12.0.0          |12.0.0 HF1       |          |                |
|BIG-IP         |11.6.0          |11.6.1           |Low       |Kernel          |
|Analytics      |11.1.0 - 11.5.4 |11.5.5           |          |                |
|               |HF1             |11.5.4 HF2       |          |                |
|               |                |11.0.0           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |12.1.0 - 13.0.0  |          |                |
|               |12.0.0          |12.0.0 HF1       |          |                |
|               |11.6.0          |11.6.1           |          |                |
|BIG-IP APM     |11.1.0 - 11.5.4 |11.5.5           |Low       |Kernel          |
|               |HF1             |11.5.4 HF2       |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |12.1.0 - 13.0.0  |          |                |
|               |12.0.0          |12.0.0 HF1       |          |                |
|BIG-IP ASM     |11.6.0          |11.6.1           |Low       |Kernel          |
|               |11.1.0 - 11.5.4 |11.5.5           |          |                |
|               |HF1             |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP DNS     |12.0.0          |12.1.0 - 13.0.0  |Low       |Kernel          |
|               |                |12.0.0 HF1       |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP Edge    |11.1.0 - 11.3.0 |11.0.0           |Low       |Kernel          |
|Gateway        |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |11.6.1           |          |                |
|               |11.6.0          |11.5.4 HF2       |          |                |
|BIG-IP GTM     |11.1.0 - 11.5.4 |11.5.5           |Low       |Kernel          |
|               |HF1             |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |12.1.0 - 13.0.0  |          |                |
|               |12.0.0          |12.0.0 HF1       |          |                |
|BIG-IP Link    |11.6.0          |11.6.1           |          |                |
|Controller     |11.1.0 - 11.5.4 |11.5.5           |Low       |Kernel          |
|               |HF1             |11.5.4 HF2       |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |12.1.0 - 13.0.0  |          |                |
|               |11.6.0          |12.0.0 HF1       |          |                |
|BIG-IP PEM     |11.3.0 - 11.5.4 |11.6.1           |Low       |Kernel          |
|               |HF1             |11.5.5           |          |                |
|               |                |11.5.4 HF2       |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP PSM     |11.1.0 - 11.4.1 |11.0.0           |Low       |Kernel          |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP         |11.1.0 - 11.3.0 |11.0.0           |Low       |Kernel          |
|WebAccelerator |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP WOM     |11.1.0 - 11.3.0 |11.0.0           |Low       |Kernel          |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|ARX            |None            |6.0.0 - 6.4.0    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|Enterprise     |3.0.0 - 3.1.1   |None             |Low       |Kernel          |
|Manager        |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|FirePass       |None            |7.0.0            |Not       |None            |
|               |                |6.0.0 - 6.1.0    |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |4.0.0 - 4.5.0   |None             |Low       |Kernel          |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Device  |4.2.0 - 4.5.0   |None             |Low       |Kernel          |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Security|4.0.0 - 4.5.0   |None             |Low       |Kernel          |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ ADC     |4.5.0           |None             |Low       |Kernel          |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ         |                |                 |          |                |
|Centralized    |4.6.0 - 5.1.0   |5.2.0 - 5.3.0    |Low       |Kernel          |
|Management     |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |                |                 |          |                |
|and            |1.0.0           |None             |Low       |Kernel          |
|Orchestration  |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|F5 iWorkflow   |2.0.0 - 2.0.2   |2.1.0 - 2.3.0    |Low       |Kernel          |
+---------------+----------------+-----------------+----------+----------------+
|LineRate       |None            |2.5.0 - 2.6.1    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|F5 WebSafe     |None            |1.0.0            |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|Traffix SDC    |4.0.0 - 4.4.0   |None             |Low       |Kernel          |
|               |3.3.2 - 3.5.1   |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+

Security Advisory Recommended Actions

If you are running a version listed in the Versions known to be vulnerable
column, you can eliminate this vulnerability by upgrading to a version listed
in the Versions known to be not vulnerable column. If the table lists only an
older version than what you are currently running, or does not list a
non-vulnerable version, then no upgrade candidate currently exists.

Mitigation

To mitigate this vulnerability for affected BIG-IP/Enterprise Manager products,
you should limit shell access to only trusted users. For more information about
securing access to BIG-IP/Enterprise Manager systems, refer to K13092: Overview
of securing access to the BIG-IP system.

Supplemental Information

  o K9970: Subscribing to email notifications regarding F5 products
  o K9957: Creating a custom RSS feed to view new and updated documents
  o K4602: Overview of the F5 security vulnerability response policy
  o K4918: Overview of the F5 critical issue hotfix policy
  o K167: Downloading software and firmware from F5
  o K13123: Managing BIG-IP product hotfixes (11.x - 13.x)
  o K10025: Managing BIG-IP product hotfixes (10.x)
  o K9502: BIG-IP hotfix matrix
  o K15106: Managing BIG-IQ product hotfixes
  o K15113: BIG-IQ hotfix matrix

- --------------------------------------------------------------------------------

K51518670: Linux kernel vulnerability CVE-2015-2922

Security Advisory

Original Publication Date: Mar 23, 2016

Updated Date: Oct 25, 2017

Security Advisory Description

The ndisc_router_discovery function in net/ipv6/ndisc.c in the Neighbor
Discovery (ND) protocol implementation in the IPv6 stack in the Linux kernel
before 3.19.6 allows remote attackers to reconfigure a hop-limit setting via a
small hop_limit value in a Router Advertisement (RA) message. (CVE-2015-2922)

Impact

An attacker on a local network can use this flaw to prevent systems on that
network from sending or receiving network packets.

Security Advisory Status

F5 Product Development has assigned ID 533413 (BIG-IP), ID 542392 (BIG-IQ CM),
ID 542392-1 (BIG-IQ), and ID 542393 (Enterprise Manager) to this vulnerability,
and has evaluated the currently supported releases for potential vulnerability.
Additionally, BIG-IP iHealth may list Heuristic H582392 on the Diagnostics >
Identified > Low screen.

To determine if your release is known to be vulnerable, the components or
features that are affected by the vulnerability, and for information about
releases or hotfixes that address the vulnerability, refer to the following
table:

+---------------+----------------+-----------------+----------+----------------+
|               |Versions known  |Versions known to|          |Vulnerable      |
|Product        |to be vulnerable|be not vulnerable|Severity  |component or    |
|               |                |                 |          |feature         |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |12.1.0 - 13.0.0  |          |                |
|BIG-IP LTM     |11.6.0 - 11.6.1 |12.0.0 HF1       |Low       |Linux kernel    |
|               |11.0.0 - 11.5.4 |11.5.5           |          |                |
|               |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |12.1.0 - 13.0.0  |          |                |
|BIG-IP AAM     |11.6.0 - 116.1  |12.0.0 HF1       |Low       |Linux kernel    |
|               |11.4.0 - 11.5.4 |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |12.1.0 - 13.0.0  |          |                |
|BIG-IP AFM     |11.6.0 - 11.6.1 |12.0.0 HF1       |Low       |Linux kernel    |
|               |11.3.0 - 11.5.4 |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP         |12.0.0          |12.1.0 - 13.0.0  |          |                |
|Analytics      |11.6.0 - 11.6.1 |12.0.0 HF1       |Low       |Linux kernel    |
|               |11.0.0 - 11.5.4 |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |12.1.0 - 13.0.0  |          |                |
|BIG-IP APM     |11.6.0 - 11.6.1 |12.0.0 HF1       |Low       |Linux kernel    |
|               |11.0.0 - 11.5.4 |11.5.5           |          |                |
|               |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |12.1.0 - 13.0.0  |          |                |
|BIG-IP ASM     |11.6.0 - 11.6.1 |12.0.0 HF1       |Low       |Linux kernel    |
|               |11.0.0 - 11.5.4 |11.5.5           |          |                |
|               |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP DNS     |12.0.0          |12.1.0 - 13.0.0  |Low       |Linux kernel    |
|               |                |12.0.0 HF1       |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP Edge    |11.0.0 - 11.3.0 |None             |Low       |Linux kernel    |
|Gateway        |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |11.6.0 - 11.6.1 |                 |          |                |
|BIG-IP GTM     |11.0.0 - 11.5.4 |11.5.5           |Low       |Linux kernel    |
|               |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |12.1.0 - 13.0.0  |          |                |
|BIG-IP Link    |11.6.0 - 11.6.1 |12.0.0 HF1       |Low       |Linux kernel    |
|Controller     |11.0.0 - 11.5.4 |11.5.5           |          |                |
|               |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |12.1.0 - 13.0.0  |          |                |
|BIG-IP PEM     |11.6.0 - 11.6.1 |12.0.0 HF1       |Low       |Linux kernel    |
|               |11.3.0 - 11.5.4 |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP PSM     |11.0.0 - 11.4.1 |None             |Low       |Linux kernel    |
|               |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP         |11.0.0 - 11.3.0 |None             |Low       |Linux kernel    |
|WebAccelerator |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP WOM     |11.0.0 - 11.3.0 |None             |Low       |Linux kernel    |
|               |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|ARX            |None            |6.0.0 - 6.4.0    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|Enterprise     |3.0.0 - 3.1.1   |None             |Low       |Linux kernel    |
|Manager        |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|FirePass       |None            |7.0.0            |Not       |None            |
|               |                |6.0.0 - 6.1.0    |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |4.0.0 - 4.5.0   |None             |Low       |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Device  |4.2.0 - 4.5.0   |None             |Low       |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Security|4.0.0 - 4.5.0   |None             |Low       |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ ADC     |4.5.0           |None             |Low       |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ         |                |                 |          |                |
|Centralized    |4.6.0 - 5.1.0   |5.2.0 - 5.3.0    |Low       |Linux kernel    |
|Management     |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |                |                 |          |                |
|and            |1.0.0           |None             |Low       |Linux kernel    |
|Orchestration  |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|F5 iWorkflow   |2.0.0 - 2.0.2   |2.1.0 - 2.3.0    |Low       |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|LineRate       |None            |2.5.0 - 2.6.1    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|F5 WebSafe     |None            |1.0.0            |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|Traffix SDC    |None            |4.0.0 - 4.4.0    |Not       |None            |
|               |                |3.3.2 - 3.5.1    |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+

Security Advisory Recommended Actions

If you are running a version listed in the Versions known to be vulnerable
column, you can eliminate this vulnerability by upgrading to a version listed
in the Versions known to be not vulnerable column. If the table lists only an
older version than what you are currently running, or does not list a
non-vulnerable version, then no upgrade candidate currently exists.

To determine the necessary upgrade path for your BIG-IQ system, you should
understand the BIG-IQ product offering name changes. For more information,
refer to K21232150: Considerations for upgrading BIG-IQ or F5 iWorkflow systems
.

Mitigation

None

Supplemental Information

  o K9970: Subscribing to email notifications regarding F5 products
  o K4602: Overview of the F5 security vulnerability response policy
  o K9957: Creating a custom RSS feed to view new and updated documents
  o K4918: Overview of the F5 critical issue hotfix policy
  o K167: Downloading software and firmware from F5
  o K13123: Managing BIG-IP product hotfixes (11.x - 13.x)
  o K9502: BIG-IP hotfix matrix

- --------------------------------------------------------------------------------

Final - K95345942: Linux kernel vulnerability CVE-2015-3339

Security Advisory

Original Publication Date: Jan 30, 2016

Updated Date: Oct 26, 2017

The security issue described in this article has been resolved or does not
affect any F5 products. There will be no further updates, unless new
information is discovered.

Security Advisory Description

Race condition in the prepare_binprm function in fs/exec.c in the Linux kernel
before 3.19.6 allows local users to gain privileges by executing a setuid
program at a time instant when a chown to root is in progress, and the
ownership is changed but the setuid bit is not yet stripped. (CVE-2015-3339)

Impact

A local user with advanced shell (bash) access on a BIG-IP system, or with
local administrator access on a Traffix system, may be able to use this flaw to
gain elevated privileges. In supported configurations on the BIG-IP system,
advanced shell access is limited to system administrators. BIG-IP appliance
mode does not expose this issue, as users are not allowed advanced shell access
in this mode. On Traffix systems, only administrators have local access.

Security Advisory Status

F5 Product Development has assigned ID 540018 (BIG-IP), ID 569537 (BIG-IQ), and
ID 569538 (Enterprise Manager) to this vulnerability, and has evaluated the
currently supported releases for potential vulnerability. Additionally, BIG-IP
iHealth may list Heuristic H95345942 on the Diagnostics > Identified > Medium
screen.

To determine if your release is known to be vulnerable, the components or
features that are affected by the vulnerability, and for information about
releases or hotfixes that address the vulnerability, refer to the following
table:

+---------------+----------------+-----------------+----------+----------------+
|               |Versions known  |Versions known to|          |Vulnerable      |
|Product        |to be vulnerable|be not vulnerable|Severity  |component or    |
|               |                |                 |          |feature         |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP LTM     |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.0.0 - 11.5.4 |12.0.0 HF3       |          |                |
|               |10.1.0 - 10.2.4 |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP AAM     |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.4.0 - 11.5.4 |12.0.0 HF3       |          |                |
|               |                |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP AFM     |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.3.0 - 11.5.4 |12.0.0 HF3       |          |                |
|               |                |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP         |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|Analytics      |11.0.0 - 11.5.4 |12.0.0 HF3       |          |                |
|               |                |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP APM     |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.0.0 - 11.5.4 |12.0.0 HF3       |          |                |
|               |10.1.0 - 10.2.4 |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP ASM     |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.0.0 - 11.5.4 |12.0.0 HF3       |          |                |
|               |10.1.0 - 10.2.4 |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|BIG-IP DNS     |12.0.0          |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |                |12.0.0 HF3       |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP Edge    |11.0.0 - 11.3.0 |None             |Medium    |Linux kernel    |
|Gateway        |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |11.6.0 - 11.6.1 |                 |          |                |
|BIG-IP GTM     |11.0.0 - 11.5.4 |11.5.5           |Medium    |Linux kernel    |
|               |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP Link    |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|Controller     |11.0.0 - 11.5.4 |12.0.0 HF3       |          |                |
|               |10.1.0 - 10.2.4 |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP PEM     |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.3.0 - 11.5.4 |12.0.0 HF3       |          |                |
|               |                |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP PSM     |11.0.0 - 11.4.1 |None             |Medium    |Linux kernel    |
|               |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP         |11.0.0 - 11.3.0 |None             |Medium    |Linux kernel    |
|WebAccelerator |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP WOM     |11.0.0 - 11.3.0 |None             |Medium    |Linux kernel    |
|               |10.1.0 - 10.2.4 |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|ARX            |None            |6.2.0 - 6.4.0    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|Enterprise     |3.0.0 - 3.1.1   |None             |Medium    |Linux kernel    |
|Manager        |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|FirePass       |None            |7.0.0            |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |4.0.0 - 4.5.0   |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Device  |4.2.0 - 4.5.0   |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Security|4.0.0 - 4.5.0   |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ ADC     |4.5.0           |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ         |                |                 |          |                |
|Centralized    |4.6.0           |None             |Medium    |Linux kernel    |
|Management     |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |                |                 |          |                |
|and            |1.0.0           |None             |Medium    |Linux kernel    |
|Orchestration  |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|LineRate       |None            |2.5.0 - 2.6.1    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|F5 WebSafe     |None            |1.0.0            |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|Traffix SDC    |4.0.0 - 4.4.0   |4.4 CF 9 and     |Medium    |Linux kernel    |
|               |3.3.2 - 3.5.1   |later*           |          |                |
+---------------+----------------+-----------------+----------+----------------+

* Fix is included in the October 2015 security update.

Security Advisory Recommended Actions

If you are running a version listed in the Versions known to be vulnerable
column, you can eliminate this vulnerability by upgrading to a version listed
in the Versions known to be not vulnerable column. If the table lists only an
older version than what you are currently running, or does not list a
non-vulnerable version, then no upgrade candidate currently exists.

To determine the necessary upgrade path for your BIG-IQ system, you should
understand the BIG-IQ product offering name changes. For more information,
refer to K21232150: Considerations for upgrading BIG-IQ or F5 iWorkflow systems
.

Mitigation

BIG-IP

To mitigate this vulnerability, allow only trusted admin users to have access
to Advanced Shell (bash). Appliance mode does not expose this issue, as users
are not allowed Advanced Shell (bash) access in this mode.

Traffix SDC

To mitigate this vulnerability, you can upgrade with the Traffix package for
October 2015 (4.4 CF 9) or later versions, which includes the kernel fix. For
more information, refer to the F5 Traffix representative for your region.

Supplemental Information

  o K9970: Subscribing to email notifications regarding F5 products
  o K9957: Creating a custom RSS feed to view new and updated documents
  o K4918: Overview of the F5 critical issue hotfix policy
  o K4602: Overview of the F5 security vulnerability response policy

- --------------------------------------------------------------------------------

K17246: Linux kernel vulnerability CVE-2015-3636

Security Advisory

Original Publication Date: Sep 09, 2015
Updated Date: Oct 26, 2017

Security Advisory Description

The ping_unhash function in net/ipv4/ping.c in the Linux kernel before 4.0.3
does not initialize a certain list data structure during an unhash operation,
which allows local users to gain privileges or cause a denial of service
(use-after-free and system crash) by leveraging the ability to make a
SOCK_DGRAM socket system call for the IPPROTO_ICMP or IPPROTO_ICMPV6 protocol,
and then making a connect system call after a disconnect. (CVE-2015-3636)

Impact

A locally authenticated user, with a role that allows advanced shell access,
may be able to escalate privileges or cause a denial-of-service (DoS) attack.

Security Advisory Status

F5 Product Development has assigned ID 533413 (BIG-IP), ID 542392 (BIG-IQ), ID
542393 (Enterprise Manager), and ID 461496 (ARX) to this vulnerability, and has
evaluated the currently supported releases for potential vulnerability.
Additionally, BIG-IP iHealth may list Heuristic H542906 on the Diagnostics >
Identified > Medium screen.

To determine if your release is known to be vulnerable, the components or
features that are affected by the vulnerability, and for information about
releases or hotfixes that address the vulnerability, refer to the following
table:

+---------------+----------------+-----------------+----------+----------------+
|               |Versions known  |Versions known to|          |Vulnerable      |
|Product        |to be vulnerable|be not vulnerable|Severity  |component or    |
|               |                |                 |          |feature         |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|               |12.0.0          |12.1.0 - 12.1.2  |          |                |
|BIG-IP LTM     |11.6.0 - 11.6.1 |12.0.0 HF1       |Medium    |Linux kernel    |
|               |11.1.0 - 11.5.4 |11.5.5           |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP AAM     |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.4.0 - 11.5.4 |12.0.0 HF1       |          |                |
|               |                |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP AFM     |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.3.0 - 11.5.4 |12.0.0 HF1       |          |                |
|               |                |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|BIG-IP         |12.0.0          |12.1.0 - 12.1.2  |          |                |
|Analytics      |11.6.0 - 11.6.1 |12.0.0 HF1       |Medium    |Linux kernel    |
|               |11.1.0 - 11.5.4 |11.5.5           |          |                |
|               |                |11.0.0           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|               |12.0.0          |12.1.0 - 12.1.2  |          |                |
|BIG-IP APM     |11.6.0 - 11.6.1 |12.0.0 HF1       |Medium    |Linux kernel    |
|               |11.1.0 - 11.5.4 |11.5.5           |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|               |12.0.0          |12.1.0 - 12.1.2  |          |                |
|BIG-IP ASM     |11.6.0 - 11.6.1 |12.0.0 HF1       |Medium    |Linux kernel    |
|               |11.1.0 - 11.5.4 |11.5.5           |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|BIG-IP DNS     |12.0.0          |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |                |12.0.0 HF1       |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP Edge    |11.1.0 - 11.3.0 |11.0.0           |Medium    |Linux kernel    |
|Gateway        |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |11.6.0 - 11.6.1 |11.5.5           |          |                |
|BIG-IP GTM     |11.1.0 - 11.5.4 |11.0.0           |Medium    |Linux kernel    |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|               |12.0.0          |12.1.0 - 12.1.2  |          |                |
|BIG-IP Link    |11.6.0 - 11.6.1 |12.0.0 HF1       |Medium    |Linux kernel    |
|Controller     |11.1.0 - 11.5.4 |11.5.5           |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0          |13.0.0           |          |                |
|BIG-IP PEM     |11.6.0 - 11.6.1 |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.3.0 - 11.5.4 |12.0.0 HF1       |          |                |
|               |                |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP PSM     |11.1.0 - 11.4.1 |11.0.0           |Medium    |Linux kernel    |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP         |11.1.0 - 11.3.0 |11.0.0           |Medium    |Linux kernel    |
|WebAccelerator |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP WOM     |11.1.0 - 11.3.0 |11.0.0           |Medium    |Linux kernel    |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|ARX            |6.0.0 - 6.4.0   |None             |Low       |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|Enterprise     |3.0.0 - 3.1.1   |None             |Medium    |Linux kernel    |
|Manager        |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|FirePass       |None            |7.0.0            |Not       |None            |
|               |                |6.0.0 - 6.1.0    |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |4.0.0 - 4.5.0   |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Device  |4.2.0 - 4.5.0   |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Security|4.0.0 - 4.5.0   |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ ADC     |4.5.0           |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ         |                |                 |          |                |
|Centralized    |4.6.0 - 5.1.0   |5.2.0 - 5.3.0    |Medium    |Linux kernel    |
|Management     |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |                |                 |          |                |
|and            |1.0.0           |None             |Medium    |Linux kernel    |
|Orchestration  |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|F5 iWorkflow   |2.0.0 - 2.0.2   |2.1.0 - 2.3.0    |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|LineRate       |None            |2.5.0 - 2.6.1    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|F5 WebSafe     |None            |1.0.0            |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|Traffix SDC    |None            |4.0.0 - 4.4.0    |Not       |None            |
|               |                |3.3.2 - 3.5.1    |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+

Security Advisory Recommended Actions

If you are running a version listed in the Versions known to be vulnerable
column, you can eliminate this vulnerability by upgrading to a version listed
in the Versions known to be not vulnerable column. If the table lists only an
older version than what you are currently running, or does not list a
non-vulnerable version, then no upgrade candidate currently exists.

To determine the necessary upgrade path for your BIG-IQ system, you should
understand the BIG-IQ product offering name changes. For more information,
refer to K21232150: Considerations for upgrading BIG-IQ or F5 iWorkflow systems
.

Mitigation

To mitigate this vulnerability, you should only permit management access to F5
products over a secure network, and restrict command line access for the
affected systems to trusted users. For more information, refer to K13309:
Restricting access to the Configuration utility by source IP address (11.x -
13.x) and K13092: Overview of securing access to the BIG-IP system.

Supplemental Information

  o K9970: Subscribing to email notifications regarding F5 products
  o K9957: Creating a custom RSS feed to view new and updated documents
  o K4918: Overview of the F5 critical issue hotfix policy
  o K167: Downloading software and firmware from F5

- --------------------------------------------------------------------------------
K90230486: Linux kernel vulnerability CVE-2015-7613

Security Advisory

Original Publication Date: Dec 04, 2015
Updated Date: Oct 25, 2017

Security Advisory Description

Race condition in the IPC object implementation in the Linux kernel through
4.2.3 allows local users to gain privileges by triggering an ipc_addid call
that leads to uid and gid comparisons against uninitialized data, related to
msg.c, shm.c, and util.c. (CVE-2015-7613)

Impact

Exploitation of this issue requires shell access, and a non-standard and
unsupported configuration (such as modifications to Linux configuration files)
may expose this issue further. F5 does not recommend manually editing Linux
configuration files. There is no remote access vector or data plane exposure.

Security Advisory Status

F5 Product Development has assigned IDs 556740 and 563154 (BIG-IP), IDs 558161
and 565223 (Enterprise Manager), IDs 558159 and 565221 (BIG-IQ), and
INSTALLER-2102 (Traffix SDC) to this vulnerability, and has evaluated the
currently supported releases for potential vulnerability.

To determine if your release is known to be vulnerable, the components or
features that are affected by the vulnerability, and for information about
releases or hotfixes that address the vulnerability, refer to the following
table:

+---------------+----------------+-----------------+----------+----------------+
|               |Versions known  |Versions known to|          |Vulnerable      |
|Product        |to be vulnerable|be not vulnerable|Severity  |component or    |
|               |                |                 |          |feature         |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|               |                |12.1.0 - 12.1.2  |          |                |
|BIG-IP LTM     |12.0.0          |12.0.0 HF3       |Medium    |Linux kernel    |
|               |11.1.0 - 11.6.1 |11.5.5           |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|BIG-IP AAM     |12.0.0          |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.4.0 - 11.6.1 |12.0.0 HF3       |          |                |
|               |                |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|BIG-IP AFM     |12.0.0          |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.3.0 - 11.6.1 |12.0.0 HF3       |          |                |
|               |                |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|BIG-IP         |12.0.0          |12.1.0 - 12.1.2  |          |                |
|Analytics      |11.1.0 - 11.6.1 |12.0.0 HF3       |Medium    |Linux kernel    |
|               |                |11.5.5           |          |                |
|               |                |11.0.0           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|               |                |12.1.0 - 12.1.2  |          |                |
|BIG-IP APM     |12.0.0          |12.0.0 HF3       |Medium    |Linux kernel    |
|               |11.1.0 - 11.6.1 |11.5.5           |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|               |                |12.1.0 - 12.1.2  |          |                |
|BIG-IP ASM     |12.0.0          |12.0.0 HF3       |Medium    |Linux kernel    |
|               |11.1.0 - 11.6.1 |11.5.5           |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|BIG-IP DNS     |12.0.0          |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |                |12.0.0 HF3       |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP Edge    |11.1.0 - 11.3.0 |11.0.0           |Medium    |Linux kernel    |
|Gateway        |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |11.5.5           |          |                |
|BIG-IP GTM     |11.1.0 - 11.6.1 |11.0.0           |Medium    |Linux kernel    |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|               |                |12.1.0 - 12.1.2  |          |                |
|BIG-IP Link    |12.0.0          |12.0.0 HF3       |Medium    |Linux kernel    |
|Controller     |11.1.0 - 11.6.1 |11.5.5           |          |                |
|               |                |11.0.0           |          |                |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |13.0.0           |          |                |
|BIG-IP PEM     |12.0.0          |12.1.0 - 12.1.2  |Medium    |Linux kernel    |
|               |11.3.0 - 11.6.1 |12.0.0 HF3       |          |                |
|               |                |11.5.5           |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP PSM     |11.1.0 - 11.4.1 |11.0.0           |Medium    |Linux kernel    |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP         |11.1.0 - 11.3.0 |11.0.0           |Medium    |Linux kernel    |
|WebAccelerator |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP WOM     |11.1.0 - 11.3.0 |11.0.0           |Medium    |Linux kernel    |
|               |                |10.1.0 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|ARX            |None            |6.0.0 - 6.4.0    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|Enterprise     |3.0.0 - 3.1.1   |None             |Medium    |Linux kernel    |
|Manager        |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|FirePass       |None            |7.0.0            |Not       |None            |
|               |                |6.0.0 - 6.1.0    |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |4.0.0 - 4.5.0   |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Device  |4.2.0 - 4.5.0   |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Security|4.0.0 - 4.5.0   |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ ADC     |4.5.0           |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ         |                |                 |          |                |
|Centralized    |4.6.0           |None             |Medium    |Linux kernel    |
|Management     |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |                |                 |          |                |
|and            |1.0.0           |None             |Medium    |Linux kernel    |
|Orchestration  |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|LineRate       |None            |2.5.0 - 2.6.1    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|F5 WebSafe     |None            |1.0.0            |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|Traffix SDC    |4.0.0 - 4.4.0   |None             |Low       |None            |
|               |3.3.2 - 3.5.1   |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+

Security Advisory Recommended Actions

If you are running a version listed in the Versions known to be vulnerable
column, you can eliminate this vulnerability by upgrading to a version listed
in the Versions known to be not vulnerable column. If the table lists only an
older version than what you are currently running, or does not list a
non-vulnerable version, then no upgrade candidate currently exists.

Mitigation

To mitigate this vulnerability, you can limit access to the Linux shell to
trusted users only.

Supplemental Information

  o K9970: Subscribing to email notifications regarding F5 products
  o K9957: Creating a custom RSS feed to view new and updated documents
  o K4602: Overview of the F5 security vulnerability response policy
  o K4918: Overview of the F5 critical issue hotfix policy
  o K167: Downloading software and firmware from F5


- --------------------------------------------------------------------------------
K08440897: Linux kernel vulnerability CVE-2016-0774

Security Advisory

Original Publication Date: Jul 14, 2016
Updated Date: Oct 24, 2017

Security Advisory Description

The (1) pipe_read and (2) pipe_write implementations in fs/pipe.c in a certain
Linux kernel backport in the linux package before 3.2.73-2+deb7u3 on Debian
wheezy and the kernel package before 3.10.0-229.26.2 on Red Hat Enterprise
Linux (RHEL) 7.1 do not properly consider the side effects of failed
__copy_to_user_inatomic and __copy_from_user_inatomic calls, which allows local
users to cause a denial of service (system crash) or possibly gain privileges
via a crafted application, aka an "I/O vector array overrun." NOTE: this
vulnerability exists because of an incorrect fix for CVE-2015-1805. (
CVE-2016-0774)

Impact

A local unprivileged user may be able to leak kernel memory to user space or
cause a denial of service (DoS).

Security Advisory Status

F5 Product Development has assigned ID 582813 (BIG-IP) and INSTALLER-2520
(Traffix SDC). Additionally, BIG-IP iHealth may list Heuristic H602697 on the
Diagnostics > Identified > Medium screen.

To determine if your release is known to be vulnerable, the components or
features that are affected by the vulnerability, and for information about
releases or hotfixes that address the vulnerability, refer to the following
table:

+---------------+----------------+-----------------+----------+----------------+
|               |Versions known  |Versions known to|          |Vulnerable      |
|Product        |to be vulnerable|be not vulnerable|Severity  |component or    |
|               |                |                 |          |feature         |
+---------------+----------------+-----------------+----------+----------------+
|               |                |12.1.1           |          |                |
|               |12.0.0 - 12.1.0 |11.6.1 HF1       |          |                |
|BIG-IP LTM     |11.6.0 - 11.6.1 |11.4.0 - 11.5.5  |Medium    |Linux kernel    |
|               |                |11.2.1           |          |                |
|               |                |10.2.1 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0 - 12.1.0 |12.1.1           |          |                |
|BIG-IP AAM     |11.6.0 - 11.6.1 |11.6.1 HF1       |Medium    |Linux kernel    |
|               |                |11.4.0 - 11.5.5  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0 - 12.1.0 |12.1.1           |          |                |
|BIG-IP AFM     |11.6.0 - 11.6.1 |11.6.1 HF1       |Medium    |Linux kernel    |
|               |                |11.4.0 - 11.5.5  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP         |12.0.0 - 12.1.0 |12.1.1           |          |                |
|Analytics      |11.6.0 - 11.6.1 |11.6.1 HF1       |Medium    |Linux kernel    |
|               |                |11.2.1 - 11.5.5  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |12.1.1           |          |                |
|               |12.0.0 - 12.1.0 |11.6.1 HF1       |          |                |
|BIG-IP APM     |11.6.0 - 11.6.1 |11.4.0 - 11.5.5  |Medium    |Linux kernel    |
|               |                |11.2.1           |          |                |
|               |                |10.2.1 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |12.1.1           |          |                |
|               |12.0.0 - 12.1.0 |11.6.1 HF1       |          |                |
|BIG-IP ASM     |11.6.0 - 11.6.1 |11.4.0 - 11.5.5  |Medium    |Linux kernel    |
|               |                |11.2.1           |          |                |
|               |                |10.2.1 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP DNS     |12.0.0 - 12.1.0 |12.1.1           |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP Edge    |None            |11.2.1           |Not       |None            |
|Gateway        |                |10.2.1 - 10.2.4  |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |11.6.1 HF1       |          |                |
|BIG-IP GTM     |11.6.0 - 11.6.1 |11.4.0 - 11.5.5  |Medium    |Linux kernel    |
|               |                |11.2.1           |          |                |
|               |                |10.2.1 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |                |12.1.1           |          |                |
|BIG-IP Link    |12.0.0 - 12.1.0 |11.6.1 HF1       |          |                |
|Controller     |11.6.0 - 11.6.1 |11.4.0 - 11.5.5  |Medium    |Linux kernel    |
|               |                |11.2.1           |          |                |
|               |                |10.2.1 - 10.2.4  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|               |12.0.0 - 12.1.0 |12.1.1           |          |                |
|BIG-IP PEM     |11.6.0 - 11.6.1 |11.6.1 HF1       |Medium    |Linux kernel    |
|               |                |11.4.0 - 11.5.5  |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP PSM     |None            |11.4.0 - 11.4.1  |Not       |None            |
|               |                |10.2.1 - 10.2.4  |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP         |None            |11.2.1           |Not       |None            |
|WebAccelerator |                |10.2.1 - 10.2.4  |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IP WOM     |None            |11.2.1           |Not       |None            |
|               |                |10.2.1 - 10.2.4  |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|ARX            |None            |6.2.0 - 6.4.0    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|Enterprise     |None            |3.1.1            |Not       |None            |
|Manager        |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|FirePass       |None            |7.0.0            |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |None            |4.0.0 - 4.5.0    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Device  |None            |4.2.0 - 4.5.0    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Security|None            |4.0.0 - 4.5.0    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ ADC     |None            |4.5.0            |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ         |                |5.0.0            |Not       |                |
|Centralized    |None            |4.6.0            |vulnerable|None            |
|Management     |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|BIG-IQ Cloud   |                |                 |Not       |                |
|and            |None            |1.0.0            |vulnerable|None            |
|Orchestration  |                |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+
|F5 iWorkflow   |None            |2.0.0            |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|LineRate       |None            |2.5.0 - 2.6.1    |Not       |None            |
|               |                |                 |vulnerable|                |
+---------------+----------------+-----------------+----------+----------------+
|F5 MobileSafe  |1.0.0           |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|F5 WebSafe     |1.0.0           |None             |Medium    |Linux kernel    |
+---------------+----------------+-----------------+----------+----------------+
|Traffix SDC    |5.0.0           |None             |Low       |Linux kernel    |
|               |4.0.0 - 4.4.0   |                 |          |                |
+---------------+----------------+-----------------+----------+----------------+

Security Advisory Recommended Actions

If you are running a version listed in the Versions known to be vulnerable 
column, you can eliminate this vulnerability by upgrading to a version listed
in the Versions known to be not vulnerable column. If the table lists only an
older version than what you are currently running, or does not list a
non-vulnerable version, then no upgrade candidate currently exists.

Mitigation

None

Supplemental Information

  o K9970: Subscribing to email notifications regarding F5 products
  o K9957: Creating a custom RSS feed to view new and updated documents
  o K4602: Overview of the F5 security vulnerability response policy
  o K4918: Overview of the F5 critical issue hotfix policy
  o K167: Downloading software and firmware from F5
  o K13123: Managing BIG-IP product hotfixes (11.x - 13.x)


- --------------------------------------------------------------------------------

K31603170:Linux kernel vulnerability CVE-2016-7097

Security Advisory

Original Publication Date: 23 Jun, 2017

Latest   Publication Date: 04 Apr, 2018

Security Advisory Description

The filesystem implementation in the Linux kernel through 4.8.2 preserves the
setgid bit during a setxattr call, which allows local users to gain group
privileges by leveraging the existence of a setgid program with restrictions
on execute permissions. (CVE-2016-7097)

Impact

A local user may be allowed to gain group privileges by way of certain setgid 
applications.


Security Advisory Status

F5 Product Development has assigned IDs 652516 and 651741 (BIG-IP), ID 669855
(BIG-IQ), ID 670353 (F5 iWorkflow), and ID 669854 (Enterprise Manager) to this
vulnerability. Additionally, BIG-IP iHealth may list Heuristic H31603170 on
the Diagnostics > Identified > Medium page.

To determine if your release is known to be vulnerable, the components or
features that are affected by the vulnerability, and for information about
releases or hotfixes that address the vulnerability, refer to the following
table.

+---------------+---------------+-----------------+----------+---------------+
|               |Versions known |Versions known to|          |Vulnerable     |
|Product        |to be          |be not vulnerable|Severity  |component or   |
|               |vulnerable     |                 |          |feature        |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|                 |          |               |
|               |12.0.0 - 12.1.2|12.1.3           |          |               |
|BIG-IP LTM     |11.6.0 - 11.6.1|11.6.2           |Medium    |Kernel         |
|               |11.4.0 - 11.5.4|11.5.5           |          |               |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|12.1.3           |          |               |
|BIG-IP AAM     |12.0.0 - 12.1.2|11.6.2           |Medium    |Kernel         |
|               |11.6.0 - 11.6.1|11.5.5           |          |               |
|               |11.4.0 - 11.5.4|                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|12.1.3           |          |               |
|BIG-IP AFM     |12.0.0 - 12.1.2|11.6.2           |Medium    |Kernel         |
|               |11.6.0 - 11.6.1|11.5.5           |          |               |
|               |11.4.0 - 11.5.4|                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|                 |          |               |
|BIG-IP         |12.0.0 - 12.1.2|12.1.3           |          |               |
|Analytics      |11.6.0 - 11.6.1|11.6.2           |Medium    |Kernel         |
|               |11.4.0 - 11.5.4|11.5.5           |          |               |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|                 |          |               |
|               |12.0.0 - 12.1.2|12.1.3           |          |               |
|BIG-IP APM     |11.6.0 - 11.6.1|11.6.2           |Medium    |Kernel         |
|               |11.4.0 - 11.5.4|11.5.5           |          |               |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|                 |          |               |
|               |12.0.0 - 12.1.2|12.1.3           |          |               |
|BIG-IP ASM     |11.6.0 - 11.6.1|11.6.2           |Medium    |Kernel         |
|               |11.4.0 - 11.5.4|11.5.5           |          |               |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IP DNS     |13.0.0 - 13.1.0|12.1.3           |Medium    |Kernel         |
|               |12.0.0 - 12.1.2|                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IP Edge    |11.2.1         |None             |Medium    |Kernel         |
|Gateway        |               |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |11.6.0 - 11.6.1|11.6.2           |          |               |
|BIG-IP GTM     |11.4.0 - 11.5.4|11.5.5           |Medium    |Kernel         |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|                 |          |               |
|BIG-IP Link    |12.0.0 - 12.1.2|12.1.3           |          |               |
|Controller     |11.6.0 - 11.6.1|11.6.2           |Medium    |Kernel         |
|               |11.4.0 - 11.5.4|11.5.5           |          |               |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|12.1.3           |          |               |
|BIG-IP PEM     |12.0.0 - 12.1.2|11.6.2           |Medium    |Kernel         |
|               |11.6.0 - 11.6.1|11.5.5           |          |               |
|               |11.4.0 - 11.5.4|                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IP PSM     |11.4.0 - 11.4.1|None             |Medium    |Kernel         |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IP         |11.2.1         |None             |Medium    |Kernel         |
|WebAccelerator |               |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|12.1.3           |          |               |
|BIG-IP WebSafe |12.0.0 - 12.1.2|11.6.2           |Medium    |Kernel         |
|               |11.6.0 - 11.6.1|                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|ARX            |None           |6.2.0 - 6.4.0    |Not       |None           |
|               |               |                 |vulnerable|               |
+---------------+---------------+-----------------+----------+---------------+
|Enterprise     |3.1.1          |None             |Medium    |Kernel         |
|Manager        |               |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ Cloud   |4.4.0 - 4.5.0  |None             |Medium    |Kernel         |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ Device  |4.4.0 - 4.5.0  |None             |Medium    |Kernel         |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ Security|4.4.0 - 4.5.0  |None             |Medium    |Kernel         |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ ADC     |4.5.0          |None             |Medium    |Kernel         |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ         |5.0.0 - 5.4.0  |                 |          |               |
|Centralized    |4.6.0          |None             |Medium    |Kernel         |
|Management     |               |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ Cloud   |               |                 |          |               |
|and            |1.0.0          |None             |Medium    |Kernel         |
|Orchestration  |               |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|F5 iWorkflow   |2.0.0 - 2.3.0  |None             |Medium    |Kernel         |
+---------------+---------------+-----------------+----------+---------------+
|LineRate       |None           |2.5.0 - 2.6.2    |Not       |None           |
|               |               |                 |vulnerable|               |
+---------------+---------------+-----------------+----------+---------------+
|Traffix SDC    |5.0.0 - 5.0.0  |5.1.0            |Medium    |Kernel         |
|               |4.4.0          |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+

Security Advisory Recommended Actions

If you are running a version listed in the Versions known to be vulnerable
column, you can eliminate this vulnerability by upgrading to a version listed
in the Versions known to be not vulnerable column. If the table lists only an
older version than what you are currently running, or does not list a
non-vulnerable version, then no upgrade candidate currently exists.

To determine the necessary upgrade path for your BIG-IQ system, you should
understand the BIG-IQ product offering name changes. For more information,
refer to K21232150: Considerations for upgrading BIG-IQ or F5 iWorkflow
systems.

Mitigation

To mitigate this vulnerability, you should permit management access to F5
products only over a secure network and restrict command line access for
affected systems to only trusted users. For more information, refer to K13309:
Restricting access to the Configuration utility by source IP address (11.x -
13.x) and K13092: Overview of securing access to the BIG-IP system.


Supplemental Information

  o K9970: Subscribing to email notifications regarding F5 products
  o K9957: Creating a custom RSS feed to view new and updated documents
  o K4602: Overview of the F5 security vulnerability response policy
  o K4918: Overview of the F5 critical issue hotfix policy
  o K167: Downloading software and firmware from F5

- --------------------------------------------------------------------------------

K23030550:Linux kernel vulnerability CVE-2016-8399

Security Advisory

Original Publication Date: 12 Jul, 2017

Latest   Publication Date: 31 Jan, 2018

Security Advisory Description

An elevation of privilege vulnerability in the kernel networking subsystem
could enable a local malicious application to execute arbitrary code within
the context of the kernel. This issue is rated as Moderate because it first
requires compromising a privileged process and current compiler optimizations
restrict access to the vulnerable code. Product: Android. Versions:
Kernel-3.10, Kernel-3.18. Android ID: A-31349935. (CVE-2016-8399)

Impact

This vulnerability allows unauthorized disclosure of information, unauthorized
modification, and disruption of service.


Security Advisory Status

F5 Product Development has assigned IDs 652516 and 695072 (BIG-IP), ID 669855 
(BIG-IQ), ID 669854 (Enterprise Manager), and ID 673043 (F5 iWorkflow) to this
vulnerability. Additionally, BIG-IP iHealth may list Heuristic H23030550 on
the Diagnostics > Identified > Medium screen.

To determine if your release is known to be vulnerable, the components or
features that are affected by the vulnerability, and for information about
releases or hotfixes that address the vulnerability, refer to the following
table.

+---------------+---------------+-----------------+----------+---------------+
|               |Versions known |Versions known to|          |Vulnerable     |
|Product        |to be          |be not vulnerable|Severity  |component or   |
|               |vulnerable     |                 |          |feature        |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|                 |          |               |
|               |12.0.0 - 12.1.2|12.1.3           |          |               |
|BIG-IP LTM     |11.6.0 - 11.6.1|11.6.2 - 11.6.3  |Medium    |Linux kernel   |
|               |11.4.1 - 11.5.4|11.5.5           |          |               |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|12.1.3           |          |               |
|BIG-IP AAM     |12.0.0 - 12.1.2|11.6.2 - 11.6.3  |Medium    |Linux kernel   |
|               |11.6.0 - 11.6.1|11.5.5           |          |               |
|               |11.4.1 - 11.5.4|                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|12.1.3           |          |               |
|BIG-IP AFM     |12.0.0 - 12.1.2|11.6.2 - 11.6.3  |Medium    |Linux kernel   |
|               |11.6.0 - 11.6.1|11.5.5           |          |               |
|               |11.4.1 - 11.5.4|                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|                 |          |               |
|BIG-IP         |12.0.0 - 12.1.2|12.1.3           |          |               |
|Analytics      |11.6.0 - 11.6.1|11.6.2 - 11.6.3  |Medium    |Linux kernel   |
|               |11.4.1 - 11.5.4|11.5.5           |          |               |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|                 |          |               |
|               |12.0.0 - 12.1.2|12.1.3           |          |               |
|BIG-IP APM     |11.6.0 - 11.6.1|11.6.2 - 11.6.3  |Medium    |Linux kernel   |
|               |11.4.1 - 11.5.4|11.5.5           |          |               |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|12.1.3           |          |               |
|BIG-IP ASM     |12.0.0 - 12.1.2|11.6.2 - 11.6.3  |Medium    |Linux kernel   |
|               |11.4.1 - 11.6.1|11.5.5           |          |               |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IP DNS     |13.0.0 - 13.1.0|12.1.3           |Medium    |Linux kernel   |
|               |12.0.0 - 12.1.2|                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IP Edge    |11.2.1         |None             |Medium    |Linux kernel   |
|Gateway        |               |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |11.6.0 - 11.6.1|11.6.2 - 11.6.3  |          |               |
|BIG-IP GTM     |11.4.1 - 11.5.4|11.5.5           |Medium    |Linux kernel   |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|                 |          |               |
|BIG-IP Link    |12.0.0 - 12.1.2|12.1.3           |          |               |
|Controller     |11.6.0 - 11.6.1|11.6.2 - 11.6.3  |Medium    |Linux kernel   |
|               |11.4.1 - 11.5.4|11.5.5           |          |               |
|               |11.2.1         |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|12.1.3           |          |               |
|BIG-IP PEM     |12.0.0 - 12.1.2|11.6.2 - 11.6.3  |Medium    |Linux kernel   |
|               |11.6.0 - 11.6.1|11.5.5           |          |               |
|               |11.4.1 - 11.5.4|                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IP PSM     |11.4.1 - 11.4.1|None             |Medium    |Linux kernel   |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IP         |11.2.1         |None             |Medium    |Linux kernel   |
|WebAccelerator |               |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|               |13.0.0 - 13.1.0|12.1.3           |          |               |
|BIG-IP WebSafe |12.0.0 - 12.1.2|11.6.2 - 11.6.3  |Medium    |Linux kernel   |
|               |11.6.0 - 11.6.1|                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|ARX            |None           |6.2.0 - 6.4.0    |Not       |None           |
|               |               |                 |vulnerable|               |
+---------------+---------------+-----------------+----------+---------------+
|Enterprise     |3.1.1          |None             |Medium    |Linux kernel   |
|Manager        |               |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ Cloud   |4.4.0 - 4.5.0  |None             |Medium    |Linux kernel   |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ Device  |4.4.0 - 4.5.0  |None             |Medium    |Linux kernel   |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ Security|4.4.0 - 4.5.0  |None             |Medium    |Linux kernel   |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ ADC     |4.5.0          |None             |Medium    |Linux kernel   |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ         |5.0.0 - 5.3.0  |                 |          |               |
|Centralized    |4.6.0          |None             |Medium    |Linux kernel   |
|Management     |               |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|BIG-IQ Cloud   |               |                 |          |               |
|and            |1.0.0          |None             |Medium    |Linux kernel   |
|Orchestration  |               |                 |          |               |
+---------------+---------------+-----------------+----------+---------------+
|F5 iWorkflow   |2.0.0 - 2.3.0  |None             |Medium    |Linux kernel   |
+---------------+---------------+-----------------+----------+---------------+
|LineRate       |None           |2.5.0 - 2.6.2    |Not       |None           |
|               |               |                 |vulnerable|               |
+---------------+---------------+-----------------+----------+---------------+
|Traffix SDC    |None           |5.0.0 - 5.1.0    |Not       |None           |
|               |               |4.0.0 - 4.4.0    |vulnerable|               |
+---------------+---------------+-----------------+----------+---------------+

Security Advisory Recommended Actions

If you are running a version listed in the Versions known to be vulnerable
column, you can eliminate this vulnerability by upgrading to a version listed
in the Versions known to be not vulnerable column. If the table lists only an
older version than what you are currently running, or does not list a
non-vulnerable version, then no upgrade candidate currently exists.

To determine the necessary upgrade path for your BIG-IQ system, you should
understand the BIG-IQ product offering name changes. For more information,
refer to K21232150: Considerations for upgrading BIG-IQ or F5 iWorkflow
systems.

Mitigation

None


Supplemental Information

  o K9970: Subscribing to email notifications regarding F5 products
  o K9957: Creating a custom RSS feed to view new and updated documents
  o K4602: Overview of the F5 security vulnerability response policy
  o K4918: Overview of the F5 critical issue hotfix policy
  o K167: Downloading software and firmware from F5

- --------------------------------------------------------------------------------

K39428424: SQL injection vulnerability CVE-2017-0304

Security Advisory

Original Publication Date: Dec 20, 2017
Updated Date: Dec 21, 2017

Security Advisory Description

The SQL injection vulnerability in the Configuration utility is related to the
BIG-IP AFM system. (CVE-2017-0304 )

Impact

An attacker can exploit this vulnerability regardless of the BIG-IP AFM
provisioning configuration; however, exploiting this vulnerability does not
impact traffic processing or the live firewall rules used in the Traffic
Management Microkernel (TMM). The impacts are as follows:

  * If the BIG-IP AFM system is or has been provisioned, a copy of the
    configured firewall rules may be tampered with and impact the BIG-IP AFM
    Configuration utility until the rules are resynchronized.
  * If the BIG-IP AFM system is not or has never been provisioned, there is no
    impact.

Security Advisory Status

F5 Product Development has assigned ID 639729 (BIG-IP) to this vulnerability.

To determine if your product and version have been evaluated for this
vulnerability, refer to the Applies to (see versions) box. To determine if your
release is known to be vulnerable, the components or features that are affected
by the vulnerability, and for information about releases or hotfixes that
address the vulnerability, refer to the following table.

+-----------------------------------------------------------------------------+
|               |      |Versions  |Fixes     |           |CVSSv3|Vulnerable   |
|Product        |Branch|known to  |introduced|Severity   |score^|component or |
|               |      |be        |in        |           |1     |feature      |
|               |      |vulnerable|          |           |      |             |
|---------------+------+----------+----------+-----------+------+-------------|
|               |13.x  |13.0.0    |13.1.0    |           |      |             |
|               |      |          |13.0.0 HF1|           |      |             |
|               |------+----------+----------|           |      |             |
|BIG-IP (AFM)   |12.x  |12.0.0 -  |12.1.3    |Medium     |5.4   |Configuration|
|               |      |12.1.2    |          |           |      |utility      |
|               |------+----------+----------|           |      |             |
|               |11.x  |None      |Not       |           |      |             |
|               |      |          |applicable|           |      |             |
|---------------+------+----------+----------+-----------+------+-------------|
|               |      |          |Not       |           |      |             |
|BIG-IP (LTM,   |13.x  |None      |applicable|           |      |             |
|AAM, Analytics,|      |          |          |           |      |             |
|APM, ASM, DNS, |------+----------+----------|           |      |             |
|Edge Gateway,  |      |          |Not       |Not        |      |             |
|GTM, Link      |12.x  |None      |applicable|vulnerable^|None  |None         |
|Controller,    |      |          |          |2          |      |             |
|PEM, PSM,      |------+----------+----------|           |      |             |
|WebAccelerator,|      |          |Not       |           |      |             |
|WebSafe)       |11.x  |None      |applicable|           |      |             |
|               |      |          |          |           |      |             |
|---------------+------+----------+----------+-----------+------+-------------|
|ARX            |6.x   |None      |Not       |Not        |None  |None         |
|               |      |          |applicable|vulnerable |      |             |
|---------------+------+----------+----------+-----------+------+-------------|
|Enterprise     |3.x   |None      |Not       |Not        |None  |None         |
|Manager        |      |          |applicable|vulnerable |      |             |
|---------------+------+----------+----------+-----------+------+-------------|
|BIG-IQ (Cloud, |      |          |Not       |Not        |      |             |
|Device,        |4.x   |None      |applicable|vulnerable |None  |None         |
|Security, ADC) |      |          |          |           |      |             |
|---------------+------+----------+----------+-----------+------+-------------|
|               |5.x   |None      |Not       |           |      |             |
|BIG-IQ         |      |          |applicable|Not        |      |             |
|Centralized    |------+----------+----------|vulnerable |None  |None         |
|Management     |4.x   |None      |Not       |           |      |             |
|               |      |          |applicable|           |      |             |
|---------------+------+----------+----------+-----------+------+-------------|
|BIG-IQ Cloud   |      |          |Not       |Not        |      |             |
|and            |1.x   |None      |applicable|vulnerable |None  |None         |
|Orchestration  |      |          |          |           |      |             |
|---------------+------+----------+----------+-----------+------+-------------|
|F5 iWorkflow   |2.x   |None      |Not       |Not        |None  |None         |
|               |      |          |applicable|vulnerable |      |             |
|---------------+------+----------+----------+-----------+------+-------------|
|LineRate       |2.x   |None      |Not       |Not        |None  |None         |
|               |      |          |applicable|vulnerable |      |             |
|---------------+------+----------+----------+-----------+------+-------------|
|               |5.x   |None      |Not       |           |      |             |
|               |      |          |applicable|Not        |      |             |
|Traffix SDC    |------+----------+----------|vulnerable |None  |None         |
|               |4.x   |None      |Not       |           |      |             |
|               |      |          |applicable|           |      |             |
+-----------------------------------------------------------------------------+

^1The CVSSv3 score link takes you to a resource outside of AskF5, and it is
possible that the document may be removed without our knowledge.

^2 The specified products contain the affected code. However, F5 identifies the
vulnerability status as Not vulnerable because the attacker cannot exploit the
code in default, standard, or recommended configurations.

Security Advisory Recommended Actions

If you are running a version listed in the Versions known to be vulnerable
column, you can eliminate this vulnerability by upgrading to a version listed
in the Fixes introduced in column. If the table lists only an older version
than what you are currently running, or does not list a non-vulnerable version,
then no upgrade candidate currently exists.

Note: For details about how Security Advisory articles are versioned, and what
versions are listed in the table, refer to K51812227: Understanding Security
Advisory versioning.

Mitigation

To mitigate this vulnerability, you should allow access to the BIG-IP AFM
system to only trusted users. For more information, refer to K13309:
Restricting access to the Configuration utility by source IP address (11.x -
13.x) and K13092: Overview of securing access to the BIG-IP system.

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBWsVtp4x+lLeg9Ub1AQgjNRAAgFEvqNXY6XJLZdK3ZxDckc1cw8BMXQEr
XaX/AelOVWTKr2qy9uxjRUZgkTHrCH9VSq2Q0fZOc9K2DbmDomoKU4igONsKBII7
vDRzsHoW41hK/yd678SEOO1cYojvmuB1LB7Lk3aimPbXumdT0eb7bPSISWyz5af0
GX9yFIivLa9j2OADC1FQJk6tT97cM4rWH/P1qvCdhDbUK+eFpydIfyrjMsMwQfr5
4CqJnhD3XeYLqz4wqzywf/sH/EwB8mgZlNE7QpsTDCIST8ZimzEtAvRImWfh68MF
Ha0NN7DZWLgtvwExEDpxauqH6Nlw6wRwnZRmhoGOjmvtShdenJHNMgEtfRZC5ak/
BG1eHXqA7btZnYquJ7taOgfzPZs4Ks/sB0/0Fpr02di0VNy9/ks0J9j61NqzdU5t
gI6WX/39eGLUo9OpNXRe2dFf2jII38/zSWMIKYVwzS0eKEkg388rG3BjpZ3sL9Co
qsZBaJbv8KTTOO3TaRE9UkJZWshMAJLTO7Xu0CAegyOP/o35Iqv0M3aRtNIMznXX
ieIDWxTkBJtjD9rHc6PHIDq7h+dRnR0OiBl/B1rpmnKtn86BtuKfKP4C8nc6ZhX6
rsn8qF7ar3E2MpVtlXhliSQ+EbR6n3jds5z9rCXoMdKwJsG3m7Pc//p4pGKS3Aol
e7YqaIIVSME=
=YNfL
-----END PGP SIGNATURE-----

« Back to bulletins