ESB-2017.2161 - [SUSE] java-1_7_1-ibm: Multiple vulnerabilities 2017-08-30

Printable version
PGP/GPG verifiable version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2017.2161
         SUSE Security Update: Security updates for java-1_7_1-ibm
                              30 August 2017

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:          java-1_7_1-ibm
Publisher:        SUSE
Operating System: SUSE
Impact/Access:    Execute Arbitrary Code/Commands -- Remote/Unauthenticated      
                  Access Privileged Data          -- Remote with User Interaction
                  Modify Arbitrary Files          -- Remote with User Interaction
                  Delete Arbitrary Files          -- Remote with User Interaction
                  Denial of Service               -- Remote/Unauthenticated      
                  Access Confidential Data        -- Remote/Unauthenticated      
                  Reduced Security                -- Remote/Unauthenticated      
Resolution:       Patch/Upgrade
CVE Names:        CVE-2017-10243 CVE-2017-10125 CVE-2017-10116
                  CVE-2017-10115 CVE-2017-10111 CVE-2017-10110
                  CVE-2017-10109 CVE-2017-10108 CVE-2017-10107
                  CVE-2017-10105 CVE-2017-10102 CVE-2017-10101
                  CVE-2017-10096 CVE-2017-10090 CVE-2017-10089
                  CVE-2017-10087 CVE-2017-10081 CVE-2017-10074
                  CVE-2017-10067 CVE-2017-10053 

Reference:        ESB-2017.2144
                  ESB-2017.2046
                  ESB-2017.1826

Comment: This bulletin contains two (2) SUSE security advisories.

- --------------------------BEGIN INCLUDED TEXT--------------------

   SUSE Security Update: Security update for java-1_7_1-ibm
______________________________________________________________________________

Announcement ID:    SUSE-SU-2017:2280-1
Rating:             important
References:         #1053431 
Cross-References:   CVE-2017-10053 CVE-2017-10067 CVE-2017-10074
                    CVE-2017-10081 CVE-2017-10087 CVE-2017-10089
                    CVE-2017-10090 CVE-2017-10096 CVE-2017-10101
                    CVE-2017-10102 CVE-2017-10105 CVE-2017-10107
                    CVE-2017-10108 CVE-2017-10109 CVE-2017-10110
                    CVE-2017-10111 CVE-2017-10115 CVE-2017-10116
                    CVE-2017-10125 CVE-2017-10243
Affected Products:
                    SUSE OpenStack Cloud 6
                    SUSE Linux Enterprise Software Development Kit 12-SP3
                    SUSE Linux Enterprise Software Development Kit 12-SP2
                    SUSE Linux Enterprise Server for SAP 12-SP1
                    SUSE Linux Enterprise Server for SAP 12
                    SUSE Linux Enterprise Server 12-SP3
                    SUSE Linux Enterprise Server 12-SP2
                    SUSE Linux Enterprise Server 12-SP1-LTSS
                    SUSE Linux Enterprise Server 12-LTSS
______________________________________________________________________________

   An update that fixes 20 vulnerabilities is now available.

Description:

   This update for java-1_7_1-ibm fixes the following issues:

   - Version update to 7.1-4.10 [bsc#1053431]
     * CVE-2017-10111 CVE-2017-10110 CVE-2017-10107 CVE-2017-10101
       CVE-2017-10096 CVE-2017-10090 CVE-2017-10089 CVE-2017-10087
       CVE-2017-10102 CVE-2017-10116 CVE-2017-10074 CVE-2017-10115
       CVE-2017-10067 CVE-2017-10125 CVE-2017-10243 CVE-2017-10109
       CVE-2017-10108 CVE-2017-10053 CVE-2017-10105 CVE-2017-10081: Multiple
       unspecified vulnerabilities in multiple Java components could lead to
       code execution or sandbox escape

    More information can be found here:
   https://developer.ibm.com/javasdk/support/security-vulnerabilities/#Oracle_
   July_18_2017_CPU


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud 6:

      zypper in -t patch SUSE-OpenStack-Cloud-6-2017-1395=1

   - SUSE Linux Enterprise Software Development Kit 12-SP3:

      zypper in -t patch SUSE-SLE-SDK-12-SP3-2017-1395=1

   - SUSE Linux Enterprise Software Development Kit 12-SP2:

      zypper in -t patch SUSE-SLE-SDK-12-SP2-2017-1395=1

   - SUSE Linux Enterprise Server for SAP 12-SP1:

      zypper in -t patch SUSE-SLE-SAP-12-SP1-2017-1395=1

   - SUSE Linux Enterprise Server for SAP 12:

      zypper in -t patch SUSE-SLE-SAP-12-2017-1395=1

   - SUSE Linux Enterprise Server 12-SP3:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-2017-1395=1

   - SUSE Linux Enterprise Server 12-SP2:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-1395=1

   - SUSE Linux Enterprise Server 12-SP1-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2017-1395=1

   - SUSE Linux Enterprise Server 12-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-2017-1395=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE OpenStack Cloud 6 (x86_64):

      java-1_7_1-ibm-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-alsa-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-devel-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-jdbc-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-plugin-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Software Development Kit 12-SP3 (ppc64le s390x x86_64):

      java-1_7_1-ibm-devel-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Software Development Kit 12-SP2 (ppc64le s390x x86_64):

      java-1_7_1-ibm-devel-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server for SAP 12-SP1 (ppc64le x86_64):

      java-1_7_1-ibm-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-devel-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-jdbc-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server for SAP 12-SP1 (x86_64):

      java-1_7_1-ibm-alsa-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-plugin-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server for SAP 12 (x86_64):

      java-1_7_1-ibm-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-alsa-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-devel-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-jdbc-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-plugin-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server 12-SP3 (ppc64le s390x x86_64):

      java-1_7_1-ibm-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-jdbc-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server 12-SP3 (x86_64):

      java-1_7_1-ibm-alsa-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-plugin-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server 12-SP2 (ppc64le s390x x86_64):

      java-1_7_1-ibm-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-jdbc-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server 12-SP2 (x86_64):

      java-1_7_1-ibm-alsa-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-plugin-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (ppc64le s390x x86_64):

      java-1_7_1-ibm-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-devel-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-jdbc-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server 12-SP1-LTSS (x86_64):

      java-1_7_1-ibm-alsa-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-plugin-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server 12-LTSS (ppc64le s390x x86_64):

      java-1_7_1-ibm-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-devel-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-jdbc-1.7.1_sr4.10-38.5.1

   - SUSE Linux Enterprise Server 12-LTSS (x86_64):

      java-1_7_1-ibm-alsa-1.7.1_sr4.10-38.5.1
      java-1_7_1-ibm-plugin-1.7.1_sr4.10-38.5.1


References:

   https://www.suse.com/security/cve/CVE-2017-10053.html
   https://www.suse.com/security/cve/CVE-2017-10067.html
   https://www.suse.com/security/cve/CVE-2017-10074.html
   https://www.suse.com/security/cve/CVE-2017-10081.html
   https://www.suse.com/security/cve/CVE-2017-10087.html
   https://www.suse.com/security/cve/CVE-2017-10089.html
   https://www.suse.com/security/cve/CVE-2017-10090.html
   https://www.suse.com/security/cve/CVE-2017-10096.html
   https://www.suse.com/security/cve/CVE-2017-10101.html
   https://www.suse.com/security/cve/CVE-2017-10102.html
   https://www.suse.com/security/cve/CVE-2017-10105.html
   https://www.suse.com/security/cve/CVE-2017-10107.html
   https://www.suse.com/security/cve/CVE-2017-10108.html
   https://www.suse.com/security/cve/CVE-2017-10109.html
   https://www.suse.com/security/cve/CVE-2017-10110.html
   https://www.suse.com/security/cve/CVE-2017-10111.html
   https://www.suse.com/security/cve/CVE-2017-10115.html
   https://www.suse.com/security/cve/CVE-2017-10116.html
   https://www.suse.com/security/cve/CVE-2017-10125.html
   https://www.suse.com/security/cve/CVE-2017-10243.html
   https://bugzilla.suse.com/1053431

- ---

   SUSE Security Update: Security update for java-1_7_1-ibm
______________________________________________________________________________

Announcement ID:    SUSE-SU-2017:2281-1
Rating:             important
References:         #1053431 
Cross-References:   CVE-2017-10053 CVE-2017-10067 CVE-2017-10074
                    CVE-2017-10081 CVE-2017-10087 CVE-2017-10089
                    CVE-2017-10090 CVE-2017-10096 CVE-2017-10101
                    CVE-2017-10102 CVE-2017-10105 CVE-2017-10107
                    CVE-2017-10108 CVE-2017-10109 CVE-2017-10110
                    CVE-2017-10111 CVE-2017-10115 CVE-2017-10116
                    CVE-2017-10125 CVE-2017-10243
Affected Products:
                    SUSE Linux Enterprise Software Development Kit 11-SP4
                    SUSE Linux Enterprise Server 11-SP4
______________________________________________________________________________

   An update that fixes 20 vulnerabilities is now available.

Description:

   This update for java-1_7_1-ibm fixes the following issues:

   - Version update to 7.1-4.10 [bsc#1053431]
     * CVE-2017-10111 CVE-2017-10110 CVE-2017-10107 CVE-2017-10101
       CVE-2017-10096 CVE-2017-10090 CVE-2017-10089 CVE-2017-10087
       CVE-2017-10102 CVE-2017-10116 CVE-2017-10074 CVE-2017-10115
       CVE-2017-10067 CVE-2017-10125 CVE-2017-10243 CVE-2017-10109
       CVE-2017-10108 CVE-2017-10053 CVE-2017-10105 CVE-2017-10081: Multiple
       unspecified vulnerabilities in multiple Java components could lead to
       code execution or sandbox escape

    More information can be found here:
   https://developer.ibm.com/javasdk/support/security-vulnerabilities/#Oracle_
   July_18_2017_CPU


Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Software Development Kit 11-SP4:

      zypper in -t patch sdksp4-java-1_7_1-ibm-13248=1

   - SUSE Linux Enterprise Server 11-SP4:

      zypper in -t patch slessp4-java-1_7_1-ibm-13248=1

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 ppc64 s390x x86_64):

      java-1_7_1-ibm-devel-1.7.1_sr4.10-26.5.1

   - SUSE Linux Enterprise Server 11-SP4 (i586 ppc64 s390x x86_64):

      java-1_7_1-ibm-1.7.1_sr4.10-26.5.1
      java-1_7_1-ibm-jdbc-1.7.1_sr4.10-26.5.1

   - SUSE Linux Enterprise Server 11-SP4 (i586 x86_64):

      java-1_7_1-ibm-alsa-1.7.1_sr4.10-26.5.1
      java-1_7_1-ibm-plugin-1.7.1_sr4.10-26.5.1


References:

   https://www.suse.com/security/cve/CVE-2017-10053.html
   https://www.suse.com/security/cve/CVE-2017-10067.html
   https://www.suse.com/security/cve/CVE-2017-10074.html
   https://www.suse.com/security/cve/CVE-2017-10081.html
   https://www.suse.com/security/cve/CVE-2017-10087.html
   https://www.suse.com/security/cve/CVE-2017-10089.html
   https://www.suse.com/security/cve/CVE-2017-10090.html
   https://www.suse.com/security/cve/CVE-2017-10096.html
   https://www.suse.com/security/cve/CVE-2017-10101.html
   https://www.suse.com/security/cve/CVE-2017-10102.html
   https://www.suse.com/security/cve/CVE-2017-10105.html
   https://www.suse.com/security/cve/CVE-2017-10107.html
   https://www.suse.com/security/cve/CVE-2017-10108.html
   https://www.suse.com/security/cve/CVE-2017-10109.html
   https://www.suse.com/security/cve/CVE-2017-10110.html
   https://www.suse.com/security/cve/CVE-2017-10111.html
   https://www.suse.com/security/cve/CVE-2017-10115.html
   https://www.suse.com/security/cve/CVE-2017-10116.html
   https://www.suse.com/security/cve/CVE-2017-10125.html
   https://www.suse.com/security/cve/CVE-2017-10243.html
   https://bugzilla.suse.com/1053431

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        http://www.auscert.org.au/render.html?cid=1980

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBWaYjwox+lLeg9Ub1AQibQA/+PnosQ3RsiqBytruOXUzy7En24K7wMUta
xV/ljd7Rj2gRDOb4yM55XuVQYk0l/ENPY6Kxsx4FP9/k5bJlKFclKsxP0gLesYdM
+ELeHLW0uzXMClANhK0jUQFWseBsXbaw+nH6V7OzZjMiIVQ2ntfvRr4QIQoM4y2V
YF9fCtwUaC4PtyDy/IvXYpXtawV4gMFV+9NLGy8QFg+2aWV/SuPQItuayYSC6d6k
/d84LdwgndTANgPxgd8T8sBzmozu8kiVtr6juOz7mePoHAHcwmP6dOkR8ptSCYPw
pbpEc4Aht3VSdXBiIjYAMT2sLcZ440PgqJjiL1C4oa1/76+laScIyMqGqf4cjJA+
pYI6FuBmY8P1FdMF0QHGEpX/AU36EzOZALAVkMUl06Qdv3kQqb0BBKFwRP+QlJLT
11gelYvOcJGz0yTwjV6vEBOdL7wqPI8XvJVDcPISJMIoaTvb5LQmXXNorgSbvf3A
O1Dm1spdtpLu2NJ6JnRkE+SPxHS/0ZtjHENsT7phqdwAYxkF8acpBFmlx3JoHbgQ
9ROg9ClmSGhMSCf1AqV5ge4hF2OHcN8J+i03NtPM9vK5Lv1sJpNzKeRaeop4t5pN
mBiwdHHki1LpJhvtEL2N6s3kvjtVWfk8xFXkM7XE1iH0gFP9VTx92fZdENXcYKyN
HD4edkufSNY=
=izB9
-----END PGP SIGNATURE-----

« Back to bulletins